View Full Version : Solved Beta thread title translation issue

Simon Lloyd
18-10-11, 19:34
Hi all, i'm using the beta and find that threa titles don't seem to be transalting everywhere take a look here The Code Cage Forums (http://www.thecodecage.com/forumz/search.php?searchid=52276) (vBET staff have login details) the title shown as "redondeo al restar" the thread is here Redondeo al restar (http://www.thecodecage.com/forumz/microsoft-excel-miscellaneous/211614-redondeo-al-restar.html) and in the actual thread the title is translated, in the thread forum it WAS translated but when i accessed the thread later none of it is translated??? i have cache cleaner turned off (according toyour settings). I have noticed that my cache and usage doesn't seem to be growing since i turned cache cleaning off.

Can someone help?, i've already spent $200 using Google V2 API and i want to ensure i keep ALL translated results.

18-10-11, 20:09
Hi. When I fallow your first link I see:

Sorry - no matches. Please try some different terms.
Please provide example which we can check - please tell what search criteria should be used.

Please note that turning off cache cleaning do not turn of cache usage. Please make sure that you have turned on cache for all languages.

If you was checking it as guest then it could be caused by Guest Cache (it was translated during search, but guest cache still had version generated when provider was not available).

18-10-11, 20:13
First please tell if you are using all Api, i.e. if you reach your limits in all translation providers, the data will stay untranslated until translation will be available again.
Please also check your ttl for cache, if you are not using Google API v1 you can even turn it off(0 = disable)! So cache won't be deleted

admincp -> vBET Cache -> Database Cache -> Cache Time To Live (TTL)
Moreover I can see that your translation didn't work at all, please check if you reach your limits by using those tests http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-2.html#post1728
Also make sure if you have upload all needed files (also this from upload once folder)
Meanwhile i will try to reproduce with "dissaperaing" translations

Simon Lloyd
18-10-11, 20:39
Hey guy's the firts link has expired as it's for "New posts of members" but the second has not, Michael you have admin access (remember i pm'd you) could you check my settings for vBET? i'm sure they are correct.

@r.dziadusz i am using Google V2 API but Micheal can check my settings so i get the best of all worlds. I visited that thread and it WAS translated from spanish to english, when i revisited it was NOT translated, surely if it was translated once for me then it should always be translated? I DO have all files uploaded, again Michael has ftp access and can check this :)

19-10-11, 16:18
Hi. I just went to Your admin CP to check vBET configuration as you asked, but the account you created has not enough privileges. I'm not able to see vBET options I only see vBET menus.

About the 2nd link - which translation should I use to see the issue? Also I need Admin CP access so I will be able to check does translation providers are available when I will check it.

Simon Lloyd
19-10-11, 19:48
Michael, sorry about the permissions :) they are all set now! this thread Round to subtract / Redondeo al restar (http://www.thecodecage.com/forumz/microsoft-excel-miscellaneous/211614-redondeo-al-restar.html) was translated from spanish to english for me but when i revisted it the thread was back in spanish - the translation had gone? - so i guess check it out in english ;)

20-10-11, 12:30
I'm going there now. Sorry for delay - yesterday we had new release.

Simon Lloyd
20-10-11, 12:40
don't worry Michael, i know you are busy!

20-10-11, 12:48
Hi I just checked it and it is OK. This is what I did.
1. I went to the page with issue and made sure I know what we are talking about (indeed Spanish was not translated)
2. I went to Admin CP and check settings (I turned on cache for all tables - you had some disabled)
3. I checked there providers availability - all was disabled at the moment
4. I enabled Microsoft Translation API hoping that limit is available again
5. I refreshed the page and saw that translations are working - Spanish was translated
6. I disabled Microsoft manually to be sure that another translation request will not be send
7. I refreshed the page and saw that translations are still available what means that those had to be taken from cache (all providers was disabled)

So it is OK now. I do not know what exactly happen before. Maybe the post was edited (new text = new translation) - cannot say I see that it was edited by you (added manual translation) so I do not know does the Spanish test was also edited.
Another scenario is that it could be only partly translated - so few lines was translated and then limit was reached. In such case it didn't went to cache (otherwise cache would be broken, because only part was translated). So when you came again you had already reached limit and no partly translated results cached.
Anyway if you find it happens again please let us know and do not change anything there - maybe we will got another clue.

You can remove manual translation - it is not needed anymore.
Also - please update to last release - it is optimized for providers queue (those will be available more) and caches results for RSS translations.

Do you need more help here? :)

Simon Lloyd
20-10-11, 14:27
Michael, thanks for checking and analysing, i disabled some languages as i didn't want to reach my limits (paid of free) too quickly for languages that i have decided bring little traffic.

I will upgrade to the latest tonight when i am home, you can mark this thread solved as i do not need further help at this time with this :)

20-10-11, 20:18
Great. Enjoy vBET! :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations supported by vBET 4.9.99