PDA

View Full Version : Solved Troubl with vbseo integration - HELP



gopalmm2
15-10-11, 22:44
I upgraded vbet to the latest version today - 4.4.3 and then I decided to use vbseo integration.

I followed all the steps... and now, the forum page has gone blank. I have disabled vbseo, so the forum page is back again. Did I just mess something up while integrating it with vbseo?

Thanks for any response,

GMan

gopalmm2
15-10-11, 23:25
UPDATE - I checked all changes and everything seems good. I redid the integration from the start... I have no clue why the page appreas blank.

Thanks...

r.dziadusz
17-10-11, 07:18
Hi
Firstly please check out if you upload content from upload-once, also could you show me your .htaccess file?

gopalmm2
17-10-11, 07:59
I re-uploaded the upload-once contents and over-wrote the files just now, but that didn't fix it, unfortunately... the thing that worries me is that it doesn't give me an error to troubleshoot it with - just a blank page!

Here is my .htaccess contents:


# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/forums/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap|api\.php)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/

RewriteCond %{QUERY_STRING} (hl=|language=)(zh-TW|zh-CN|..)
RewriteRule ^(.*)$ http://%{HTTP_HOST}/%2/$1? [L,R=301]

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/

RewriteRule ^(.+)$ vbseo.php [L,QSA]


Thank you for responding.

r.dziadusz
17-10-11, 09:12
Your .htaccess file is wrong, you should put new rules before vbseo rules, please follow the description from here: http://www.vbenterprisetranslator.com/forum/vbet4-integration-other-plugins/414-vbseo-integration.html
You have to move it just after this line:

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

gopalmm2
17-10-11, 14:45
OK, thank you so much! So I did make a mess after all. I am able to turn vbseo on now, but there is another issue. Whenever I click on a translation flag, it does not translate.. gives me a half-page like this:
https://lh4.googleusercontent.com/-ttT8Cur-YEU/TpwxAdYWaqI/AAAAAAAABYM/-3C-D0LpPkU/s800/TBVBET.jpg

Any ideas?

r.dziadusz
17-10-11, 20:21
Did you upload all vBET files, please check it, and if you have all content uploaded, please make sure you have it all configurated properly.
If it doesn't help please re-upload all files and redo changes
If it didn't work after all, please PM your access detail i can check it on place

gopalmm2
17-10-11, 22:29
Thanks. I have sent you a PM. I redid everything, but same results.

r.dziadusz
18-10-11, 11:54
PM received

r.dziadusz
18-10-11, 13:07
I've also niticed you miss one line in your .htaccess, please use this


# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/forums/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap|api\.php)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/

RewriteCond %{QUERY_STRING} (hl=|language=)(zh-TW|zh-CN|..)
RewriteRule ^(.*)$ http://%{HTTP_HOST}/%2/$1? [L,R=301]

RewriteRule ^(.+)$ vbseo.php [L,QSA]


And I don't get access from you, i will be able to check it just after you send me those:)

gopalmm2
18-10-11, 21:00
I believe that is what I have as .htaccess now. I have sent you the access by PM. Thank you once again! I can get vbet to work separately from vbseo... but integrating both seems to be hard for me... sorry for the trouble and thank you. It is very much appreciated :). I am pleased by the support here.

r.dziadusz
19-10-11, 13:19
Hi i can not acces your forum with data you've gave me please check your inbox

gopalmm2
19-10-11, 14:56
Hi, I checked the login before sending it. I tried it again and it works for me. I sent you an alternate server IP in case of DNS issue.

THanks.

gopalmm2
19-10-11, 16:52
Thaks to r.dziadusz, my issue has been resolved. Your help is much appreciated :D.

r.dziadusz
19-10-11, 17:01
:) happy to help you, If you have any other questions please ask, for any other issue please open new thread

gopalmm2
21-10-11, 00:12
Sorry, but there still seems to be some issue. My entire page translates now, but individual translations don't seem to work for some reason. Do you know what the issue is? Since the page translation works, I guess google API or microsoft API is working, but I don't know why individual text is not translating.

Thanks for any response.

vBET
21-10-11, 02:55
Please open new thread for new issue - also please provide more details (exact URL to the page where issue exists, quote of text which is not translated).

Shortly - please note that you do not have to guess does translation API is working you can check it in Admin CP -> vBET -> Translation Providers Availability. The reason why individual translation is not working can be that actually providers are not available, so you got what you have in cache and some parts (those not translated) are new on page (new answers, edited posts). If you need more help please open new thread for this new issue.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations supported by vBET 4.9.99