PDA

View Full Version : Solved Dropping visitors



harleyforum.se
11-10-11, 17:09
Story:

1. I had the free version, 2.2.4 for a month or so. Worked great, got many many more visitors to the site!
Running (i.e. 'address?language=en') links on this version.

Now (problem):

2. Bought and installed the license version 4.4.2. Changed the settings in the forum according to your readme file.
A. Changed from (i.e. 'address?language=en') to (i.e. '/en/address')
B. placed your .htaccess file in the root as is. No changes to the file at all.
C. Changed conical webaddresses to STRICT and also change to Advanced type of url:s

Suddenly visits dropped to amost half within a week. Got error messages like, "TO_MANY_REDIRECTS" when creating posts on my forum and clinking on links to my forum from facebook etc. Also Google admin tools reported many broken links etc, all of them linked to languagelinks. an, fr sv etc.

Number 2A is still the the same setting (/en/) and htaccess file still there.

Today Changed back advanced to standard URL, and also removed STRICT to std. and l´now links starting to work again....anything you know of before?

I have now disabled translate software for the time beeing.

Any suggestions what to do?! I do want the translatesystem active. Thats why I bought it ;)

vBET
11-10-11, 19:56
Hi.

Please note that when you changed link type you suppose to add special rules which will redirect language= links to SEO links. This way Google will know how to re-index it (I already PM you those rules).
You had not working links so visits where not count - you just need fixed links :)

Please give EXACT URL were the issue with too many redirects happens. If you do not want to have vBET enabled until we fix the issue then please send us access details to Admin CP, FTP and vbseo CP (if used) or just turn enable vBET so we can check what is going on. Also please send us your full .htaccess content.

harleyforum.se
11-10-11, 20:18
Thanx! About them rules in .htcaccess. Should I edit anything on the string below? Add ALL the countrycodes like i did here, yes?


RewriteCond %{QUERY_STRING} language=(RewriteCond %{QUERY_STRING} language=(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)
RewriteRule ^(.*)$ http://%{HTTP_HOST}/%1/$1? [L,R=301])

harleyforum.se
11-10-11, 20:32
Did add the rules to htaccess file. nothing worked! error 500 something , forum and admincp was down. hag to remove the htaccess file and disable product.
You have to look at this later on**********

vBET
11-10-11, 20:57
Thanx! About them rules in .htcaccess. Should I edit anything on the string below? Add ALL the countrycodes like i did here, yes?


RewriteCond %{QUERY_STRING} language=(RewriteCond %{QUERY_STRING} language=(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)
RewriteRule ^(.*)$ http://%{HTTP_HOST}/%1/$1? [L,R=301])


This is broken. and it is not what I send you. Please see again here: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq.html#post1541

Also those are rules just to change old links to new one. For new one you need SEO rules. If you didn't add it after changing links type it it obvious it couldn't work. It is clearly described in Linkt Type parmaeter:


Configure which type of translation links you want.

NOTE that SEO links require changes in .htaccess file which are described here (http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq.html#post11).

So please:
- First make your SEO links working (test it)
- Then make your old links redirected to new one (also test it)

You have all required links :) In case of issues please send your WHOLE .htaccess content after changes you made.

vBET
11-10-11, 20:57
Did add the rules to htaccess file. nothing worked! error 500 something , forum and admincp was down. hag to remove the htaccess file and disable product.
You have to look at this later on**********

It is because you set there wrong thing - please see previous post.

harleyforum.se
12-10-11, 08:23
This is how it looks now. Added the 2 lines from your FAQ, correct? (my .htaccess is the one you have in the "do not upload" dir.) no changes made to that one. Just added the two lines.

http://i1228.photobucket.com/albums/ee444/Harleyforum_Sweden/htaccess.jpg

harleyforum.se
12-10-11, 08:41
My site SEEMS to work, but how do I know that all works alright?

Example Danish:

OLD:
http://harleyforum.se/?language=da

NEW:
http://harleyforum.se/da/forum.php

r.dziadusz
12-10-11, 11:24
If you previously use like with language=xx you will have to use this code:


RewriteCond %{QUERY_STRING} (hl=|language=)(zh-TW|zh-CN|..)
RewriteRule ^(.*)$ http://%{HTTP_HOST}/%2/$1? [L,R=301]

instead of your yellow colored :


RewriteCond %{QUERY_STRING} (hl=)(zh-TW|zh-CN|..)$
RewriteRule ^(.*)$ http://%{HTTP_HOST}/$1\?language=%2 [L,R=301]

harleyforum.se
12-10-11, 11:31
If you previously use like with language=xx you will have to use this code:


RewriteCond %{QUERY_STRING} (hl=|language=)(zh-TW|zh-CN|..)
RewriteRule ^(.*)$ http://%{HTTP_HOST}/%2/$1? [L,R=301]

instead of your yellow colored :


RewriteCond %{QUERY_STRING} (hl=)(zh-TW|zh-CN|..)$
RewriteRule ^(.*)$ http://%{HTTP_HOST}/$1\?language=%2 [L,R=301]


Sorry, don´t understand? Can I copy your new code above as it is or do I have to edit it somehow? My default languange is SV (swedish)

harleyforum.se
12-10-11, 11:35
If i do put the new code as you wrote it, i get this immediately on ie. http://harleyforum.se/da/forum.php (danish)

Error 310 (net::ERR_TOO_MANY_REDIRECTS):

(had to switch back to first code again)

Please, must get this to work now, have LOADS of other things to do.

r.dziadusz
12-10-11, 12:35
I have still your acces information do you want me to check it on place?
Also your old redirection didn't work with code you use, when you enable it you got some further errors

harleyforum.se
12-10-11, 13:23
I have still your acces information do you want me to check it on place?
Also your old redirection didn't work with code you use, when you enable it you got some further errors


Yes, please. Check your pm for all info.

r.dziadusz
12-10-11, 16:14
Yes i browse throughout your files and what I found, please change this two lines in your .htaccess file:


RewriteCond %{QUERY_STRING} (hl=)(zh-TW|zh-CN|..)$
RewriteRule ^(.*)$ http://%{HTTP_HOST}/$1\?language=%2 [L,R=301]


to


RewriteCond %{QUERY_STRING} language=(zh-TW|zh-CN|..)
RewriteRule ^(.*)$ http://%{HTTP_HOST}/%1/$1? [L,R=301]


don't change anything, just replace it and let mi now if it helps

harleyforum.se
12-10-11, 16:33
Sorry NO. (click link below)

Same error: tried German : http://harleyforum.se/de/index.php

Error 310 (net::ERR_TOO_MANY_REDIRECTS)

harleyforum.se
12-10-11, 16:41
Maybe better to go back to the other linksystem ( . 'address?language=en') and remove the .htaccess file. ???
Just as i was in the free version, all worked great then.

OR

You have access to my FTP, please go in and edit the .htaccess file until it works.

vBET
12-10-11, 20:27
Hi. I will take this issue from Radek and help you personally :) Please PM me actual access details - I will see what is going on there and solve it :) I understand importance of this issue.

harleyforum.se
12-10-11, 21:21
Hi. I will take this issue from Radek and help you personally :) Please PM me actual access details - I will see what is going on there and solve it :) I understand importance of this issue.

Thanx! Pm:ed info to you. I am 99.9% that the error is in the .htaccess file somewhere.

Site works now, but I just want to make sure that there is no doublelinks (since I change from 'address?language=en to /EN/ ) so google freaks out and ban me :D

harleyforum.se
12-10-11, 21:27
As you can see in BING when you search harleyforum, bing finds the OLD-style language link.
Link works? but does not translate.

http://i1228.photobucket.com/albums/ee444/Harleyforum_Sweden/bing_.jpg

vBET
12-10-11, 22:17
OK - I'm reading whole history of this topic and going there to solve it :)

vBET
12-10-11, 22:46
I just checked all information and links. It seems that links you gave are working. Also old link which has language= is also working. Please see forum description: Harleyforum.se - Skandinaviens forum för Harley-Davidson & Custom (Danish) - it means that vBET appropriately recognized language and asked for translations - most probably you already reached translation providers limits. I will also check ti and confirm.

Still there is an issue - old link suppose to be redirected to new format, so search engine will re index it. I'm going on your forum now to solve the issue and confirm does lack of translation is because of reached limits or because of some issue. Also please note that limits are temporary, so you will be able to translate again when translation providers reset their limits :) Going there now :)

vBET
12-10-11, 23:03
OK - one thing confirmed - your translation providers are not available. When I turn it, those immediately turns off, because limits are reached. You can check it here Admin CP -> vBET -> Trnalsation Providers Availability

Also I checked it in other way - I used Microsoft test - you can check it here: http://harleyforum.se/microsofttest.php and actual answer from Microsoft Translation API is:

Starting translation test
Test result: "TranslateApiException: AppId is over the quota : ID=3737.V2_Json.Translate.1F6D7B14"
Test error:
Connection time (ms): 426.399902344
So as you see you already reach your quota in Microsoft. Microsoft has hourly and monthly limits.

I also used Google test: http://harleyforum.se/googletest.php at this moment it tells that it is OK:

Starting translation test G API V1
Test result: {"responseData": {"translatedText":"powitanie"}, "responseDetails": null, "responseStatus": 200}
Test error
But vBET disables it immediately - most probably you reach limits for connections in one second - I will checks it in logs and confirm. I will also change one settings for you (waiting time between translations) - it will make your queries send with some time between (for one page translation) so chance that you reach Google limit for one second will be smaller - still possible, but it is Google who set those limits...

Please note that vBET checks every 10 minutes does provider is available again.

I will keep you informed here :)

vBET
12-10-11, 23:07
ONE VERY IMPORTAN THING You had disabled database cache - no wonder you had no translations at all - you reached your limits immediately, because forum wasn't caching results and was asking each time for translations (over and over again). I just turned on your database cache - please keep it turned on :)

harleyforum.se
12-10-11, 23:15
ONE VERY IMPORTAN THING You had disabled database cache - no wonder you had no translations at all - you reached your limits immediately, because forum wasn't caching results and was asking each time for translations (over and over again). I just turned on your database cache - please keep it turned on :)

Yes, thats correct due to harddisk on server was alost full the other day, had to disable it till serverdudes rised harddisk limit. Fixed now.

OK. so .htaccess file is correct? thats what I mostly want to be sure of. The translate limits i am aware of. Thanx so far.

harleyforum.se
12-10-11, 23:18
Still there is an issue - old link suppose to be redirected to new format, so search engine will re index it. I'm going on your forum now to solve the issue

Any luck on this issue?

vBET
12-10-11, 23:26
OK - confirmed that Google is turned off because of quota. Right now you have in your public_html devlog.log file where are written logs about when providers was turned on again and why was turned off with all details. Here is response from Google:

1318457726437 13.10.2011 00:15:26 ******SWITCH provider availability Google to 0 /da/forum.php
19 13.10.2011 00:15:26 ******Google error: {"responseData": null, "responseDetails": "Quota Exceeded. Please see http://code.google.com/apis/language/translate/overview.html", "responseStatus": 403}
and request: cut here
and decoded request: cut here - too long see in logs full /da/forum.php

So as you see translation is working - you simply reached your quota. Google test can work when translation is not working, because test has just one short word to translate and when you turn on provider manually (or vBET automatically) there is so many requests that you reach Google quota immediately.

What to do with that. Few options - one just wait until cache will fill and fill and if it will be filling up faster that new messages are coming then everything is OK. It is really bad that you had your cache turned off, but it is filing up right now. Other option is to disable for some time most languages - leave only few - this way you will have less Google translation requests so you shouldn't reach second limit so fast. Other option is to use Google v2 where you can set your own limits, but this API is unfortunately paid.

Please note that at this moment I'm leaving logs on - I will remove it if you want. Still you can go there and see how it is working.

I'm going now to redirection rules to allow to redirect old links to new ones.

vBET
12-10-11, 23:51
TO OTHERS WHO ALSO READ THIS TOPIC - please note that your forum can require other rules modifications (used vbseo or other type of vBulletin Friendly URLS) - I made in bold what is essential in modification. So it is 1st rule and modifying standard vBET rules (remember you can have different - because or vbseo, friendly... - just as just described). So do not just copy it and if you have doubts just contact us and we will help you :) Please remember that this it modified here only because earlier was used other type of links. If you start with SEO link you do not need anything like that :)

OK - issue with old links is solved. It is now redirecting appropriately to new links type.
So this: Harleyforum.se - Skandinavisk forum for Harley Davidson & Brugerdefineret (dansk) (http://harleyforum.se/?language=da)
Is redirected here: Harleyforum.se - Skandinavisk forum for Harley Davidson & Brugerdefineret (dansk) (http://harleyforum.se/da/)

I had to change rules which are described in the post - I think we will have to update those. So your rules now are:


RewriteEngine On

#TEMPORARY RULES****** - until search engines reindex from old urls to new urls
RewriteCond %{QUERY_STRING} language=(zh-TW|zh-CN|..)
RewriteCond %{QUERY_STRING} !vbetredirected
RewriteCond %{REQUEST_FILENAME} !css.php
RewriteRule ^(.*)$ http://%{HTTP_HOST}/%1/$1? [L,R=301]

RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/archive/index.php/(.*)?$ archive/index.php?/$2&language=$1&vbetredirected=true [L,QSA]
RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ index.php?language=$1&vbetredirected=true [L,QSA]
RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ $2?language=$1&vbetredirected=true [L,QSA]
#END OF TEMPORARY RULES

#RULES for SEO translation links without any SEO engine (on raw vBulletin links)
#If you are using vB 'Mod Rewrite Friendly URLs' then put those rules JUST BEFORE vB rules
#******************************USE THOSE 3 when after disabling temporary rules
#RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/archive/index.php/(.*)?$ archive/index.php?/$2&language=$1 [L,QSA]
#RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ index.php?language=$1 [L,QSA]
#RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ $2?language=$1 [QSA]

Please note that I marked some rules as temporary - after your pages will be re indexed you can remove those add go back to standard rules. It is because you had internal redirection loop even when rules clearly tell that it suppose to be last rule. We had to made little improvisation here (added special parameter to recognize is it already redirected or not. Also I had to made special case for your css.php requests.

Now search engines will appropriately re index your old links to new one. Please note that it can take some time - it depends on your forum size, how often tour forum is crawled by robots and for search engine itself. It can even take 3-6 months before your pages will be re indexed. You can of course just leave all those rules just to be sure. Still those are modified so if you will find any issue please let us note we will help you :)

Please check and tell do you need more support here :)

vBET
13-10-11, 00:04
Any luck on this issue?

Just solved - please see previous post. Had to improvise but it is working :) Sorry it caused you trouble - this is not needed if someone starts with SEO links - you had free version before with SEO links turned on (free version also supports SEO links) so that is why it was needed. Please check and confirm.

harleyforum.se
13-10-11, 08:29
Thank you vBet dude! :D

All seams to work fine now. HOW long approx do I need the temp rules? approx 2-4 months?

I have only 9 language now so cache can build up. The tranlate quota I understand, just happy the links are working.

Great service, thanx again for your help!

r.dziadusz
14-10-11, 08:56
It is difficult to say, it depends on your server traffic etc. I would say that something about 3-6 months. You can check it after some time how links are shown in search engines. Also please note that you can just leave those rules - it will not affect performance in any visible way.

Have you got any further questions about this issue?

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations delivered by vBET 4.9.99