PDA

View Full Version : Solved Uninstall & Results



raymond
08-10-11, 03:08
After using vBET4 for a couple of months, everything seems good but I've decided that I want to remove it from my forum.

Reasons:
1. My dedicated server's database has become very huge, and every feature in forum becomes very slow. I had to upgrade my server's hard drive to SSD so that everything becomes normal again. I believe this is only a temporary solution and everything would become slow again when the size of the database grows some more.
2. Will have to pay when Google started charging money to use their API v2.
3. It is never really a good idea to run automated translation WITH caching to make it look like your forum has more threads. I used to run a similar plugin in Wordpress and one day Google just removed all indexes on auto translated pages.

The above reasons may not be right but they are my reasons and I don't want to take any risks.

Because vBET is a very advance and sophisticated plugin, I am sure that the uninstallation is not going to be easy since the installation itself wasn't very easy either.

I have 2 concerns now:
1. Uninstall (Can you offer paid "uninstall service")
2. 404 errors. After uninstallation, there will be a lot of 404 errors because of the removal of translated pages. Is there anyway to make a script to auto redirect the search engine bots and guests back to the original thread with a 301 permanently moved code?

In vBSEO, there is an option in General Settings > vBSEO Settings. Maybe that can help?

"File Not Found" requests handling?
Select how 'File Not found' requests will be handled:
- Redirect to homepage
- Send 404 HTTP code and show a 'Page not found' message
- Include custom error page. NOTE: The filename should include the absolute path. (example: /home/user/public_html/error.php)

raymond
08-10-11, 04:20
An update.

I've done the following:
1. Disabled vBET
2. Revert .htaccess
3. Restore functions_vbseo_createurl.php and functions_vbseo_url.php

When I try visiting translated threads, it shows Status: HTTP/1.1 301 Moved Permanently and redirects me to the original thread. This is good news!

However, I have only disabled vBET but haven't uninstall it.
What if I uninstall it? Will the 301 Moved Permanently redirect gone as I suspect this is currently done by vBET.

Some other things to look into, additional usergroups, and etc...

r.dziadusz
08-10-11, 08:13
After uninstall things like additional usergroups(created by vBET) will be removed from your database, also right now it available beta version of PHP robot which will remove all your BBcode - from links also

raymond
09-10-11, 07:42
Thank you.

Can anyone confirm that the 301 permanently moved headers and redirect are done by vBET?
If it is done by vBET, I will only disable it (not uninstall) because if I uninstall, it will cause a lot of 404 not found errors.

vBET
09-10-11, 12:44
No your 301 redirects are not made by vBET - you have vBET disabled so it does nothing. You can uninstall vBET.
Please note that you can set .htaccess rules to have redirects - now it is probably done by vbseo.

Please tell do you need more help here?

PS.
vBET goal is not to make your forum look like it have more pages as you wrote - the idea is to support multilingual communities, were everyone can write and read in his own language :)

raymond
09-10-11, 14:45
It's interesting that vBSEO knows where to redirect the translated thread to the original thread.
I'll schedule to fully uninstall vBET tomorrow. Please leave this thread open for the time being.

Although I agree with you that vBET is able to make our forum support multilingual, but unfortunately Google may not see it that way.
vBET is so far the smartest because it translates both URL and content, and Google is still not aware of it.
A lot of Wordpress plugins doesn't translate URL and they were all penalized.
For example, vbet.com/blog/test, the russian translated SEO url would be vbet.com/blog/test/ru or vbet.com/blog/ru/test which is easily identified as automated translated page.

Keep up the good work, although I've decided to stop using it but I would still say it is a good mod.

vBET
10-10-11, 15:53
vbseo recognizes thread by ID which is included in URL, then checks does URL is as it should be and if not redirects - same thing happens when you set a typo in URL.

We believe that internet without language barriers is the future :) And it is closed each time when translation engines improves their translation quality. Changing free APIs to paid one will slow this down, but it will not stop it. As long as people want be heard everywhere. As long as people want to communicate with everyone. This is what for internet exists :)

In case of any issues during uninstall please just write here - we will help you.

raymond
11-10-11, 04:14
So far uninstalled fine. The additional usergroups were successfully removed.
Now I am only seeing titles with
I found a thread somewhere that there is a script or SQL command to remove it. Going to give it a try.

r.dziadusz
11-10-11, 06:14
I guess you see "[ langtitle=]" etc
Yes the script you can find here: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/2466-how-remove-vbet-language-code-2.html#post10556

raymond
14-12-11, 03:19
I'm bumping this thread because I am seeing thousands of errors from Google Webmasters after a complete uninstall including cleaning up caches from database.

Please see the attached image.

http://i.imgur.com/mCH8a.png

Those translated URLs with ID does not get permanently redirected to the original thread.

I tried to reinstall vBET to see if they are redirect properly but wasn't able to install because the forum ended up as blank page. I noticed this happen immediately after I update the vBSEO files. The .htaccess is definitely correct because I restored the older version when vBET was still running.

I also found out that the latest vBET 4.4.5 ZIP doesn't contain upload-once folder.
Maybe that is the cause of the problem?

r.dziadusz
14-12-11, 12:51
We just decided to marge these two folders upload and upload-once into one. The content from upload-once still exist, so it shouldn't be the problem.
Please tell me if did all required steps: did you made changes in vBSEO files? Becouse if not, the old .htaccess file wouldn't work

raymond
14-12-11, 13:51
Yes I did all the required steps. vBulletin is installed in /forum directory.
1. Upload everything from the upload folder to the root of the forum.
2. Installed the product from admincp
3. Updated htaccess.

RewriteEngine On

RewriteBase /forum/
RewriteCond %{HTTP_HOST} !^www.raymond.cc$ [NC]
RewriteRule ^(.*)$ http://www.raymond.cc/forum/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/index.php [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]

4. Modified functions_vbseo_createurl.php and functions_vbseo_url.php according to readme.html instruction.

Right after I change the 2 vbseo files, my forum became blank. Of course I've checked the configuration of vBET and make sure that every important option is set such as license key and etc...

raymond
15-12-11, 12:25
Bump again!

vBET
15-12-11, 13:46
Hi. If you want just to have redirects please add to .htaccess appropriate rules. If ou are done with vBET then there is no sense to install it just to have redirects. Still vBET will to the redirects if someone goes to unsupported language, but having simple .htaccess rules is better for performance.

Google will show you errors as long as it will not remove old links from indexes and as long as other pages includes URLs to your pages. It would be same if I add to my page URL: your_domain\not_existing_page
You will see then one more Google error, because he didn't found on your forum URL he fallowed. So you can just ignore it or redirect. As I saw on your screen shot only one URL is to translated pages - the rest is to normal - also not existing pages. And the one to translated one is simply inked to your from 6 locations.

vBET impact on your forum finished when you installed it. Now you are dealing with already indexed pages and links to your forum from other services. If you do not want to use vBET there is no need to install it. Just simply add rules with 301 from translated pages. Radek - we already gave such rules in some thread. Please found those and publish here for raymond.

r.dziadusz
15-12-11, 14:21
Hi
Here is an article:



For already indexed - just create redirection rules which will redirect all those requests back to the original one. Use this (please test those):


#RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ / [L,QSA]
#RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ /$2 [L,QSA]

Add your forum directory there. Or in other words - those are 2 first vBET rules where you should remove vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=

raymond
16-12-11, 13:11
vBulletin is installed in /forum/ directory. Can you advise where should I insert the rewrite rule based on my .htaccess file below?
Also don't forget to put the 301 redirect code. Thank you.


RewriteEngine On

RewriteBase /forum/
RewriteCond %{HTTP_HOST} !^www.raymond.cc$ [NC]
RewriteRule ^(.*)$ http://www.raymond.cc/forum/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]

r.dziadusz
17-12-11, 11:36
Just edit the content from your previous .htaccess


RewriteEngine On

RewriteBase /forum/
RewriteCond %{HTTP_HOST} !^www.raymond.cc$ [NC]
RewriteRule ^(.*)$ http://www.raymond.cc/forum/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ /forum/ [L,R=301]
RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ /forum/$2 [L,R=301]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]

r.dziadusz
27-12-11, 13:34
I will mark this thread as solved. If you still have any question about this issue please ask, for any other - open new thread

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.2 supports automatic translations