PDA

View Full Version : Solved Translation works on CMS page but not in CMS article



brubros
06-10-11, 16:27
Is this a Google translate issue or a vBET issue?

On the home page of our web site, we have this article that is translated successfully into Spanish from English by Google (screen shot) : http://www.actuparchives.org/2011-10-06_091506.jpg but when you click on the translated article to read the complete story, only this appears (no text at all, just the picture from the article) : http://www.actuparchives.org/2011-10-06_091722.jpg even though, when viewed in English, you see : http://www.actuparchives.org/2011-10-06_092104.jpg. You can see this behavior for yourself by going to actup.org and looking at the article that screen captured here.

I just need for vBET to confirm that this is a Google issue that I need Google to address or to confirm that it is some other issue related to vBulletin or vBET or some other component. Thanks!

r.dziadusz
06-10-11, 19:30
To be shure please run these tests for all api you are currently using: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post1729

brubros
06-10-11, 19:40
Yes, we used the tests you installed and discovered that Google reports a TOS violation (403 error) and we have filed a report with them to determine what can be done to fix the problem.

I should have been more clear with my question. Does the translation that appears in the front page of CMS come from a different cache than the full article translation? Does this cache 'belong' to vBET or vBulletin? Does vBET make an API call for the CMS summary page or does it use a vBET cache or a vBulletin cache? Does vBET make an API call for the CMS full article translation or does it pull it from the vBET cache (assuming it has been enabled in settings)? I am just trying to isolate where vBET is involved and where it is not.

Thanks!

vBET
06-10-11, 21:37
Hi. Pictures you send shows that your quota was exceeded - that is why you do not see translation. You see translation on main page - it was translated when you still had limits. But when you went on the page limit was already reached so no text was displayed. Please see newest release - the behavior is changed now in case when provider is not available. We have still some issues in newest BETA release (providers are marked as unavailable more often that it is needed), but I'm working on it right now.

The cache is one and it is vBET cache. Just note that texts "Example..." and "Example of text" are 2 different strings - you have cached translation of short one, but not for long one.

So assuming - there is no vBET issue here. Just limit reached on translation provider API. Please check newest release. Soon it will be corrected, but available to use right now - just not optimized (disable providers even when wrong message is send - working on this right now).

Do you need more help here?

brubros
06-10-11, 21:50
Yes, this helps. Thank you for taking the time to explain.

May I create a new service request to have this latest software added to our site by vBET?

As I have said, I really do not want anyone, except for vBET, to be touching our web site until we are functioning again. It sounds like this newest release may be an important step - even without it being fully optimized.

vBET
06-10-11, 22:49
Please create service request. We will handle this :)

brubros
07-10-11, 14:31
I received your note regarding confirming the service integration update (that you wish to tweak a bit more before installing, which I understand). I just want to report that last night we finally figured out what was appending some extra characters to the URL. It was a social bookmarking enhancement called ADDTHIS (addthis.com) and we removed it entirely from our web site so the URLs no longer have extra characters appearing. However, I want to report that unfortunately we still receive errors when a story on the front of CMS (where the translation is good) is clicked, we still get a 'no data received' error from Chrome (Error 324 (net:ERR_EMPTY_RESPONSE) when the full article is supposed to display (screenshot) : http://www.actuparchives.org/2011-10-07_071809.jpg or a blank page from Firefox.

I hope this error may be eliminated by the vBET upgrade or that you will at least test one or two CMS articles by clicking on them on the home page, after you have installed the update, to determine if the "no data received" error is eliminated as a result of the upgrade now that we have removed that third-party product that was introducing extra characters to the URL. Thanks!

Also, last night, our GoogleTest returned a '200' (everything is fine) though this morning when we run GoogleTest.php again we are back to a '403' error (TOS issue). I just want you to know this for testing purposes.

vBET
08-10-11, 12:18
Hi. We found one issue in beta version which was installed on your forum - it was our bug. I already uploaded updated file and checked exact thread I see in the picture and it is working now.
Please check it and confirm it is solved :)

brubros
08-10-11, 12:29
Thanks. But unfortunately it only works when logged in as admin. As a guest, the same error appears.

brubros
08-10-11, 12:53
[entry deleted by brubros]

brubros
08-10-11, 13:40
[UPDATED] The steps we took to return to normal operation were to upgrade vBulletin from 4.0.7 to 4.1.7 (all translations began to work immediately after that effort was complete) and upgrade vBSEO from 3.5.1 to 3.6.0 and we did not touch your installation of vBET so clearly the issue we were experiencing, though the coincidence in timing was odd, was not vBET. vBET still remains a hero in my heart, even if my sleep-deprived mind had lost hope for a moment. I am, once again, a great fan.

brubros
08-10-11, 23:53
Everything works now. It required a clean install of everything. vBET runs beautifully. You have my permission to delete this sleeplessly written note.

vBET
09-10-11, 00:01
I checked your forum and I do not see the issue.

I just checked URL: YOUR_DOMAIN/forum/content/october-24-2008-usa-apple-says-gay-marriage-civil-rights-issue-not-political-issue-6361/ and its translation to Polish as guest - page generates. Where do you see the issue? Please give EXACT URL where you see that issue happens.

Please remember that I noticed you that you had issue like that earlier and that was related to your server cloud. Most probably here it is same issue. It is not related to vBET - you can check it easily because:
1. You are writing that not translated pages are not generated.
2. You can disable vBET and check does it changes anything.
3. See included link to image

I see the page is generated and you don't - just like before I noted you that I do not see it and you saw it. So I bet now you have same reason - solve it same as you solve it before. It is not vBET issue. Pages are working well for me (as guest) proof:
http://www.vbenterprisetranslator.com/images/actup.png

So before you take any actions please think does it has any sense. Most probably it is not software issue but your infrastructure issue.

Please tell do you need any more help here :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations by vB Enterprise Translator 4.9.99