PDA

View Full Version : Solved I am appealing to Google Translate, but need help from vBET first



brubros
05-10-11, 17:25
I am making an appeal to Google Translate (API Access Notice - Google Code (http://code.google.com/apis/errors/)) but I do not know how to answer their questions, including the following. Could you please help with providing answers so I can pursue directly with Google?

"IP address of your server which is making the requests?" - Is it my server that is making the request?
"Are you using the API server-side or in JavaScrip?" - I don't know how to answer this
"If you are using server-side, what is the HTTP referer used in request?" - does vBET use this?
"please enter a URL where you have the API implemented" - do I provide Google with my URL?
"Are you sure that your requests include an API key, a valid HTTP referer and the userip parameter (for server-side requests)?" - does vBET do this?

r.dziadusz
05-10-11, 19:32
1) Yes it is IP of your server
2) You are using api server side
3) It is url to your translated part
4) URL ex(without *)
for api google 1 - wihout key: ht*tp://ajax.googleapis.com/ajax/services/language/translate?v=1.0&format=html&langpair=en|pl&q=welcome
and for api google v2: ht*tps://www.googleapis.com/language/translate/v2?key='your_api_key'&format=html&q=welcome&target=pl

brubros
05-10-11, 19:47
Thank you! I have just submitted my appeal to Google.

vBET
06-10-11, 03:15
If you will need more help here just write :) We would also be very happy if Google v1 work until close without such surprises but it is up to Google...

Vetall
12-10-11, 07:10
brubros, you've already got a response from Google? restore the API?

vBET
12-10-11, 21:35
We do not know did burbos got answer. Our own experience - Google first send the message about blocking, but we think that finally they realized that there is some bug because everyone was blocked, now we have it unblocked (we even didn't wrote there) and now if limits are reached we simply get response with information about reached limit. So for us Google is available after blocking without any intervention on our side. Please just check right now googletest (http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post1729) on your forum.

Vetall
13-10-11, 07:03
googletest.php


<?php
echo "Starting translation test G API V1<br/>\n";
$connection = curl_init();
curl_setopt($connection, CURLOPT_URL, 'http://ajax.googleapis.com/ajax/services/language/translate?v=1.0&format=html&langpair=en|pl&q=welcome');
curl_setopt($connection, CURLOPT_USERAGENT, 'Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)');
//curl_setopt($connection, CURLOPT_FOLLOWLOCATION, 1);
curl_setopt($connection, CURLOPT_RETURNTRANSFER, 1);
$result = curl_exec($connection);
echo 'Test result: '.$result."<br/>\n";
echo 'Test error: '.curl_error($connection)."<br/>\n";
curl_close($connection);
?>


Starting translation test G API V1
Test result: {"responseData": null, "responseDetails": "Suspected Terms of Service Abuse. Please see http://code.google.com/apis/errors", "responseStatus": 403}
Test error:





googletest.php


<?php
echo "Starting translation test<br/>\n";
$connection = curl_init();
curl_setopt($connection, CURLOPT_URL, 'http://ajax.googleapis.com/ajax/services/language/translate?v=1.0&format=html&langpair=en|pl&q=welcome');
curl_setopt($connection, CURLOPT_USERAGENT, 'Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)');
curl_setopt($connection, CURLOPT_RETURNTRANSFER, 1);
$time = microtime(true) * 1000;
$result = curl_exec($connection);
$time = microtime(true) * 1000 - $time;
echo 'Test result: '.$result."<br/>\n";
echo 'Test error: '.curl_error($connection)."<br/>\n";
curl_close($connection);
echo 'Connection time (ms): '.$time;
?>


Starting translation test
Test result: {"responseData": {"translatedText":"powitanie"}, "responseDetails": null, "responseStatus": 200}
Test error:
Connection time (ms): 148.76098632812



-This results in my site for the two versions of the script googletest.php

r.dziadusz
13-10-11, 11:27
Please for any issue open new thread, we will be glad to help you

vBET
15-10-11, 00:17
Shortly about your last post Vetall - the code is same in case of connection. The differences are only in messages on your side and 2nd code also shows connection time. So the difference in answers is not because use of 2 different scripts, but because those where run in different time.

If you need more help about it then Just as Radek wrote - please open new thread.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.2beta brings automatic translations