PDA

View Full Version : Solved Major translation issues



Simon Lloyd
28-09-11, 17:20
Hi, i'm in need of some urgent help, i find today that some of the thread titles are missing but if i change languages they appear (sometimes), check here http://www.thecodecage.com/forumz/microsoft-excel-worksheet-functions/ you will see lotsof threads starters names but no thread titles (well maybe one or two), now change languages say to greek you will see the thread titles, change to another language and some titles are gone and some remain?!

Can someone help please?

tavenger5
28-09-11, 21:38
I believe I'm having the same issue. It suddenly started happening today.

tavenger5
28-09-11, 22:53
btw, when I switched to the Google v2 api the same threads that were previously not translating are now translating. Google must have changed something in the v1 api.

Update: it seems to be in an out actually. I'll reload a page after switching the api, then I'll reload it again in couple minutes and the default language will not be translated. If I switch the API again, things seem to work for a couple min.

r.dziadusz
29-09-11, 09:45
Hi
Link that you put in your post didn't work, can you show me exactly liks where it happend?
Simon Lloyd: Which API do you use?

But first, look for this folder in your forum root: vbet_translation_options
If there isn't, please read this post Vbet 3.5 relase (http://www.vbenterprisetranslator.com/forum/vbet-announcements/2404-vbet-3-5-0-released.html#post10168)
especially:

NOTE: there is one additional update step necessary:
- Upload to server content of directory upload-once from vBET package (includes configuration for multi translation API support)

Simon Lloyd
29-09-11, 12:43
Hi the link doesn't work at the moment because we are optimising the database, i am using the lateset stable release vBET3.4.1 which i uploaded last night from 3.4.0, but then every page on the forum was taking 30 seconds to open, so before complaining here i decided to optimise the database just in case, it may take a few hours more yet as our DB is 11.5gb.

Simon Lloyd
29-09-11, 13:10
The missing thread titles and translations were apparent before i upgraded.

r.dziadusz
29-09-11, 13:54
You could upgrade your forum to latest version, and enable also microsoft api, but first afer database is opimised try our google test - http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-2.html#post1728, and find out if everything is ok, you'he written in other post about google api v1 limits, I have to investigate it, also you can use our hints to reduce your requests: http://www.vbenterprisetranslator.com/forum/general-discussions/243-vbet-performance.html

tavenger5
29-09-11, 14:00
Here is one of my posts not working correctly: http://cellphoneforums.net/********/t335694-a.html

m otorola is filtered on here too - replace ***'s with m otorola (without space)

Also, vbet_translation_options is uploaded to my server. I still can't use MS Translator though.

r.dziadusz
29-09-11, 14:05
I'm working on it, and please open new thread for this issu becouse your problem is about vbet 3.5 and this thread is open by 3.4x user it's difference,

Simon Lloyd
29-09-11, 14:09
You could upgrade your forum to latest version, and enable also microsoft api, but first afer database is opimised try our google test - http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-2.html#post1728, and find out if everything is ok, you'he written in other post about google api v1 limits, I have to investigate it, also you can use our hints to reduce your requests: http://www.vbenterprisetranslator.com/forum/general-discussions/243-vbet-performance.htmlI'll never move to vb4.x as its riddled with problems and security flaws, they've released maybe 15 patches in as many months, not good!, i have followed ALL your optimisation tips (and posted previous threads on this), the optimisation will take another hour or so then i'll be able to check that link..etc

r.dziadusz
29-09-11, 14:24
I ment the latest version of vbet 3.x for vb3.x Vbet 3.5 relase (http://www.vbenterprisetranslator.com/forum/vbet-announcements/2404-vbet-3-5-0-released.html#post10168)

Simon Lloyd
29-09-11, 14:32
i could but thats a beta and you state you dont give support for it and that also is no good to me :)

tavenger5
29-09-11, 20:21
some more info: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/2430-translations-not-working-suddenly.html#post10304

r.dziadusz
30-09-11, 13:26
Please -do this test for all API you are using-http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-2.html#post1728

Simon Lloyd
30-09-11, 14:35
I will when i have finished optimising my database, i am only using API V1 as i only have vBET 3.4.1 installed.

Simon Lloyd
01-10-11, 11:05
Please -do this test for all API you are using-http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-2.html#post1728Ok i ran that test and got this
Starting translation test G API V1
Test result: {"responseData": {"translatedText":"powitanie"}, "responseDetails": null, "responseStatus": 200}
Test error:

Simon Lloyd
01-10-11, 19:27
I have further issues, the vbenterprisetranslatot.php is using ALL my cpu time, please check below:
Pid ************Owner Priority CPU % Memory % Command
12493 (Trace) (Kill) thecodec 0 - 104 - 0.5 /usr/bin/php /home/thecodec/public_html/forumz/vbenterprisetranslator_seo.php
12496 (Trace) (Kill) thecodec 0 - 72.0 - 0.5 /usr/bin/php /home/thecodec/public_html/forumz/vbenterprisetranslator_seo.php
12495 (Trace) (Kill) thecodec 0 - 67.0 - 0.5 /usr/bin/php /home/thecodec/public_html/forumz/vbenterprisetranslator_seo.php
12492 (Trace) (Kill) thecodec 0 - 42.0 - 0.6 /usr/bin/php /home/thecodec/public_html/forumz/vbenterprisetranslator_seo.php
12490 (Trace) (Kill) thecodec 0 - 23.5 - 0.6 /usr/bin/php /home/thecodec/public_html/forumz/vbenterprisetranslator_seo.php
12484 (Trace) (Kill) thecodec 0 - 11.7 - 0.6 /usr/bin/php /home/thecodec/public_html/forumz/vbenterprisetranslator_seo.php
20732 (Trace) (Kill) mysql 0 - 1.8 - 6.2 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/server.thecodecage.com.pid --skip-external-locking --


I have 4 cpu's and it's killing my site now that it cant get translations!!, i have disabled half of the translations and still have the issue!

Can someone help?

Simon Lloyd
01-10-11, 20:27
I have upgraded to the beta to try to solve my issues but it seems that i'm not getting translations from Microsoft?

Here's the micorsoft test result:

Starting translation test MS
Test result: "InvalidOperationException: : ID=3641.V2_Json.Translate.365033CA"
Test error:
Connection time (ms): 237.756103516

I've double chaecked i have the MS ID correct!

harleyforum.se
02-10-11, 16:05
Hi, i'm in need of some urgent help, i find today that some of the thread titles are missing but if i change languages they appear (sometimes), check here http ://www .thecodecage.com/forumz/microsoft-excel-worksheet-functions/]Microsoft Excel Worksheet Functions you will see lotsof threads starters names but no thread titles (well maybe one or two), now change languages say to greek you will see the thread titles, change to another language and some titles are gone and some remain?!

Can someone help please?

Have the exact same thing.. started couple of days ago. (free version 2.4.4)

vBET
02-10-11, 22:46
Hi, i'm in need of some urgent help, i find today that some of the thread titles are missing but if i change languages they appear (sometimes), check here Microsoft Excel Worksheet Functions (http://www.thecodecage.com/forumz/microsoft-excel-worksheet-functions/) you will see lotsof threads starters names but no thread titles (well maybe one or two), now change languages say to greek you will see the thread titles, change to another language and some titles are gone and some remain?!

Can someone help please?

Please note that Google v1 put more restrictions on API usage since they are preparing to close. And what you describe looks like you reach your limit. Some titles (content) is not shown because it cannot be translated. Some are OK because you already have it cached. Please note that newest vBET version (at now marked as BETA because of lot of changes) allows to use other translation API - Paid Google v2 and still free Microsoft. So this can solve you issue which is not on vBET side but on translation provider side - Google just prepare for closing v1. We are all unhappy because of that :(

You can check details about your actual Google translation by using googletest - please see here for details: http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-2.html#post1728

Simon Lloyd
02-10-11, 22:53
Thanks for the reply Michael but if you read further through this thread you would see that i was having further problems with vBET 3.4.1 and then upgraded to the Beta, even with the beta+ Google V2 Api, Google V1 Api and Microsoft ID they still didn't show the translation, i have manually translated some now, but i did expect those translations that were lost to re appear when paying for the results, i have reduced my support for all languages down to about half, only 7 languages have been called so far according to Google API V2 stats and in just 40 minutes i'd used 100,000 characters!

Simon Lloyd
02-10-11, 22:55
As added information i have set Google API V2 as the detection, i have tried Microsoft as detection and Google API V1 but none translated the thread titles back.

vBET
02-10-11, 22:57
I have further issues, the vbenterprisetranslatot.php is using ALL my cpu time, please check below:
Pid ************Owner Priority CPU % Memory % Command
12493 (Trace) (Kill) thecodec 0 - 104 - 0.5 /usr/bin/php /home/thecodec/public_html/forumz/vbenterprisetranslator_seo.php
12496 (Trace) (Kill) thecodec 0 - 72.0 - 0.5 /usr/bin/php /home/thecodec/public_html/forumz/vbenterprisetranslator_seo.php
12495 (Trace) (Kill) thecodec 0 - 67.0 - 0.5 /usr/bin/php /home/thecodec/public_html/forumz/vbenterprisetranslator_seo.php
12492 (Trace) (Kill) thecodec 0 - 42.0 - 0.6 /usr/bin/php /home/thecodec/public_html/forumz/vbenterprisetranslator_seo.php
12490 (Trace) (Kill) thecodec 0 - 23.5 - 0.6 /usr/bin/php /home/thecodec/public_html/forumz/vbenterprisetranslator_seo.php
12484 (Trace) (Kill) thecodec 0 - 11.7 - 0.6 /usr/bin/php /home/thecodec/public_html/forumz/vbenterprisetranslator_seo.php
20732 (Trace) (Kill) mysql 0 - 1.8 - 6.2 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/server.thecodecage.com.pid --skip-external-locking --


I have 4 cpu's and it's killing my site now that it cant get translations!!, i have disabled half of the translations and still have the issue!

Can someone help?


Please use one thread per one issue. For new issue use other thread. Shortly - its not vbenterprisetranslator_seo.php who takes whole your resources - it is whole your forum, because each forum request goes trought vbenterprisetranslator_seo.php which only sets few variables for vbseo.php and includes really requested resource. You set whole your forum traffic to this file by your .htaccess file. So there is no issue with this file at all - this is your whole forum consumption. If more description in this area is needed - please open new thread for it or find already existing. One issue per one thread :)

vBET
02-10-11, 23:00
I have upgraded to the beta to try to solve my issues but it seems that i'm not getting translations from Microsoft?

Here's the micorsoft test result:


I've double chaecked i have the MS ID correct!

We will check it with highest priority and let you know about results - maybe Microsoft changed the API if operation is not recognized. Now it is midnight in our country so we will start morning, but Radek gets info from me to check it ASAP.

vBET
02-10-11, 23:02
Have the exact same thing.. started couple of days ago. (free version 2.4.4)

Please see explanation here: http://www.vbenterprisetranslator.com/forum/troubleshooting/2425-major-translation-issues-2.html#post10379
It is not vBET - it is Google v1 new restriction - Google v1 is preparing to be closed. If you need to discuss it more please open your own thread in free version section.

Simon Lloyd
02-10-11, 23:04
We will check it with highest priority and let you know about results - maybe Microsoft changed the API if operation is not recognized. Now it is midnight in our country so we will start morning, but Radek gets info from me to check it ASAP.Ok, will wait to hear from you, i have run that file many times, i will pm you the file links for both google and MS on my site and you can click them whenever you like :)

vBET
02-10-11, 23:07
Thanks for the reply Michael but if you read further through this thread you would see that i was having further problems with vBET 3.4.1 and then upgraded to the Beta, even with the beta+ Google V2 Api, Google V1 Api and Microsoft ID they still didn't show the translation, i have manually translated some now, but i did expect those translations that were lost to re appear when paying for the results, i have reduced my support for all languages down to about half, only 7 languages have been called so far according to Google API V2 stats and in just 40 minutes i'd used 100,000 characters!

Yes I'm on it now and I just saw that you confirmed update to vBET 3.5.0 - thanks for reminding :)
If you do not use Google v1 anymore it is advised to disable cache cleaner. In booth Microsoft API and Google v2 API it is allowed to cache results as long as you need.
Also please consider to block as many pages as you think are not relevant for translation - vBET allows to set which pages should be ignored for translation.
And of course use still free Microsoft API. I know there is an issue now - this is general hint - we will work to correct this.

vBET
02-10-11, 23:15
As added information i have set Google API V2 as the detection, i have tried Microsoft as detection and Google API V1 but none translated the thread titles back.

Please note that detection do not translates! It only detects language and wrap message into BBCode if message is in other language. The translation itself happens when it is needed. So detection options will not change your page behavior during generation - detection is used only when new message is coming.

vBET
02-10-11, 23:19
Ok, will wait to hear from you, i have run that file many times, i will pm you the file links for both google and MS on my site and you can click them whenever you like :)

Can be helpful - thanks :) For us it is really also big inconvenience that Google puts limits, but it is not up to us.
Still your issue with Microsoft can be a bug, or related to some changes in API (the message says that operation is wrong). So we have to check it.

Simon Lloyd
03-10-11, 00:10
Hey you should be in bed now :), i have blocked all pages previously that i didn't need translation. Right now i am set to use just API V2 but have limited each day to 100,000 characters due to cost.

I have set Cache cleaner to "Dissabled", i'm wondering if it is disabled as you may have missed the typo "Dissabled" shows in my admincp but maybe the plugin looks for "Disabled"?

r.dziadusz
03-10-11, 08:03
I have upgraded to the beta to try to solve my issues but it seems that i'm not getting translations from Microsoft?

Here's the micorsoft test result:


I've double chaecked i have the MS ID correct!

Your Microsoft translation api ID is correct, this kind of error appears here: msdn-issue (http://social.msdn.microsoft.com/Forums/en-HK/microsofttranslator/thread/c6359c8f-e694-4c74-97e6-1caae06f0c63) Please read it. But your google test looks good. Also if you pm your account acces I could seek for any internal problem

Simon Lloyd
03-10-11, 09:53
i see but i have always use google set and using api v2 so would i always hit my limit? i also have ggogle api v2 as the detection

vBET
03-10-11, 14:01
Do I understand you correct - you didn't use Microsoft? It wasn't never turned on, on your forum? Please note that Microsoft have monthly limits, so of you reach your limit you have to wait until next time period. It is not daily limit. But if you never used Microsoft before then you shouldn't reach the limit. Please clarify - you are not using it now or you didn't use it at all.

Simon Lloyd
03-10-11, 17:07
Michael, i am currently NOT using Microsoft, i have vBET set to Use Google Only, Detection Google API V2, Use Google API V2, prior to that i used V1, running the link for Microsoft now produces a translation but its sporadic, if you consider you say they are monthly limits then of course my limits should not yet be reset until November 1st.

Simon Lloyd
03-10-11, 17:09
I do have my character limit for google set to 100,000 perday so with my settings above when i reach that limit and no longer get results from paid google would the free APIs then start producing results?

vBET
04-10-11, 00:07
Michael, i am currently NOT using Microsoft, i have vBET set to Use Google Only, Detection Google API V2, Use Google API V2, prior to that i used V1, running the link for Microsoft now produces a translation but its sporadic, if you consider you say they are monthly limits then of course my limits should not yet be reset until November 1st.

The limits are not on our side but on Microsoft side. Information that there is monthly limit is taken from here: InvalidOperationException: : ID=3644.V2_Json.TranslateArray.2485281C (http://social.msdn.microsoft.com/Forums/en-HK/microsofttranslator/thread/c6359c8f-e694-4c74-97e6-1caae06f0c63)
Ant you are right I made little mistake - the full information is:

volume restrictions on free use, at 4 million characters a month and not more than 400K per hour
So you have also hourly limits. Sorry for little disinformation - I should read it more carefully. Does Microsoft have any other limits - please ask Microsoft. At this moment I'm not aware about other limits. If you got the error message form Microsoft then it means that you reach some of their limits. Please contact with Microsoft for more detailed information - it is them who gives you error for appropriate request. I cannot explain them. It is 3rd party. In case of wrong key error message is different what you can simply check.

Also please note that it doesn't have to be November 1st - we do not know details about when new time period is started. Is it per calendar month, or it is sum of last 30 days, or other way... Really have no idea how Microsoft manage it - please ask Microsoft if more details are needed. Anyway if it is form last 30 days then it would allow you each day to made new requests (if you didn't use whole limit in one day).

vBET
04-10-11, 00:09
I do have my character limit for google set to 100,000 perday so with my settings above when i reach that limit and no longer get results from paid google would the free APIs then start producing results?

No. At this moment vBET asks for translation only one provider (depending on your forum configuration). If there is error in response we do not ask other provider. You can create new feature request for this if you feel it is important.

Simon Lloyd
04-10-11, 00:59
Ok Michael, i'll start a feature request, you can mark this thread solved for me as it no longer serves any purpose :)

vBET
04-10-11, 08:34
OK so - marked solved :)

r.dziadusz
04-10-11, 11:43
Starting translation test MS
Test result: "InvalidOperationException: : ID=3641.V2_Json.Translate.365033CA"
Test error:
Connection time (ms): 237.756103516

I've tried to investigate this error more carefully but it is impossible.
You have to ask Microsoft yourself, becouse it could also be internal microsoft issue, if you are sure you didn't reach your limits:
To do that please write an email to : mtcont@microsoft.com
Describe your problem - use error from test
Send your Microsoft Translation API ID - this is mainly way i cannot do it by myself
Write your volume of translations sent to service in characters or MB/hour and chars or MB/day

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations by vB Enterprise Translator 4.9.99