PDA

View Full Version : To explain Time to first byte - BIG difference if Google is turned off.



norku
21-09-11, 17:21
Has anyone else noticed a big difference in the time to first byte with the following setting:

admincp - vBet - Translation Providers - Use Google ONLY (BETA) - no

If I set it to no I end up with a time to first byte of over 8secs. If I set it to yes the time goes down to 1.2secs.

I've tested this over the last hour and the results are consistent. All I'm doing is calling the forum page through webpagetest.org in the default language - no language switches.

admincp - vBet - Translation Providers - Use Google ONLY (BETA) - Application ID for Microsoft Translation API is correctly entered.

Also, with the above setting on 'no' the translations don't appear. I watched a French member replying to a post. Once he had saved the post I saw that the vbet box and flags appeared in the postbit but that the translated text was missing. I went back and set Use Google ONLY (BETA) to yes and voila! everything worked normally.

I'd be interested to see whether anyone else sees this problem on their board.

r.dziadusz
21-09-11, 17:36
Hi
At first, could you please check out if you have got proper ID for Microsoft Translation API?

norku
21-09-11, 18:27
Hi,

Yes, as mentioned, the Microsoft API number is correct and entered. It's also definitely enabled - I just logged into Bing and checked.

r.dziadusz
22-09-11, 09:00
Please check Forum language option, if it is done properly(default language is set) please show me your .htaccess file. If your configuration is ok, we will have to check it on place

vBET
22-09-11, 13:08
About translation time - it is not up to vBET - it is up to external translation service. As appears Microsoft Translation API is slower than Google Translation API. It can change with time. Anyway we can do nothing with it. So there is nothing to solve here.

About lack of results - please describe exactly how to reproduce. Exact data which was in the post. URL to page where it happens also will help :)

norku
22-09-11, 14:44
htaccess:


# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /


#RewriteCond %{HTTP_HOST} !^www\.xxx\.com
RewriteCond %{HTTP_HOST} !(^www\.xxx\.com$|^cdn\.xxxx\.com$)
RewriteRule (.*) http://www.xxxx/$1 [R=301,L]

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/forum/$1 [L,R=301]

RewriteRule ^forum/((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

#vbet translator rules start
RewriteRule ^forum/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ forum/vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^forum/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ forum/vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^forum/((archive/)?(.*.php(/.*)?))$ forum/vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbenterprisetranslator_seo.php [L,QSA]

#vbet translator rules end


RewriteCond %{REQUEST_URI} !(media/|admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(media|admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbseo.php [L,QSA]

## Expires
<ifModule mod_expires.c>
ExpiresActive On
ExpiresDefault "access plus 1 seconds"
ExpiresByType text/html "access plus 1 seconds"
ExpiresByType image/gif "access plus 3456000 seconds"
ExpiresByType image/jpeg "access plus 3456000 seconds"
ExpiresByType image/png "access plus 3456000 seconds"
ExpiresByType text/css "access plus 3456000 seconds"
ExpiresByType text/javascript "access plus 3456000 seconds"
ExpiresByType application/javascript "access plus 3456000 seconds"
ExpiresByType application/x-javascript "access plus 3456000 seconds"
</ifModule>

## Compression
<ifmodule mod_headers.c>
<ifmodule mod_deflate.c>
AddOutputFilterByType DEFLATE text/html text/css text/xml application/x-javascript
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
</ifmodule>
</ifmodule>

#Remove index.php from xxx.com/index.php
#rewrite engine on
RewriteCond %{THE_REQUEST} index\.php
RewriteCond %{QUERY_STRING} ^$
RewriteRule ^index\.php$ / [L,R=301]



The forum default language is English. Switching Google off and using Microsoft should make no difference when viewing /forum/ (for example) as there is no translation needed. If I am viewing /forum/da/ I would expect to see a difference, yes but I see that 8sec time to first byte when viewing /forum/ That can't be right.

The user wasn't doing anything special. He had French set as his default language and made a single sentence post in that language in a public forum. With Google turned off I looked at his post and there was no text, just the vbet flags showing language from and to and the text box where the vbet translation normally appears. I turned Google back on and the text was visible.

I checked my logs just now and I'm getting hundreds of these errors:

[Thu Sep 15 14:04:17 2011] [error] [client 66.249.72.103] [Thu Sep 15 14:04:17 2011] [info] Executing "/home/xxx/public_html/forum/vbenterprisetranslator_seo.php" as UID 503, GID 500

vBET
22-09-11, 18:25
Your .htacess is correct. As you wrote everything works fine with Google, so rules are correct.

Please note that response Translation API response time is not up to us. You already got this information. We can do nothing with this. You can ask Microsoft about making their service faster. If you want you an check how much time vBET is waiting for responses from external Translation API - just turn on Admin CP -> vBET -> Translation Options -> Translation response time. Then if you are logged as administrator you will see how many time your server was waiting during this page generation. Please note that you there will be no wait if translation is already cached.

Please give EXACT message which was written. The bug can be about some special character.

About the log - please open new thread for new issue and we will work about it there :)

norku
23-09-11, 10:23
So when loading a page in the forum default language (no translation required) there is still a delay caused by connection to microsoft? That doesn't make sense..

vBET
23-09-11, 15:43
It can look like it has not sense, but only when no translations are made. Still - on forum default page translations can be made. It is because you can look on page which needs to translate messages written in other languages (used lang and/or langtitle BBCode).

So please - use our hint. You already know what to do, to check waiting time. So please do it. Writing that it has no sense for you gives us no progress. If you do not need our support and do not want to use it, we can mark this issue as solved. If you need our support - please use it and give us results not opinions - otherwise it will be never ending loop about what we think ;)

Details - this is what we need to work with issues :)

norku
24-09-11, 14:22
I realise(d) that the Microsoft response time is beyond your control. That isn't my point. My point is: why is the response time an issue when I am loading a page in the default language which contains only the default language? There is no requirement for a translation yet there is an 8sec delay before the page loads. If I switch back to Google the page loads normally. Once the cache begins to fill for the other languages then the Microsoft response time won't perhaps be such an issue but if there is a page delay on the default language then that is crap. Again, I fully realise that this is beyond your control :)

Again, the French user posted a standard message using standard symbols. The translation simply didn't work when I was using Microsoft. It was translated correctly when I switched back to Google. I tested just now and Microsoft translated a post written in German and displayed it correctly. The thing with the french guy was probably just a glitch.


By the way, Admin CP -> vBET -> Translation Options -> Translation response time ON causes CSS issues. We discussed this a while back.

http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/1969-vb-4-1-4-vbet-4-2-3-mess.html

vBET
25-09-11, 22:13
Once again - please USE OUR HINT and check what is waiting time for translations. It doesn't matter do we think that translations happens or not - is matters do they really happens or not. So please use our hint and VERIFY that you really do not have any translations there what is hard to believe for us now. If it do not happen right now you can temporarily disable cache and you will see again how it works when cache is not filled up. We do not believe that you have 8 sec longer page generation without any translation - it simply doesn't have nay sense. We believe that there are translations and you just do not realize it. And we already gave you long time ago tool how to verify it. Please use it. Without verification future discussion has no point, because we do not know what we discuss about. Please use our hint and verify translation waiting time on page where you think that translation doesn't happen. If it really doesn't and generation is slower then we will look closer on this. Right now your question has no sense, because it is not confirmed that there is no any translation.

CSS issues for Admin CP -> vBET -> Translation Options -> Translation response time ON doesn't matter at all. As you can read in parameter description this is visible only for administrator and should be used only to determine what is going on downstairs. Please use it - give us results (how many waiting time for translation is on this page where you are waiting 8sec for generation, how many connections) - and turn it off.

We are not able to help you when you refuse our help. Please use it.

About French message - please give EXACT message (title and content) posted in French so we will be able to test it and solve the issue :) But do it in separate thread - this one is about your waiting time differences. We will be lost if we will split one thread by several issues - no discussion tracking will be possible in such case. Sorry for this little inconvenience but it will help us all to find out on what stage the issue solving is.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations by vBET translator 4.9.2