PDA

View Full Version : Solved Fatal error after 4.2.2 upgrade in CMS articles translation



vforum
19-09-11, 11:30
After upgrade to 4.2.2 everything seems to be translated except cms articles

only front page in cms is translated , others generate redirect error

default english:

Trusted source for Bodybuilding information - Standing Barbell Curls (http://www.muscleadvice.com/content/standing-barbell-curls-272/standing-barbell-curls-189.html)


translated german with error:

http://www.muscleadvice.com/de/content/standing-barbell-curls-272/standing-barbell-curls-189.html?vbet_lang=de&redirected=/content.php

The page isn't redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept
cookies.



any idea?

vBET
19-09-11, 12:16
I see what is going on. Please give me your full .htaccess file - we will check does rules are OK. If yes then we will have to check it on place, but first lets check .htaccess

vforum
19-09-11, 19:19
# Use PHP5 Single php.ini as default
ErrorDocument 403 /403.html
ErrorDocument 404 /404.html

RewriteEngine on
RewriteBase /

#RewriteCond %{SERVER_NAME} ^muscleadvice.com$
#RewriteRule ^(.*)$ http://www.MuscleAdvice.com/$1 [R=301,L,QSA]



# vbSEO Sitemap
# RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]
# END

# vBET
# RULES for SEO translation links with vBSEO (have to be included before all rules to vbseo.php)

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ /vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L,R=301]

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]



RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]
# vBET End

vBET
20-09-11, 23:27
I see no issue in .htaccess. Please PM me access details to your Admin CP and FTP - I will check it and correct it on place.

vBET
22-09-11, 18:15
Done. You had wrong setting for: Link Type
Please note that when you update you do not have to reinstall. And reinstall is even not advised, because you loose your cache and whole your previous configuration.

Please check does everything is OK now and confirm.

vBET
23-09-11, 15:32
Confirmed in PM - issue solved :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations by vBET translator 4.9.2