PDA

View Full Version : Solved photopost and external vb for vbet



tsak76
16-09-11, 14:42
the external vb thing for vbet works ok..

however there is a problem with photopost. if u are using photopost in the same db with vb and vbet and different db, the plugins that show photos in vba_cmps give errors in TRANSLATED pages only

this is from the file of pp for example.

//$link = mysql_connect ("localhost", "$dbuserid", "$dbuserpassword") or die('I cannot connect to the database.');
//mysql_select_db ("pp_database")or die("Could not select photopost database");

error is like vbet_pp_photos doesnt exist. although it doesnt show this with the normal lang

vBET
16-09-11, 20:55
Please give exact URL to page with the error - we need to check HTML output. Does it happens only when vBET is using external DB or it doesn't matter? Also please give exact error message.

tsak76
16-09-11, 22:10
when u change vbet cache to external db, the scripts that fetch data from photopost database (which is the default vb db) assume that pp is in vbet db. ONLY in vb external db, maybe vbet has nothing to do with it and i might need to edit the line above in the scripts to reflect always to the vb db.

Warning: mysql_fetch_row(): supplied argument is not a valid MySQL result resource in /home/.../public_html/albums/inc_features_cmps.php on line 67
Table 'xxx_vbet.pp_photos' doesn't exist


// If you have placed PhotoPost into a seperate database, you will need to
// uncomment these lines to connect to the PhotoPost database. It is suggested
// that you install PP into the same database as vB for better performance.
//
// If you use the same userid/password to access both databases, you don't need to
// uncomment the mysql_connect - this is only if you require different ids to access
// the PhotoPost database.
//
//$link = mysql_connect ("localhost", "$dbuserid", "$dbuserpassword") or die('I cannot connect to the database.');
//mysql_select_db ("pp_database")or die("Could not select photopost database");

// Number of photos to display
$num_display = 5;

vBET
16-09-11, 22:21
If it happens only when vBET external DB is turned on, then most probably we have some conflict here. Please PM me your Admin CP and FTP access details, and exact URL where I can see the issue. I will check it and solve it on place (we do not have photopost on our testing environment). Please note that I will check it tomorrow, because right now it is late on our country - hope it is OK for you.

r.dziadusz
04-10-11, 09:39
No answer, consider it solved, if you have any question about this topic please ask, I will reopen it, for any other issues please open new thread

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations made by vBET 4.9.2