PDA

View Full Version : Solved Problems with page formatting for members only



Snake
12-09-11, 19:56
My site is 100% translated for guests but when members login and browse pages require some 'extra' translation because of more text on pages.

This is pretty normal except when you view a page as a member you have to refresh (F5) the page 2-3 time before everything displays correct.

I have added some images to explain.

http://www.computer-juice.com/vbeterror.gif

r.dziadusz
13-09-11, 10:05
Hi
Problem seems to be in translation api, becouse once translated text is stored in cache so it can be used properly, but "extra" translation need to connect with google/microsoft api.
Are using google or microsoft api to translation?
If microsoft, please make sure that your microsoft api id is correct, if google please read this post: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post1729
Also, problem may be in your server,please find out, if there is blocked output connection

Snake
13-09-11, 10:28
I agree, seems api is stopped and it take 2-3 goes to get full translation.

Im using google api, ill read the faq and report back, thanks.

Snake
13-09-11, 10:30
Ok so i am not blocked by google, it just seems they are limiting amount of querys in one go.

How do i fix this?

r.dziadusz
15-09-11, 09:19
If you are not blocked by google and your output connection aren't blocked and also there is no redirection problem. Maybe you could try to use microsoft API and then you'll see if there is any improvments.
Also be aware that,soon, you will have to pay for using google api.

vBET
16-09-11, 21:05
Ok so i am not blocked by google, it just seems they are limiting amount of querys in one go.

How do i fix this?

Like Radek wrote you can use Microsoft API. Please note that Google is putting limits on Translation API v1 to prepare users for closing in December. So you can also switch to paid on (I know you do not want to from your other post).

There is also other solution! We discovered some time ago that if too many translation requests are going to Google too often then Google makes time penalties. As we see now it is also service denial penalty, but... We have special parameter for this! Please go to Admin CP -> vBET -> Translation Provider and set Delay between translations. This will add defined delay time between translation requests, so if the reason is too many requests in short time period, then it will be solved. Please note that even with this delay set you can have your translations faster! Just as I wrote Google can give time penalties, so waiting a little on server side can make whole translation faster :)

Also if it appear that Google limited maximum length of one query, or maximum segments in one query, then it is enough to set lower values for constants in class vBET_Translator_Google (see file /includes/vbenterrpsietranslator_class_translator.php)

Please tell do you need more help in this area or the issue is solved.

Snake
16-09-11, 21:09
You read my other posts wrong i DO want to use paid.

So how do i do that? Please reply to my other thread properly!

vBET
16-09-11, 21:38
Sorry. I made mistake (just checked the discussion http://www.vbenterprisetranslator.com/forum/vbet-announcements/2327-vbet-4-4-2-released.html#post9965 - it was form other user - username also starts with S ;)). No need to scream - I will go to all threads which are still waiting for response. You can give me exact URL here if you want :) I'm checking one by one posts from last 2-3 days - my laptop was crashed and Radek was taking care about forum.

If you want to use Google Translation API V2 - just install newest release of vBET4.x, go to Admin CP -> vBET -> Translation Providers and set options appropriately. You will find there whole description with appropriate links how to get Google API key and so on.

vBET 3.x will support it soon (most probably it would already if not my laptop crash). We scheduled release for this month. We have little delay because of hardware issue, but still new vBET3.x release should be available at the end of this month :)

Please tell do you need more help with issue described in this thread :)

PS. Just remembered that this is 3.x sub-forum. We will provide Google Translation v2 support soon in vBET3.x - it is on testing stage now. Code changes are already done.

Snake
16-09-11, 21:44
I know this is the vb3 forum, im running vb3 thats why i post here

When will vb3 support apiv2?

vBET
16-09-11, 21:48
http://www.vbenterprisetranslator.com/forum/troubleshooting/2360-problems-page-formatting-members-only.html#post10086

I was editing my last post when you send your response - so please check there the link above. Sorry for trouble - I miss that it is 3.x sub-forum at the beginning - my fault :P

r.dziadusz
04-10-11, 09:40
No answer, consider it solved, if you have any question about this topic please ask, I will reopen it, for any other issues please open new thread

Snake
04-10-11, 09:44
Solved?

No.

Google api v1 has new low limits, pages not being translated.

Uninstalled now.

Solved? LOL.

vBET
04-10-11, 10:00
As I understand you do not have the issue anymore - right? What more help you need here? :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.2 brings automatic translations