PDA

View Full Version : Solved 404 in ver 3.4.1



tsak76
12-09-11, 16:37
i upgraded to last ver for 3.8 and i get no found in translations, Blank Page 404 error, the vbseo file modifications are done correctly

(link removed)

htaccess

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

RewriteRule t([0-9]+)/ http://www.SITE.com/forums/showthread.php?t=$1 [L,R=301]
RewriteRule t([0-9]+)-([0-9]+)/ http://www.www.SITE.com/forums/showthread.php?t=$1&page=$2 [L,R=301]
RewriteRule f([0-9]+)/ http://www.www.SITE.com/forums/forumdisplay.php?f=$1 [L,R=301]

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

RewriteCond %{HTTP_HOST} !^www\.SITE\.com
RewriteRule (.*) http://www.www.SITE.com/forums/$1 [L,R=301]

#RULES for SEO translation links with vBSEO (have to be included before all rules to vbseo.php)
#RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
#RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

#RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
#RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
#RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]

r.dziadusz
12-09-11, 17:23
Your htacces file looks like this :


# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

RewriteRule t([0-9]+)/ http://www.SITE.com/forums/showthread.php?t=$1 [L,R=301]
RewriteRule t([0-9]+)-([0-9]+)/ http://www.www.SITE.com/forums/showthread.php?t=$1&page=$2 [L,R=301]
RewriteRule f([0-9]+)/ http://www.www.SITE.com/forums/forumdisplay.php?f=$1 [L,R=301]

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

RewriteCond %{HTTP_HOST} !^www\.SITE\.com
RewriteRule (.*) http://www.www.SITE.com/forums/$1 [L,R=301]

#RULES for SEO translation links with vBSEO (have to be included before all rules to vbseo.php)
#RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
#RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

#RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
#RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
#RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]

but please take a look for my changes:

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

RewriteRule t([0-9]+)/ http://www.SITE.com/forums/showthread.php?t=$1 [L,R=301]
RewriteRule t([0-9]+)-([0-9]+)/ http://www.www.SITE.com/forums/showthread.php?t=$1&page=$2 [L,R=301]
RewriteRule f([0-9]+)/ http://www.www.SITE.com/forums/forumdisplay.php?f=$1 [L,R=301]

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

RewriteCond %{HTTP_HOST} !^www\.SITE\.com
RewriteRule (.*) http://www.www.SITE.com/forums/$1 [L,R=301]

#RULES for SEO translation links with vBSEO (have to be included before all rules to vbseo.php)

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forums/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forums/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]


RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]

Please start with changing this file, if error will occur let us know

tsak76
12-09-11, 17:41
ok that works , thanx, and how about vbadvanced portal in the ROOT dir ? this my htaccess. how i must make it ?



Options +FollowSymLinks

RewriteEngine On

RewriteCond %{THE_REQUEST} \ /(.+/)?index\.php\ [NC]
RewriteRule ^(.+/)?index\.php$ http://SITE.com/$1? [R=301,L]



RewriteCond %{HTTP_HOST} !^www\.SITE\.com$
RewriteRule (.*) http://www.SITE.com/$1 [R=301,L]

RewriteCond %{REQUEST_FILENAME} !forums/
RewriteCond %{QUERY_STRING} !vbseourl=
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ forums/vbseo.php?vbseourl=$1&vbseorelpath=../&%{QUERY_STRING} [L]

RewriteCond %{REQUEST_FILENAME} !forums/
RewriteRule ^(.*\.php)$ forums/vbseo.php?vbseourl=$1&vbseorelpath=../&%{QUERY_STRING} [L]

tsak76
12-09-11, 18:32
opps now i noticed that while the translation works the english url has greek letters in it and doesnt become english :/

r.dziadusz
13-09-11, 11:20
1)I think your root direction are translated properly, what seems to be the problem
2)Make sure that your integration, and modification are done properly. Please read once again readme file

tsak76
13-09-11, 16:08
the forum is greek so the default thread url is forum/3234-τιτλος-θεματος.html

when the page translates into english, the translation works but the url becomes

forum/en/3234-τιτλος-θεματος.html

instead of

forum/en/3234-thread-title.html and same for all other langs

r.dziadusz
13-09-11, 16:19
I haven't been clear enough, sorry


and how about vbadvanced portal in the ROOT dir ? this my htaccess. how i must make it ?

and my answer is that translation in your root page work properly, and


opps now i noticed that while the translation works the english url has greek letters in it and doesnt become english :/

Like I said before(and also here http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq-2.html#post3220) please make sure that your integration is made properly.

tsak76
13-09-11, 16:30
yes the vbseo file edits have been done properly

tsak76
13-09-11, 16:34
btw vbseo had a bug with the greek characters in urls and they had fixed the issue with this edit. not sure if this is related.

from vbseo support





change this line in functions_vbseo_url.php

$text = strtolower($text);


with:
$text = (VBSEO_UTF8_SUPPORT && function_exists('mb_strtolower')) ?
mb_strtolower ($text, 'UTF-8')
: strtolower($text);

tsak76
13-09-11, 23:05
i need some support here to solve this important issue

r.dziadusz
15-09-11, 09:25
Personal message send

vBET
16-09-11, 21:43
I will just read whole thing and give you support in few minutes.

tsak76
16-09-11, 22:02
its solved

vBET
16-09-11, 22:06
Sorry but I'm not able to determine what is the issue. Here is several things started and this thread is in mess already... Please open new thread for each still existing issue and copy messages from here (just copy, paste). Sorry for trouble - Radek didn't know our management policy - one issue per one thread so it is our fault, but still we need to clean it up otherwise it will get worst. Now I have impression like each post is about something else (404, vbadvanced, Greek letters in URL, vbseo bug) and I cannot determine status of any issue. Really - I do not know what help do you need now...

This thread in title has 404 error and as I understand it is solved. If you still have 404 issue please write here if it is solved - please confirm. For other issues - please open other threads (1 thread per issue). I have new hardware now (I had laptop crash so Radek was alone on forum last days) so I will be able to help you quick this time. Just please do what I asked for - open new thread for each issue, so we will be able to manage it and go back if needed (like now) to whole issue history.

tsak76
16-09-11, 22:18
i said its solved. the other support i gave him access to the test forum and solved it. r.dziadusz should have marked it solved. :)

vBET
16-09-11, 22:34
Great - thanks for confirmation :) I'm marking it now. In case of other/future issues - please open new thread for each one :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.2 gives automatic translations