PDA

View Full Version : Solved charset ISO-8859-9 not supported?



contemptx
09-09-11, 13:04
one of your staff responded to me saying they have updated my forums.
however I have replied to them saying there are errors with no response:

some threads are showing an error:

Link:
http://www.cardshare.tv/forum/italian-italiano/66681-a.html

Error:
Warning: htmlspecialchars() [function.htmlspecialchars]: charset `ISO-8859-9' not supported, assuming iso-8859-1 in [path]/includes/vbenterprisetranslator_functions_bbcode.php on line 281
Warning: htmlspecialchars() [function.htmlspecialchars]: charset `ISO-8859-9' not supported, assuming iso-8859-1 in [path]/includes/vbenterprisetranslator_functions_bbcode.php on line 281

r.dziadusz
12-09-11, 11:51
Your forum is not responding at the moment. vBET supports all encodings, but it is best if your forum uses utf-8 encoding.
It may be the configuration problem, please check the readme file again - pay attention on vBulletinTM Configuration.
Moreover it is only warning not an error, please note that.

contemptx
12-09-11, 17:07
I have checked the configuration however can not see anything wrong.
This is not just a warning as the pages this show on do not function, but just show this error.

r.dziadusz
12-09-11, 19:53
Ok,
Your php function do not suppord this charset, therefore you can do 2 things:
a) change your charset into one of these :
ISO-8859-1, ISO-8859-15, UTF-8 but it is not sugested and very problematic
b) you can simply turn off warnings by adding "@" before function in line 281:


before:

$content = htmlspecialchars($content,ENT_COMPAT,vB_Template_Runtime::fetchStyleVar('charset'),false);

after:

$content = @htmlspecialchars($content,ENT_COMPAT,vB_Template_Runtime::fetchStyleVar('charset'),false);

Let us know if problem is solved

contemptx
14-09-11, 16:27
It has stopped the error from showing, however whatever the vbet plugin is trying to do and can not do is causing seriously high load and making the site run very slow.

contemptx
15-09-11, 10:28
After altering what you said yesterday, the site is running horribly slow & keeps crashing.
I am currently unimpressed with the level of support being offered at the moment, considering things were working before, I then paid for an upgrade which was done but the site is no longer functioning correctly.

Yesday I lost over £50 in revenue.
I have a busy forum and can not afford for things to continue you like this, I would like this resolved as soon as possible.

I have reverted the change for now.

r.dziadusz
15-09-11, 10:49
We are sorry that you have to wait,
First of all make sure that the cache are turned on

Please check out this topic http://www.vbenterprisetranslator.com/forum/vbet4-general-discussions/408-vbet-performance.html .Please focus on point 2, 16, 18 but read all of them

If the problem still exit turn off all languages without one, check if the caches are getting full

Also you can ask your host provider, if you're using latest version of PHP

Moreover you can check out what's the problem on server. After login seek for problem with memory consuption, or procesor overload. Find out if there is a process responsible for that.

contemptx
15-09-11, 13:29
My server load is between 0.50 - 1.50 = very low.
vBulletin AdminCP = working very fast aswell as other sites and control panels on the server.

I have enabled Guest Cache, but this is not the issue.
The issue is that many users are reaching pages with errors and vBet is not working correctly so its crashing the site.

r.dziadusz
15-09-11, 16:19
Pleace notice that it is not vBet bug. It happend because of PHP - PHP manual (http://php.net/manual/en/function.htmlspecialchars.php) .
These warnings shouldn't crash the site, but like i said please try turn off languages and find out if the forum works faster

vBET
16-09-11, 21:42
The issue is that many users are reaching pages with errors and vBet is not working correctly so its crashing the site.

Sorry - what errors do you still have? Radek gave you solution for described one and you confirmed that those are gone. Please specify what is your new issue so we will be able to help you with it :)

r.dziadusz
24-09-11, 08:52
No answer, consider it solved

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages supported by vBET Translator PRODUCER_PRODUCT_VERSION