PDA

View Full Version : Solved google automatic language detection not working



forosmb
11-08-11, 23:15
This thread is catalan:
Follar en català - Foro Escorts Relax Barcelona (http://www.sexomercadobcn.com/follar-catala-t166.html)

It should be autodetected and translated to spanish (default language).
What I'm doing wrong?

Google Language Detection:

Always trust user
Always trust Google
Trust user but ask Google
Trust Google when result is trust worthy

vBET
13-08-11, 03:12
Does this thread was created after or before you set auto detection?
If before then please note how auto detection works - this is quoted text from the parameter description (you have it in your Admin CP):

Does Google should detect language of message? Note that this can take action only when new message arrives and only if inside of message there is no lang BBCode included already.
So this works for new incoming messages only and marks it permanently so reading is cheap. Trying to recognize each time when message is read would kill your server performance. For already existing messages you can set lang BBCode manually.

So if it was created before you turned on auto detection, or you do not remember then please just copy the message, put it in new post and check how it works.
If it doesn't work for new messages, then please PM me your access details to Admin CP and FTP - I will check what is going on.

forosmb
15-08-11, 12:39
In fact thread was created before product installation and that's why it is not translated, Ok.

I see on this site the radio button you mention and it would fit in my forum.
I don't see the option in my adminCP to make it appear in my 3.7.3 post editor.

¿How is it configured? ¿Is there some version restriction?

vBET
15-08-11, 21:51
Please note that officially supported versions are 4.x and 3.8, but we have customers running vBET on 3.7 and even 3.6

There is no configuration setting for showing language radio button. It suppose to be shown automatically on editors for each user who has set his default language other than forum default language. Please check it on your forum - just set your default language to other value than forum default language and editors should be automatically enhanced. Of course you have not officially supported old vBulletin version so we cannot guarantee it will be, but we didn't get any notice before that it is not working on 3.7. Please check it first and if there will be some issue we will check what is going on.

PS.
Please write new issues in 3.x sub-forum - this sub-forum is for 4.x

forosmb
16-08-11, 00:02
Ok, sorry.
I was testing spanish configured user.
lang BBcodes radio button selector appears on editor. I have just translated related phrase.

forosmb
16-08-11, 00:08
My only challenge right now would be to alter as admin the language assigned to posts (prior to vbet install) in an easy way.

Although a complex demand, we'd need a bilingual flag available, meaning not processing translations for posts in 2 different laguages.This one should be also implicit language configuration for our forum then.

vBET
18-08-11, 10:07
OK so - as I understand automatic translation is working well.

For new issue please open new thread so we be able to keep it clean and do not lost in several parallel discussions in one thread ;)
Also please describe there more what do you mean by "alter as admin the language assigned to posts" - if you mean wrapping posts then it can be done manually or by using database query (please backup before this).

For new feature request please open new thread in feature request section :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations by vB Enterprise Translator PRODUCER_PRODUCT_VERSION