PDA

View Full Version : Accepted CMS articles not translating



Wulf
08-08-11, 15:38
The forums and blogs seem to be working fine but the CMS articles are not translating when adding one in a foreign language. Adding the [lang= ] [/lang ] tags manually doesn't make a difference either.

Wulf
08-08-11, 22:45
I also noticed it is not possible to add comments to CMS articles. Another issue is some text seems to disappear when viewing in other languages. Example:
http://saabworld.net/pl/content/saab-usa-president-i-coo-timothy-colbeck-mówienie-w-motor-press-guild-sierpnia-śniadanie-627/

Taurus
09-08-11, 12:44
I also noticed it is not possible to add comments to CMS articles.

Hey Wulf, do you perhaps have Dragonbyte Tech's Post Template mod still enabled? I had the same issue with no comments that were possible. After disabling that mod it worked again.

Wulf
09-08-11, 14:07
Taurus, thanks for the suggestion but I don't have that installed.

I am getting this in the Firefox error console when trying to add a comment:

document.getElementById("vbet_addbbcodes") is null

vBET
09-08-11, 18:11
I just checked one of your CMS articles, went to translated page and it is translated well.

Please note that [ lang] is not supported for CMS articles, because it has no sense - CMS articles is not something what every one can write (like posts, blogs) - those articles are written by very small group of people who should know your forum language. Do you really want your CMS articles be written in other languages? And I mean written - I know you want hose translated and you have it translated :)

Wulf
09-08-11, 18:20
Actually, that is important for our CMS to allow for multiple languages. We already have CMS sections with articles written in different languages. For example:

SaabWorld - Nederlands (http://saabworld.net/section/nederlands-316/)
SaabWorld - Français (http://saabworld.net/section/francais-322/)

We are are a world forum and would like to keep local articles from different countries in their own language. Important for the blogs but also for CMS articles.

For example, this German article should go on the home page as a CMS article but original German text should remain.

http://saabworld.net/blogs/frank-wulfers/runway-terminal-337/

vBET
09-08-11, 18:43
OK so - I understand your needs. At this moment it is not supported. We will work to support [ lang] also for CMS articles. I suppose there was some issue before and we left it as not needed, but I will check it again and see what happens there :)

PS.
Please open new thread for your last link issue. I see that original test is not included there. Also please describe there is it global issue or just for blogs, or just for this particular blog entry.

Wulf
09-08-11, 18:48
It would be awesome to have this possibility for the CMS articles. Thanks for looking into it.

Any thoughts on the commenting problem for CMS articles?

vBET
10-08-11, 16:39
I also noticed it is not possible to add comments to CMS articles. Another issue is some text seems to disappear when viewing in other languages. Example: SaabWorld (Polska) - Saab USA prezes i dyrektor Timothy Colbeck mówić na lunch sierpnia silnika Prasa Gildii (http://saabworld.net/pl/content/saab-usa-president-i-coo-timothy-colbeck-mówienie-w-motor-press-guild-sierpnia-śniadanie-627/)

Please keep one issue per one thread. Otherwise we will be lost in discussion. Please open new thread per each issue. Also please describe better the issue - what exactly is missing...
This thread is about supporting [ lang] in articles. Sorry for inconvenience - at the end it will help us all :)

Wulf
10-08-11, 16:52
Sorry, I thought those issue were related. I just tested again and now comments are working fine! Pretty strange it just fixed itself so I'll blame it on my user error.. ;) Please ignore

vBET
10-08-11, 17:11
Sorry, I thought those issue were related. I just tested again and now comments are working fine! Pretty strange it just fixed itself so I'll blame it on my user error.. ;) Please ignore

OK so. It could be also issue with Google translation, vBET do not cache then results so as soon as translation issue is gone results should be OK.

Wulf
10-08-11, 17:14
I actually was using Microsoft translations as well and found articles partially showing up. So I switched it back to Google only and perhaps that fixed the commenting problem. I need to do some more testing with the Microsoft translation setting.

vBET
11-08-11, 20:08
We have one known bug in Microsoft translation - it is already corrected and will be released in vBET4.4.1

Here you can find quick fix: http://www.vbenterprisetranslator.com/forum/vbet4-bug-reporting/2053-some-languages-breaking-format.html#post9333

vBET
13-08-11, 15:00
I just tested CMS article with lang BBCode added manually and it translates fine. Please make test article with lang and langtitle BBCode added manually and check how it behaves. Maybe when you changed already existing article it was taken from vBulletin cache and changes was not recognized.

PS.
Automating wrapping is not working for CMA articles now, but when it is already wrapped it should work fine.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations supported by vBET 4.9.2