PDA

View Full Version : /forums appended to domain name across the site



myandy99
20-07-11, 21:11
vBSEO 3.6
vBulletin 3.6.8
vBET 2.3.x
vBSEO sitemap

I installed the free version for a test and I have found out the translation works great!

However, there is a major issue on URLs:

My site is a social networking site (URL xxx.com) integrated with a vBulletin v3.6.8 forum (URL xxx.com/forums).

After installing vBET and made changes to forum root .htaccess, I encountered a problem - once I choose a translation, I cannot go back to xxx.com as all the xxx.com URLs now becomes xxx.com/forums.

For example URL xxx.com/index.php?page=music now becomes xxx.com/forums/index.php?page=music and therefore the social networking part of the site is completely broken as all URLs are redirected to vBulletin forums.

And, the forum URL, which was xxx.com/forums, not becomes xxx.com/forums/forums.

If I turned off URL tracking, above problem would be gone but the automatic translation also stops, which is not what I want.

I put /forums as Forum directory parameter in vBET settings, and I followed the instruction to change .htaccess for vBSEO users.

What am I missing?

vBET
20-07-11, 23:37
This can be caused by wrong configuration. Please note that Forum directory parameter should be used ONLY when your forum uses subdirectory in URL when it is real subdirectory (not virtual - like for example made by vBSEO). This is clearly described in parameter description.

So make sure that you have this right. Please clean your Forum directory parameter and check did it help.

myandy99
21-07-11, 02:51
My forum URL is xxx.com/forums and that's why I added /forums in vBET settings Forum directory.

Removing this didn't help. After removing this, the URL for forum, when translation is selected, becomes xxx.com/cs/forums (cs is a language), resulting a broken link.

Here's my .htaccess in /forums root directory:


# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forums/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forums/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

# RewriteCond %{HTTP_HOST} !^www\.xxx\.com
# RewriteRule (.*) http://www.xxx.com/forums/$1 [L,R=301]

RewriteCond %{HTTP_HOST} ^www\.xxx\.com$
RewriteRule ^(.*)$ http://xxx.com/forums/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?)?)$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]

vBET
21-07-11, 13:26
I misunderstood you before because of this description:

For example URL xxx.com/index.php?page=music now becomes xxx.com/forums/index.php?page=music and therefore the social networking part of the site is completely broken as all URLs are redirected to vBulletin forums.

NOw I understand. It is all OK - just vBET free version do not support translation of external content - translates only forum. URL: xxx.com/index.php?page=music is outside forum so it breaks. vBET free version translates only forum content. Nothing more.

Full vBET version translates content outside forum generated with vBulletin - you can see it on our forum. See content here:
http://www.vbenterprisetranslator.com/
or here
http://www.vbenterprisetranslator.com/downloads.php
and play with translation.

If I still do not understand the issue - please send me exact URL of page which makes issue.
If I understand it right - then the answer is: free vBET do not support translation of content outside forum, paid one supports pages outside forum generated with vBulletin engine.

PS.
In your .htaccess rules for vBET are in wrong place – those should be JUST BEFORE vbseo rules – no other rules should be between vBET and vbseo rules.

myandy99
21-07-11, 15:05
Yes my rules are before vBSEO rules.

I will buy a commercial version. Do I need to uninstall free version and install commercial version?

vBET
21-07-11, 20:47
Yes - if you want to install commercial version then first you have to uninstall free version - it is enough to uninstall it by Admin CP.

Also please note that .htaccess rules will change.

myandy99
11-08-11, 20:17
Hi I purchased commercial version, uninstalled free version and installed commercial version 3.x. The translation works, however I have exactly the same problems as with free version.

I had to turn off URL tracking otherwise URL becomes xxx.com/forums/forums when I navigate.

In addition, another problem still exists - after adding URL rules in front of vBSEO rules in .htaccess, vBSEO sitemap link is broken. I got page not found for my sitemap URL. Removing all vBET rules would make sitemap URL work again but this is certainly not a solution.

Am I missing something?

vBET
11-08-11, 20:26
To have sitemap running move vBET rules to appropriate place. You simply didn't fallow instructions - in instruction you have clearly described to put vBET rules JUST BEFORE vbseo.php rules and you set it before sitemap rules instead. Also please be sure that you have rules for paid version - free one has different rules. Remove old rules and put new ones in appropriate place + add forum directory to first 2 rules (just as described in instructions). If it will still not work – please send whole changed .htaccess file content.

About /forums/forums - what do you have set for Admin CP -> vBET -> Main -> Forum directory?

myandy99
11-08-11, 21:14
Ok thanks. I solved the sitemap broken link problem. But the ../forums/forums problem still exist. And, yes I set /forums at Admin CP -> vBET -> Main -> Forum directory. Without setting forums in that field the translation wouldn't even work - it would lead to a non-existing page.

myandy99
12-08-11, 00:45
Here's my current .htaccess file under xxx.com/forums root:


# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

RewriteBase /forums/

RewriteCond %{HTTP_HOST} ^www\.xxx\.com$
RewriteRule ^(.*)$ http://xxx.com/forums/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/index.php [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]

As you can see, I had to remove
RewriteRule ^(.+)$ vbseo.php [L,QSA] from .htaccess to make sitemap URL work. Is that what I am supposed to do? I don't remember I read anywhere your instruction that I have to delete vBSEO rules in .htacess file to make sitemap URL continue to work. Would this screw up my vBSEO?

vBET
13-08-11, 01:25
Hi. You do not remember to delete vbseo rules in our instructions, because it is not in our instructions and you was never asked to do it. You was instructed to remove old vBET rules (from free version) and to put new vBET rules (from full version) in appropriate place. You do not have to remove vbseo.php rules. Sorry if my previous instructions wasn't clear.
Also removing vbseo rules will not harm your forum, because vBET rules are before vbseo rules and those are same rules (just to different file) so vbseo rules are not active anyway.

About /forums/forums issue:
1. You have wrong first 2 vBET rules - you set there /forum instead of /forums - please correct this
2. If still not working please comment this line in your .htaccess file:

RewriteBase /forums/
3. If still not work - please PM me access details to your Admin CP, vbseo CP, FTP - I will check it on place.

myandy99
13-08-11, 18:52
I tried your 1 and 2 but still same problem.

And, I just found out the translation only works on forum home, not on individual treads. Just PM'ed you with the information you need. Thanks

vBET
14-08-11, 12:08
Going there now.

vBET
14-08-11, 12:22
You had wrong configuration for:
Forum main domain - it suppose to be used ONLY when you are using sub-domains not sub-folders
Link Type - wasn't changed for vBSEO

Also you had turned off translation tracking.

It is all set appropriately now and seems to be working fine :) Please check and confirm.

myandy99
14-08-11, 17:38
Unfortunately it's not working completely - the forums/forums problem still exists. For example, after you go to forum and click a translation, the other non-forum links are added a /forums/ in them and broke them all. For example, http://xxx.com/index.php?page=music now becomes http://xxx.com/forums/index.php?page=music. In this case even forum home page itself has wrong link - it becomes http://xxx.com/forums/forums

And, like I said before, above /forums/forums problem will be gone only if you turn off URL tracking and that's why I turned off URL tracking.

vBET
14-08-11, 21:36
I see those links. Please just make those links absolute instead of relative. So set there full URL http... and so on. Also please note that vBET is able to support translation for your pages outside forum if those are generated using vBulletin engine. You will have to integrate those. See here for instruction how to support translation of pages outside forum: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post1546

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations supported by vBET 4.9.2