PDA

View Full Version : Solved no translate tag in image url link



Schmike
19-07-11, 03:07
the filename contains filtered characters and the no translate tag is added, causing the image to be a broken link.

vBET
19-07-11, 17:54
Please send URL of page with example and tell exactly how to reproduce the issue. What does it mean that image filename contains filtered characters? Please give sample. What are filtered characters - do you mean ignored words or something else?

Please describe more.

Schmike
20-07-11, 03:48
What I meant is the filename contains ignored words.

"PFK" is an ignored word and this is what I get:
[ IMG ]http://www.schmike.net/pics/[ notranslate ]PFK[/ notranslate ] banner.jpg[/ IMG ]

"pfk" is also ignored but I dont't the the above problem for "pfk".

Settings for ignored word is:
pfk
PFK

vBET
20-07-11, 23:53
OK so - for existing changes you can edit it and remove manually.

For future please do little change:
1. Open /includes/vbenterprisetranslator_functions_detection.php
2. Find:

define('VBET_SEPARATORS', ", .?;:!'`&/@#$%^&*()_+=-<>{}~1234567890\"\t\n\r\r\n");
3. Edit it by removing /

Please note that ignored word must be surrounded by those signs. In your case PFK was surrounded by / so it was assumed that it is separate word and it was wrapped. If it would be "_pfk-" then it would be also wrapped, because it is surrounded by separators. So please edit separators. At this moment it is not configurable by parameters so you have to remember about the change after vBET updates. If you want us to make it configurable - please write new thread in Feature request.

Please made change, test it (write message with appropriate content) and tell did it help.

Schmike
21-07-11, 03:39
So does this mean that if i have the word in the middle of a filename it will still get wrapped? Any way to ignore if it's in any linked code like IMG, URL, etc...?

vBET
21-07-11, 13:14
I just described you way to ignore it - change separators. You can leave there for example only space, dot, colon and new lines. File names do not have spaces inside...

By default separators are set this way to recognize ignored word even when it is in brackets or something like that (assuming that "ignore" is ignored word):
(ignore)
-ignore is next option
ignore.
but,ignore.
(not appropriate/ignore)

and so on...

vBET do not check more content around - only signs before and after ignored word - so it will be not wrapped if it is part of other word like in: ignored

You can simply change it by changing separators. At this moment in code. If you want us make it configurable by Admin CP please open new thread in feature request.

Do you need more help here? :)

Schmike
21-07-11, 13:53
I don't think I will be getting what I'm expecting. You can close this thread.

vBET
21-07-11, 14:02
Please note that Feature Request is section for clients requests. You can describe there your needs for new/changed vBET functionalities. Will it be done or not is decided by vBET team according to several factors. I assume it is not important enough to write request for it.

Glad you know how to handle the issue at this moment and thread can be closed :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations supported by vBET Translator 4.9.2