PDA

View Full Version : Solved duplicate pages



Valdo
15-07-11, 08:37
Hi, I had to uninstall VB, but google keeps saying duplicate discussions of this type/members/deps.html? vbet_lang = mk & redirected =/member.php/mk/member.phpvbet_lang = & is redirected =/members/meladancer.htmlvbet_lang = &/member.php ko & redirected =/mk/member.phpvbet_lang = mk & redirected =/members/guantony.htmlvbet_lang = & m =/member.php &/mk/members/orlando.htmlvbet_lang redirected = mt & redirected =/member.phpvbet_lang =/members/orlando.html = redirected & ko & how do I delete them? I've already stuck with the robot file folders/mk/,/memers/etc but still segnalarmelegrazie

vBET
15-07-11, 10:19
Hello,

Un-installation is not necessary. You have support here - in case of issues please write and we will help you solve your issue. If you want to solve the issue, then please install again newest version of vBET and we will work on the issue.

Also in case when something wrong happens in any mod it is enough to disable it - you do not loose your configuration data and it is easy to enable again.

Now going to the issue. I see you had redirection loop. I do not know which version of vBET was used, because it is already not on your forum, so I do not know is it actual issue or just from some old vBET version.
Anyway to solve it please just add appropriate rule to .htaccess. It can be simple rule which redirects all pages with redirected= parameter to your forum main page. For example (not tested):

RewriteCond %{QUERY_STRING} redirected=
RewriteRule $ http://%{HTTP_HOST}/ [L,R=301]

If you want to solve the issue and still have vBET - please write we will gladly help you with this. Still I have feeling that there was used some old vBET version, because we already solved such issues.

Please tell did it help.

Valdo
15-07-11, 13:28
in the meantime, thanks.
Currently my htaccess is so


SetEnv PHP_VER 5

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums)
# RewriteBase /~scuocjjm/

RewriteCond %{HTTP_HOST} !^scuo\.la
RewriteRule (.*) http://scuo.la/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap|cron|chat)
RewriteCond %{QUERY_STRING} !vbseourl=
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php?vbseourl=$1 [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php?vbseourl=$1 [L,QSA]

RewriteRule ^/?archive/index.php/archive.css?$ /archive/archive.css [L,QSA]


how do I change then?
thanks

vBET
18-07-11, 11:30
Put my rule AFTER this one:

RewriteCond %{HTTP_HOST} !^scuo\.la
RewriteRule (.*) http://scuo.la/$1 [L,R=301]

Do you need help with solving the issue?

vBET
27-07-11, 18:04
No answer - considered last hint solved the issue :) In other case - please write here.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Multilingual community supported by vBET Translator 4.9.99