PDA

View Full Version : Solved Blank page when moderating.



JMTA
29-06-11, 07:55
Blank page when moderating.

When a moderator deletes, moves, merges, etc a post they get a blank page

Any solution?

vBET
29-06-11, 18:20
Is it happen on normal page or on translated page? Please note that vBET do not care about translations for administrators and moderators - so we never tested this area - such tasks should be done on normal pages not on translated.

If it happens on normal page please describe how exactly reproduce this issue. Also please go to your error logs and find error for this. Most probably something is missing - some function/class not visible.

JMTA
29-06-11, 21:11
Is it happen on normal page or on translated page? Please note that vBET do not care about translations for administrators and moderators - so we never tested this area - such tasks should be done on normal pages not on translated.

If it happens on normal page please describe how exactly reproduce this issue. Also please go to your error logs and find error for this. Most probably something is missing - some function/class not visible.

It happens on normal pages . I´ve installed vBET 3.x and when a moderator p.e. deletes a post he obtains p.e. this url: forum.com/showthread .php?t=43971 and the page is blank. If you return to the forum the post is deleted

vBET
30-06-11, 02:32
I just made tests on this forum and it is OK. So we are not able to reproduce it on our forum (maybe because of configuration differences).

Please check your error logs - you will find there information what is wrong. Please send us error message so we will be able to fight with it. As I wrote before - most probably some file is not included so there is lack of used function or class. But we need error message to find out what is going on.

PS.
I see you don't have turned on vBET SEO links - we advise to turn it on. then it will look like /pl/ instead like ?language=pl
You can turn it on in Admin CP -> vBET -> Main. This will require .htaccess changes - in parameter description you will find all details :)
If you have already indexed pages in language= style, then one additional rule in .htaccess will redirect it nice using 301 redirect – for Google it means: "This page is now in other place but it is still same page – made update in index without loosing my position". Here you will find this additional rule: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq.html#post1541

JMTA
01-07-11, 14:05
Thanks, solved

The error was PHP Fatal error: Call to undefined function vbet_vbseo_filter_replace_text() in /var/www/vhosts/forum.com/httpdocs/vbseo/includes/functions_vbseo_createurl.php on line 47

I just modified .htacces , set 'Link Type' to VBSEO_URI and turned on vBET SEO links an now works fine

Thanks

vBET
01-07-11, 21:51
It suppose to work even without SEO links (still SEO links are much better for your forum and it is advise to use it). Thanks for error message I will fix it to work even without SEO links.

EDITED
I just checked it – this function is used only for integration with vBSEO, so it is OK. Both vBET and vbseo team advice SEO links. That is why we assume that anyone who cares for links translation will also care about SEO type. So no changes in vBET for that as long as no one will tell that he must have it without SEO links (what do not have sense ;)).

Once again thanks for your confirmation – solved :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Multilingual community supported by vBET Translator PRODUCER_PRODUCT_VERSION