PDA

View Full Version : vBSEO Sitemap: Cannot run sitemap generator directly: you should be logged in to do this.



wowglider.de
17-06-11, 12:07
Hello,
i installed a fresh version of Vbulletin, Vbseo, VbseoSitemap, Vbet - all newest versions on http://www.bitcoins-deutschland.de (Bitcoins Forum Deutschland (http://forum.bitcoins-deutschland.de)) .

Now I have some serios issues with the Vbseo Sitemap.

1.) I often cant reach the "vBSEO Sitemap Reports" Link
I need to login, click ok or enter and it says please login again, i login, then it says again please login and so on.

2.) At some point i can successfull loggin, but then i get the next error. I want to run the Sitemap generator thru "Run Gernerator" but then it says "Cannot run sitemap... (see title)".

I just did these changed on the Vbseo Sitemap:
Sitemap Generator integration - vBulletin Enterprise Translator (vBET)

Edit:
I also cant click the other Buttons like Download Log... i need to login all the time and then im back on the start screen of VbSeo Sitemap.

Edit2:
I disabled vBet and it still not working. I dont think its about my .htaccess:


RewriteEngine On
RewriteRule ^((urllist|sitemap).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]
RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]
RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]
RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]
RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap|api\.php)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]

I think its about the changed done to get the sitemap working for vBet.

vBET
17-06-11, 14:40
If it is ok for you then please PM access details - I will check it on place.

If not then:
1. Login issue
Most probably it has nothing common with vBET, because vBET code changes are inside vBSEO files and you cannot even reach those.
Also this login page is from vBSEO CP - you have to log in their subsystem - it has nothing common even with vBulletin.

My advice here. Please copy your integrated vBSEO files. Restore original ones. Disable vBET for a moment. Comment vBET rules in .htaccess and check how it behaves now. If same as before then it has nothing to do with vBET, and vBSEO team will have to support you. I know they are against vBET, but this is only lies propaganda (you can see something interesting here if you want: Do not believe vBSEO team (http://www.vbulletin.org/forum/showpost.php?p=2208950&postcount=1349)).

When you will have vBET disabled, rules commented and changes reverted they will have to support you. And after that you will easily turn back to vBET - just uncomment rules in .htaccess, restore copied files, and enable again in Admin CP

2) This is same issue as 1 - you loose login credentials on your server
Maybe it is only some issue with your browser. Please try to clean your cookies or use other browser.

About Edit2:
If you want completely disable vBET then:
1. disable in Admin CP
2. comment rules in .htaccess
3. restore original vBSEO files

As I wrote I also doubt it has anything common with vBET. But is you disable vBET completely and issue will be gone, then please PM access details and I will check it (please note that next week I'm on vacation - Kamil will be active on forum).

vBET
17-06-11, 15:25
One more thing. Please remember that vBET is not supporting translation of Admin CP. So this can be also the issue. Please make sure that your admin account have set his default language same as forum language (or not at all). And please make sure that you do not have opened in other tab translated forum. Otherwise you can get redirect during logging in Admin CP area.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.2 gives automatic translations