PDA

View Full Version : Solved Activate/Deactivate vbet without trouble



Simon Lloyd
26-05-11, 08:44
Hi, in you next release can you make it so that at least for testing purposes vbet can be disabled, if i disable it right now i cannot get on to my site at all and have to mess with the .htaccess ...etc in order to make the forum useable.

There should be a way of Activating or Deactivating vBET easily just like many other mods, this kind of integration would be very valuable for users and troubleshooters.

kamilkurczak
26-05-11, 20:49
hello,

First of all - if you disable vBET - our rules in htaccess are not working - why? because you don't have flag code in url.

secondly, if you have vBET integrated with vBSEO - we don't have any options - you can only replace old vBSEO files again (vBSEO system don't have hooks system ).

at the end - your forum after disable of vBET should works normal (any blank screens, etc)
if you have a blank screen after disabling of vBET - check in your server log files for some errors - We will check it.

vBET
26-05-11, 22:20
Just like Kamil wrote - when vBET is disabled rules in .htaccess shouldn't harm anything.

Also true about vBSEO integration - there is no hooks system so file changes are needed.

This is not feature request. Disabled vBET should be harmless, if it is not, then please rapport a bug and we will check it :) I'm moving this thread to bugs section. Please give more info (if you see white screen, there must be error in logs) so we will be able to work on it.

Simon Lloyd
27-05-11, 07:58
Michal it's not a bug, this is my point there is no way to simply disable vBET, other mods will have:
Activate Product?
Yes No

And you would select the one you want and then save in admincp, this function does not exist in vBET which is why i made a FEATURE request, so you could add that feature in future :)

kamilkurczak
27-05-11, 10:17
you can enable or disable vBET in admincp->plugins->manage products - you have the same results

Simon Lloyd
27-05-11, 10:41
Ok i accept that but it would be nice to have it within the mod in vBET Main :)

kamilkurczak
30-05-11, 18:15
what do you think that this options is necessary?

Simon Lloyd
30-05-11, 18:45
I don't know what others think Kamil, but for me i believe it is especially for new forum owners who wouldn't know to go to Plugins & Products>Manage Products>disable your product, most would just look for the "turn it on/off" option in AdminCp>vBulletin Options.

kamilkurczak
31-05-11, 20:55
what about issue after disabling of vBET? can you confirm that this issue still exist ?

Simon Lloyd
31-05-11, 21:01
The only issue that exists when disabling vbet then re-enable is that the lang code tags are no longer parsed like this http://www.thecodecage.com/forumz/members-worksheet-functions/208989-cell-reference-from-the-numerical-code-to-industry.html#post1054986448 i just disabled vBET to try and then re-enable and a previously parsed [lang] tag is no longer parsed or translated

kamilkurczak
31-05-11, 21:13
yes, thats right - because this lang tags are in database (to remember the language) and vBET parser is disabled.
Please, make a new thread in Features Request with this proposition, this thread is solved and I will move it to troubleshooting section
Thanks:)

Simon Lloyd
31-05-11, 21:20
Kamil, thanks but the lang tags now no longer show the translated language after disabling then re-enabling vBET, in other words, vBET is turned back on but previously translated posts are no longer translated?

kamilkurczak
31-05-11, 21:41
if you disable vBET - langs tags are not parsed,
if you enable vBET once again - langs tags are parsed :)

only if you have vBET disabled langs tags are not parsed and message not translated:)

Simon Lloyd
31-05-11, 21:42
After vBET is disabled and the enabled again maintainance tools>Rebuild thread information must be run in order to reparse the [lang] tags

Simon Lloyd
31-05-11, 21:44
Solved now after running maintainance tools but it should be something that you put in your instructions or FAQs :)

kamilkurczak
31-05-11, 21:49
thanks for your confirmation :) solved now

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.2 gives automatic translations