PDA

View Full Version : Solved After install problems with translations



samm1129
22-05-11, 05:13
Hi, i have followed instructions and was able to install the mod. Whenever I am browsing in english, no issues, when i switch to another language in the forum root directory, no issues as well. However if i am click on the topic, or a post the forward slash that has to be like this /forum/iw/topic shows up like this /forum//iwtopic
I have uninstalled it several times, tried 3.36 as well as 3.4 and receiving same issue. Has anyone seen this and knows by chance how to resolve it?

thanks,
Sam.

vBET
22-05-11, 16:52
Hello. I think you have configuration issue. Please look carefully on your configuration for parameter Forum directory. What value you have for it? Please note parameter description:

Set with '/' at the beginning and without any '/' at the end, i.e. '/forum'
If you have it configured wrong, please change it to appropriate one. If you have this one ok, then we will investigate it more. Also please note that you do not have to uninstall it. You can just disable vBET is issue will still exists - we will need it installed to investigate it.

Please write did it help?

samm1129
22-05-11, 21:02
thats exactly how it's setup, and as i mentioned it works fine if i load h0ld.com/forum/ and then click translate to any language however, if i go deeper into the actual topic, for instance: h0ld.com/forum//zh-CNmazda/ instead of:
h0ld.com/forum/zh-CN/mazda/

samm1129
22-05-11, 21:03
my .htaccess looks like this:

# Comment the following line (add '#' at the beginning)

# to disable mod_rewrite functions.

# Please note: you still need to disable the hack in

# the vBSEO control panel to stop url rewrites.

RewriteEngine On



# Some servers require the Rewritebase directive to be

# enabled (remove '#' at the beginning to activate)

# Please note: when enabled, you must include the path

# to your root vB folder (i.e. RewriteBase /forums/)

RewriteBase /forum/



RewriteCond %{HTTP_HOST} !^www\.h0ld\.com

RewriteRule (.*) http://www.h0ld.com/forum/$1 [L,R=301]



RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]



#RULES for SEO translation links with vBSEO (have to be included before all rules to vbseo.php)

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/index.php [L,QSA]

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forum/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)

RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]



RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/

RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]



RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap|api\.php)

RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]



RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/

RewriteRule ^(.+)$ vbseo.php [L,QSA]

vBET
22-05-11, 22:38
At this moment you do not have vBET active on your forum, so I'm not able to check it. If URLs are generated wrong, then it is not .htaccess issue. If those are generated right and redirection happens then it is .htaccess issue. Please install and configure vBET on the forum (you can disable) and PM access details to your forum (Admin CP and FTP), we will check what happens. If it is not configuration issue, then we will need to change by logs why it behaves like this on your server. We will check it and we will solve it :)

samm1129
22-05-11, 22:40
it is active.

samm1129
22-05-11, 22:48
PM sent**********..

vBET
24-05-11, 18:12
Solved. You had wrong vBulletin configuration! You set '/' at the end of parameter Forum URL which is clearly described:


URL of your forum.
Note: do not add a trailing slash. ('/')

Please configure your forum carefully :)

samm1129
24-05-11, 21:11
you guys are awesome :-) Thanks for quick fix. Great support.

kamilkurczak
24-05-11, 23:29
thanks for your confirmation :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages supported by vBET Translator 4.9.2beta