PDA

View Full Version : Solved XCACHE warnings if not logged in



Lundgren
15-05-11, 22:57
vBET 4.3.0

When trying the XCACHE function, I get warnings when viewing the site without being logged in. But I get no warnings if I am logged in.


Warning: xcache_get() [function.xcache-get]: xcache.var_size is either 0 or too small to enable var data caching in [path]/includes/vbenterprisetranslator_class_cache.php on line 125

Warning: Cannot modify header information - headers already sent by (output started at [path]/includes/class_core.php:5403) in [path]/includes/vbenterprisetranslator_functions_guestcache.php on line 65

Warning: Cannot modify header information - headers already sent by (output started at [path]/includes/class_core.php:5403) in [path]/includes/vbenterprisetranslator_functions_guestcache.php on line 71

Warning: xcache_set() [function.xcache-set]: xcache.var_size is either 0 or too small to enable var data caching in [path]/includes/vbenterprisetranslator_class_cache.php on line 128

kamilkurczak
17-05-11, 08:07
hello,

What about your guest cache? do you have enabled it or not?
Please disable Xcache and test it on the file guest cache only - and write that the issue is still there or not
Thanks

Lundgren
17-05-11, 09:40
The warnings disappear immediately when I disable XCACHE for vBET.

Guest cache is active (Use Full File Cache For Guests: Yes)

I have not found a good way to verify if I have set up XCACHE properly (it is installed with the apt package on a Debian). So it is a possibility I have a general XCACHE issue on my installation.

kamilkurczak
18-05-11, 20:25
ok so I will try to reproduce it on my test forum.

kamilkurczak
18-05-11, 21:05
hello,

this notice: Warning: Cannot modify header information is caused by the first issue. You need to check you xcache configuration. maybe you need to set xcache.var_size to the higher value (and reset apache after that).

secondly, I found a article which describes the same issue, so according to this article you need to check by phpini() that you may not have saved the cache twice - please check here: php - Xcache var_size error - Stack Overflow (http://stackoverflow.com/questions/2976829/xcache-var-size-error)

kamilkurczak
26-05-11, 22:32
no answer - solved. If not - please write here and I will open this thread again

Lundgren
27-05-11, 00:06
weird... I saw your first reply, but not the second one.

Just tried it, and it worked :)

I changed xcache.var_size to the same value as xcache.size

So now it is confirmed solved instead of closed due to no response. :o :)

kamilkurczak
27-05-11, 10:23
Great :) thanks for your confirmation :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.99 brings automatic translations