PDA

View Full Version : Solved Does not strip away the no-translate tag for TITLE, default language



Lundgren
15-05-11, 22:37
vBET 4.3.0 seems to handle the < !--vBET_SNTA--> (minus the space of course) tag wrong for the TITLE tag in forum home.

If I use the no translate tag, the tab in the browser present correctly an untranslated text for translated languages. But for the forum default languge (at least when it is english) shows the tags in the tab. vBET misses to strip away the tag.

Firefox 4.0.1 and Opera 11.10

kamilkurczak
17-05-11, 08:06
hello,

Please - I need url to the thread or page with this issue :)
Thanks

Lundgren
17-05-11, 09:50
PM with url sent :)

vBET
29-05-11, 14:58
Are you using notranslate tag in thread title? It shouldn't be used there! Please note that ti you want to keep title not translated then you must use langtitle with language code which doesn’t exists, in example [ langtitle=not] (without space). Please note that vBulletin do not support tags in titles at all. We made lot of effort to support langtitle tag in title and this is only tag supported in title. For reliability and performance we support not translation of title by same bbcode as for translation - so by langtitle bbcode.

Please tell did it help. If I misunderstood something, then please send URL to page when we can see the issue.

Lundgren
31-05-11, 08:38
No, I am not talking about the Thread Title. I'm talking about wrapping vboptions.bbtitle with the VBET_SNTA tag in the FORUMHOME template part.

When looking at a translated page, everything is correctly handled; so the addon is definitely reading the tag there. :) But when I look at the forum page with the forum default language; it is correctly handled everywhere but the one wrapped in the HTML-tag TITLE, where it does not strip away the tag when it is not needed.

So what I am trying to keep untranslated is the forum name (Option -> Site Name -> Forum Name).

I send you a PM with a link.

vBET
02-06-11, 13:28
OK I see it after you send link in PM. Two things:
1. It is harmless, because it is just html comment
2. Of course we will check it closer and correct - son I will give you more details.

vBET
03-06-11, 21:32
Reproduced and solved :) Solution will be included in next release.

For quick fix please:
1. Open /includes/vbenterprisetransaltor_functions_hooks.php
2. Find:

$output =& str_replace(array('<!--vBET_SNTA--><!--vBET_NRE-->', '<!--vBET_ENTA-->'), '', $output);
3. Replace by:

$output =& str_replace(array('<!--vBET_SNTA-->', '<!--vBET_NRE-->', '<!--vBET_ENTA-->'), '', $output);

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations supported by vBET 4.9.99