PDA

View Full Version : Solved Error message when translating - any help?



cactusjack
06-12-09, 17:25
Hi,

I hope someone can help.

I'm trying to install vBET (the latest free version from vbulletin.org, 2.35) on my forum, but any time I try to translate a page, I get the message:

Fatal error: Call to undefined function: iconv() in /home/<forumname>/public_html/includes/vbenterprisetranslator_functions.php on line 258

I've tried the following:
1. I've changed my forum language to English
2. I've tried with, and without, a google API key
3. I've contacted my hosting company, and they assure me that cURL and IconV are installed and working.
4. I tried following the steps in post #4 of the FAQ, but it doesn't return anything.

Is there any help you can offer? I'm using vbulletin 3.8.4

vBET
10-12-09, 21:54
You need to install ICONV in your php - this answer you will also find in http://www.vbenterprisetranslator.com/forum/troubleshooting/6-faq.html#post7

cactusjack
11-12-09, 00:20
Thanks for the reply, I appreciate it.

I did speak to my hosting company after reading that bit of the FAQ, as I said in my original post, and they assured me that IconV was installed. I'll try speaking to them again though.

vBET
11-12-09, 01:12
As you can clearly see in your error message:
Call to undefined function: iconv()

You do not have iconv installed. Instead of discussing with them - just give them link to page on which they will see that iconv is not available for your forum.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Thanks to vBET 4.9.99 enjoy automatic translations