PDA

View Full Version : Solved Some strange problem.



Taurus
22-04-11, 02:03
When trying to go to this thread:

Background windows transparent? (http://creativx.net/forums/having-problems/46841-background-windows-transparent.html)

I get the following, twice at the top of my page, and the rest of the page does not open. Please advise.

Warning: strpos() [function.strpos (http://creativx.net/forums/having-problems/function.strpos)]: Offset not contained in string in [path]/includes/vbenterprisetranslator_functions.php on line 408

Thanks.

kamilkurczak
22-04-11, 18:41
hello, I have solution for you - NOT TESTED YET - so please make a copy of edited file!

1. open and make a copy of this file:
forum root/inlcludes/vbenterprisetranslator_functions.php
2. in this file find:

$closePosition = strpos($outputPart, '>',$openPosition + 1);
3. and replace with:

if(strlen($outputPart) > 1)
{
$closePosition = strpos($outputPart, '>',$openPosition + 1);
}
else $closePosition = false;
4. save a file and test it.

secondly - please give me a hint how to reproduce this issue on my test forum, may be this is a bug.

Thanks

kamilkurczak
03-05-11, 16:51
no answer - solved. If not, please write here and I will open this thread again.
Thanks

Taurus
03-05-11, 17:00
My apologies for the late reply. I made the changes. But it made no difference. And I don't know how to reproduce it, it happens only in this thread. Thanks.

I still get this:

Warning: strpos() [function.strpos (http://creativx.net/forums/having-problems/function.strpos)]: Offset not contained in string in [path]/includes/vbenterprisetranslator_functions.php on line 410

Warning: strpos() [function.strpos (http://creativx.net/forums/having-problems/function.strpos)]: Offset not contained in string in [path]/includes/vbenterprisetranslator_functions.php on line 410

kamilkurczak
03-05-11, 17:47
hmm try to clear cache for this language and test it again. If still nothing - I will check it once again

Taurus
05-05-11, 03:16
Sorry Kamil, but how do I clear the cache for one language? Thanks for the help!

kamilkurczak
05-05-11, 08:45
just go to admincp->vBET cache->cache cleaner, select one language and select Clean Guest Cache Files and continue ;)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Thanks to vBET PRODUCER_PRODUCT_VERSION you can enjoy automatic translations