PDA

View Full Version : Solved Advanced search shows no results



norku
22-03-11, 09:44
I've just noticed that when I log in on a test account which has German set in the user cp (forum default language is English) that I get no advanced search results returned for some terms which do indeed return results in the default language. I'm guessing that this might be happening in other languages too.

This happens on my own account too. I just used advanced search to look for a word (Bannführer) and got results using the forum default language of English. I then switched the language to German (by clicking on the flag under my navbar), performed the same search and got no results for the same word. Any ideas?

norku
22-03-11, 09:54
Just to take the scenario out of the equation I went to my Usercp and changed my default language to German, performed the same advanced search and again I got no search results. Not good if foreign language speakers can't search in their own language of course.

Edit: just tried a couple of the other languages and although the words I enter into the search are visible when the foreign language speaker is reading the forum they are not returned in the advanced search result.

kamilkurczak
22-03-11, 10:11
I was on your site. In my user details I have languege - Polish.
I used your advanced search to search word - "forum". and I have a full site of results.

Can you explain it better?

norku
22-03-11, 10:17
Some terms do work as you say but switch to German and try Bannführer and Stammführer for example. No results. Switch to Norwegian and search for bronse. No result although I have a thread with that word in the title when I view the forum in Norwegian...?

kamilkurczak
22-03-11, 10:51
You are right!
I can reproduce it on my test forum so I will move this into bug section.

There is probably issue with encoding - I will check it and fix on my test forum.
Thanks

norku
22-03-11, 10:58
Thanks Kamil.

kamilkurczak
22-03-11, 21:35
still working on it

vBET
04-05-11, 00:52
Corrected and will be included in next release. Please note that at this moment we only changed required data (there was encoding issue) testing on thread search. If you find it not working for additional filters please notify it to us.

Quick fix - at this moment you can fix it by adding new plugin:
- Go to Admin CP -> Plugins & Products -> Plugin Manager -> Add New Plugin
- Set:

Product=vB ENterprise Translator
Hook Location=search_process_start
Title=Correct search criteria for translated pages
Execution Order=5
Plugin PHP Code:


if ($_REQUEST['language'] && vB_Template_Runtime::fetchStyleVar('charset') != 'utf-8') {
$vbulletin->GPC['query'] =& vbet_encodeToSafeUTF8($vbulletin->GPC['query']);
}

Plugin is Active=Yes

- save and check does it work

In case you will find any additional issues in this area please write we will reopen the issue then. On our test forum it's working well :)

norku
06-05-11, 10:19
Hi,

Just tested the plugin and unfortunately it isn't working. Here's an example:

If I switch to French, for example, and enter "Jeunesses Hitlériennes" into either search or advanced search I get no results. However, if I enter "Hitler Youth" I then get a list of results containing "Jeunesses Hitlériennes"'. This happens regardless of whether your plugin is active or not. This is obviously not the way a french user would normally search. He wants to search in his own language of course and wishes to see results returned in that language.

kamilkurczak
06-05-11, 19:38
hello,

I was on your site and tested it. everything is working good. if you try to search your sentence by not translated advanced search - no results too.

I tried to find a Führerschnur word on all languages on your site and I had a results for all languages, so issue is solved.

you can disable vBET and try to find your sentence once again - still no results so this is not vBET bug.

:)

norku
07-05-11, 22:18
Hi,

No, you're not searching correctly. "Führerschnur" only appears in the search results because it is not always translated by Google i.e. the term "Führerschnur" appears on the Japanese version of my forum, the French, the Russian etc etc. That's why it is returned on a search. You need to search for a translated term - something you can see on the forum when you switch to a different language.

Try the search as I described in post #9 above... you'll see what I mean.

norku
14-05-11, 12:58
Any news on this chaps?

norku
17-05-11, 09:25
Bumping this again as the thread is still marked as 'SOLVED' even though the problem remains.

vBET
17-05-11, 11:51
Hi. Sorry Kamil have to miss your response. Please note that the bug was in encoding so there was no results at all form translated pages. This was corrected and that is why issue was considered solved.

About searching results - vBET do not support at this moment translation for searched phrase. Please open new thread in feature request with this :)

norku
18-05-11, 09:58
Will do Michal. Thanks.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations delivered by vBET 4.9.2