PDA

View Full Version : Solved Occassional Problems With URL Conversion



simit patel
25-11-09, 18:06
Hello,

I have been using vbet since the 2.X branch, and have been upgrading along the way. i just upgraded to 3.2.2.

now, when i click on the flags, i notice the URL changes as well. however, sometimes the page loads properly, but other times, i simply get a white page that says "page not found". my site is informedtrades.com. i have vbseo installed as well.

i saw some people reporting similar experiences, but i did not see anyone talking about it occurring only some of the time, nor did i see people who only had a problem after this recent upgrade. sorry if this was already dealt with and i missed it.

any ideas on how to fix the problem?

thanks
simit

vBET
25-11-09, 20:44
Hi. I think I found the pattern. On your forum links which have special characters are claimed to be not found. I do not know why yet.

We are not able to reproduce it on our servers (as you can see here it is working well) so please PM me access details to your Admin CP and FTP.

jorgejgm
26-11-09, 00:03
Hello,

I have been using vbet since the 2.X branch, and have been upgrading along the way. i just upgraded to 3.2.2.

now, when i click on the flags, i notice the URL changes as well. however, sometimes the page loads properly, but other times, i simply get a white page that says "page not found". my site is informedtrades.com. i have vbseo installed as well.

i saw some people reporting similar experiences, but i did not see anyone talking about it occurring only some of the time, nor did i see people who only had a problem after this recent upgrade. sorry if this was already dealt with and i missed it.

any ideas on how to fix the problem?

thanks
simit
Hello, I also happened once, but if you reload the page again and does it well. The truth that is rare, greetings.

vBET
26-11-09, 04:55
The truth is that it doesn't matter for as is it rare - it shouldn't happen at all and we will do our best to make it works all the time :)

simit patel
26-11-09, 16:18
i reverted to vbet 312, that works fine. so, the issue is related to some difference between 312 and 322. also, when i reverted to 312, the first thing i did was a product overwrite. the problem still persisted. then, when i uploaded the files of 312, that seemed to solve the problem. so, perhaps the problem relates to a file edit made between 312 and 322.

also worth noting is that i have vbblogs installed. this was not impacted at all; URLs in blogs were not being written in foreign characters. neither in 322, nor in 312.

i'd really like to take advantage of the new features in 322. is there anyway i can do that in light of the situation?

thanks
simit

ADDED: and of course i have the latest version of vbseo installed.

vBET
26-11-09, 16:23
It is not best idea to made reinstalls when support is on your board...

Also I find out that this is an issue with vBSEO configuration. The patterns which you have for thread will not allow for foreign signs:


'VBSEO_URL_THREAD' => '(\d+)-([a-z\._\-ŠŽšžźŔÁÂĂÄĹÇČÉĘËĚÍÎĎŃŇÓÔŐÖŘŮÚŰÜÝŕáâăäĺçčéęëěíîďńňóôőöřůúűüý˙µA-Z\d-]+)\.html',


it should be something like this:


'VBSEO_URL_THREAD' => '([^/]+)/(\d+)-([^/]+)\.html',


But DO NOT change it manually. Such pattern is in many places in vBSEO configuration. Please PM me access details to your vBSEO CP and I will find out which configuration parameter is responsible for this.

vBET
26-11-09, 16:38
The reason is wrong vBSEO configuration.

Set option "Replace Non-English Characters in URLs?" to "Keep Non-English Characters in URLs".

This mysteriously disappear from our integration manual. Sorry for troubles :) just set parameter and it will be fine :)

jorgejgm
26-11-09, 17:28
The reason is wrong vBSEO configuration.

Set option "Replace Non-English Characters in URLs?" to "Keep Non-English Characters in URLs".

This mysteriously disappear from our integration manual. Sorry for troubles :) just set parameter and it will be fine :)

For Spanish there is a problem with the letters THIS LETTERS Ñ, ó, í, etc etc (THE TRANSLATE REMOVE TO N, o,I .Having activated "replace the non-English characters" vbseo replaced by the letter N or (I) in the URL. This is very good for seo.With the option "Keep Non-English Characters in URLs" characters are replaced by ~. Something that affects the seo much. For future revisions of VB will be "solved" or is technically impossible?.Thank you.

vBET
26-11-09, 20:12
Having activated "replace the non-English characters" vbseo replaced by the letter N or (I) in the URL. This is very good for seo.With the option "Keep Non-English Characters in URLs" characters are replaced by ~. Something that affects the seo much. For future revisions of VB will be "solved" or is technically impossible?.Thank you.

This is done by vBSEO - vBET does not made such replacements. You have to appropriately configure vBSEO. You can have option to keep not Espagnol characters ans also configure manually in FORUM_DIR/inclues/config_vbseo.php parameter $vbseo_custom_char_replacement. Thanks that you will be able to work with translated URL's and keep your existing URL's for native language as those where.

Look here:

http://www.forum.simple-nlp.pl/informacje/1274-pierwsze-na-swiecie-forum-o-nlp-wspierajace-wielojezyczna-spolecznosc.html

This is URL where Polish letters (like śąęć) was changed thanks to $vbseo_custom_char_replacement and it still keeps all other not English letters. This is same link for Japanese:

http://www.forum.simple-nlp.pl/ja/informacje/1274-nlp多言語のサポートのための世界初のフォーラム!.html

Also this is good example why you should keep not English/Espagnol characters - some languages have noly not English/Espagnol characters.

This is example how you can set $vbseo_custom_char_replacement value (for Polish letters):


$vbseo_custom_char_replacement = array(
'ˇ' => 'A',
'¦' => 'S',
'¬' => 'Z',
'±' => 'a',
'¶' => 's',
'Ľ' => 'z',
'ą' => 'a',
'ę' => 'e',
'ć' => 'c',
'ż' => 'z',
'ś' => 's',
'ź' => 'z',
'ó' => 'o',
'ł' => 'l',
'ń' => 'n',
'Ą' => 'A',
'Ę' => 'E',
'Ć' => 'C',
'Ż' => 'Z',
'Ś' => 'S',
'Ź' => 'Z',
'Ó' => 'O',
'Ł' => 'L',
'Ń' => 'N'
);


So as you see - you can keep god SEO way for your existing links and open for translated links in 52 languages :)

I hope this will help in case of any other questions just ask - we are here to help you :)

jorgejgm
26-11-09, 21:27
Thank you very much again, works perfect. Thank you.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Thanks to vBET 4.9.99 you can enjoy automatic translations