PDA

View Full Version : Solved Memory issues



norku
15-03-11, 16:40
I don't know whether this is Vbet-related but it began to happen after I installed it so I'm going to ask here :)

I'm getting the following errors when clicking on the Vbseo 'Likes received' and 'Likes Given' buttons on the user profile page:


Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 200593 bytes) in /home/xxxx/public_html/forum/includes/functions.php on line 6862


Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 491520 bytes) in /home/xxxx/public_html/forum/includes/class_core.php(4430) : eval()'d code on line 458

As I say, this started happening after installing Vbet but I think I'm going to need some coaching here because the figures don't fit the symptoms.

Memory info:

From phpinfo: memory_limit Local - 128M Master - 128M

From php.ini:
; Suhosin Settings.

suhosin.post.max_vars = 2048

suhosin.request.max_vars = 2048

suhosin.cookie.encrypt = Off

suhosin.memory_limit = 32M

suhosin.session.encrypt = Off

Vbulletin: PHP Memory Limit 32M

Server Memory in use at the moment: 25.00% (262136 of 1048576)

The error messages are suggesting that I need to increase memory but I don't see any other symptoms of insufficient memory whilst using the forum and I have had no reports from my members. I assume however that they will also be seeing the 'Likes' fatal error.

Have you guys come across any problems like this whilst using Vbet? I'd be grateful for any tips on what to try.

kamilkurczak
15-03-11, 17:31
hello,
Ok I will test it on my test forum. You can simply try, that vBET making this issue - just disable vBET and try to do it again - If issue stil exist and vBET is disabled - this is not vBET issue. If issue will disappear - this is vBET issue and we will fix it.

Secondly - you can increase the limit of memory_limit in php.ini to 64 MB and restart your server. (please just read about this issue in google).
with vBET you have 52 more content and 52 more users on forum (if you have all languages enabled) - cost of server memory. We are still workin to make vBET more efficient (new relase very soon).
Here you have a list of hinst:http://www.vbenterprisetranslator.com/forum/vbet4-general-discussions/408-vbet-performance.html


Thanks

norku
15-03-11, 18:13
Thanks. I'd be interested in your results. I disabled Vbet and reloaded the 'Likes' page. Now I just get a blank white page - no memory error. Also not quite what I was after :)

I'll wait to hear what you discover on your test site before I up the memory setting in php.ini.

norku
15-03-11, 23:13
I edited my php.ini and increased the memory limit to 64M and then restarted Apache but vbulletin appears to be ignoring that setting and is still complaining that insufficient memory exists (same errors as I posted in post 1).

norku
16-03-11, 08:24
Hi,

Were you able to repeat the error? I can't understand why Vbulletin AdminCP is showing a 32M memory limit when php.ini has 64M.

kamilkurczak
16-03-11, 08:51
no, I can't reproduce it on my test forum (i clicked on likes buttons on user page).
Did you restart your server after change in php.ini?
Please ask about that your host provider

norku
16-03-11, 08:55
Yes, I restarted Apache after amending php.ini but it had no effect. Very odd. I checked my general memory usage and it was well below 32M anyway so very strange that I'm getting these memory errors. I've asked my host to look into this.

norku
16-03-11, 10:54
Solved. I had an incomplete php.ini in the root. All is working correctly now.

kamilkurczak
21-03-11, 21:42
ok for this confirmation :) solved

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Thanks to vBET 4.9.2 you can enjoy automatic translations