PDA

View Full Version : Solved Flag url is incorrect



norku
09-03-11, 23:06
If I enter
www.xxxxxx.com/forum/de/ manually into the browser address bar and hit enter all is good. However when I enable the German flag and hit that it btries to open
www.xxxxxx.com/de/forum/

Any ideas?

kamilkurczak
10-03-11, 10:16
I have some questions to you:
1. why you made this changes for vBSEO? described here:
http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/1513-cms-root-forum-forum.html#post7479
2. If you make a .htaccess in /forum will be not good?
3. you have this links because now in on .htaccess you have two groups of vBET rules:
- to translate main page
- to translate forum

Maybe we can make two .htaccess file? one like your old one and the second in /forum folder?

you can try it.
first .htaccess (the old one) placed outside forum folder:

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /


#RewriteCond %{HTTP_HOST} !^www\.hj-research\.com
RewriteCond %{HTTP_HOST} !(^www\.hj-research\.com$|^cdn\.hj-research\.com$)
RewriteRule (.*) http://www.hj-research.com/$1 [R=301,L]

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/forum/$1 [L,R=301]

RewriteRule ^forum/((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

#vbet translator rules start
#vbet outside site
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ index.php?language=$1&vbet_outside=true [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ $2?language=$1&vbet_outside=true [L,QSA]

RewriteCond %{QUERY_STRING} !vbet_outside=true
RewriteRule ^(.*)$ $1?vbet_outside=true [L,QSA]



#vbet translator rules end


RewriteCond %{REQUEST_URI} !(media/|admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(media|admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbseo.php [L,QSA]

## Expires
<ifModule mod_expires.c>
ExpiresActive On
ExpiresDefault "access plus 1 seconds"
ExpiresByType text/html "access plus 1 seconds"
ExpiresByType image/gif "access plus 3456000 seconds"
ExpiresByType image/jpeg "access plus 3456000 seconds"
ExpiresByType image/png "access plus 3456000 seconds"
ExpiresByType text/css "access plus 3456000 seconds"
ExpiresByType text/javascript "access plus 3456000 seconds"
ExpiresByType application/javascript "access plus 3456000 seconds"
ExpiresByType application/x-javascript "access plus 3456000 seconds"
</ifModule>

## Compression
<ifmodule mod_headers.c>
<ifmodule mod_deflate.c>
AddOutputFilterByType DEFLATE text/html text/css text/xml application/x-javascript
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
</ifmodule>
</ifmodule>

#Remove index.php from hj-research.com/index.php
#rewrite engine on
RewriteCond %{THE_REQUEST} index\.php
RewriteCond %{QUERY_STRING} ^$
RewriteRule ^index\.php$ / [L,R=301]

and the second in /forum folder (only vBET rules):

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On


RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]


RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbenterprisetranslator_seo.php [L,QSA]



#vbet translator rules end

can you test it? I am waiting for conclusion. If still not - DELETE .htaccess from /forum folder and the old .htaccess replace with this one (because with this htaccess vBET works perfect for forum and not work for main page):

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /


#RewriteCond %{HTTP_HOST} !^www\.hj-research\.com
RewriteCond %{HTTP_HOST} !(^www\.hj-research\.com$|^cdn\.hj-research\.com$)
RewriteRule (.*) http://www.hj-research.com/$1 [R=301,L]

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/forum/$1 [L,R=301]

RewriteRule ^forum/((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

#vbet translator rules start

RewriteRule ^forum/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ forum/vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^forum/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ forum/vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^forum/((archive/)?(.*.php(/.*)?))$ forum/vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbenterprisetranslator_seo.php [L,QSA]

#vbet translator rules end


RewriteCond %{REQUEST_URI} !(media/|admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(media|admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbseo.php [L,QSA]

## Expires
<ifModule mod_expires.c>
ExpiresActive On
ExpiresDefault "access plus 1 seconds"
ExpiresByType text/html "access plus 1 seconds"
ExpiresByType image/gif "access plus 3456000 seconds"
ExpiresByType image/jpeg "access plus 3456000 seconds"
ExpiresByType image/png "access plus 3456000 seconds"
ExpiresByType text/css "access plus 3456000 seconds"
ExpiresByType text/javascript "access plus 3456000 seconds"
ExpiresByType application/javascript "access plus 3456000 seconds"
ExpiresByType application/x-javascript "access plus 3456000 seconds"
</ifModule>

## Compression
<ifmodule mod_headers.c>
<ifmodule mod_deflate.c>
AddOutputFilterByType DEFLATE text/html text/css text/xml application/x-javascript
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
</ifmodule>
</ifmodule>

#Remove index.php from hj-research.com/index.php
#rewrite engine on
RewriteCond %{THE_REQUEST} index\.php
RewriteCond %{QUERY_STRING} ^$
RewriteRule ^index\.php$ / [L,R=301]

norku
10-03-11, 11:03
Hi,

I'll look into this now. Thanks. Can you expalin exactly what these htaccess files do?

kamilkurczak
10-03-11, 11:05
please, check PM.

You made a bad .htaccess.
you pasted vBET rules on the end of file! that was bad - please make a htaccess files like from my previoust post

norku
10-03-11, 11:10
I didn't. I removed them. I have now uploaded your htaccess from the post above and the server error is now rectified. There is a problem with sitemaps which I noticed earlier. They cannot be found by google

kamilkurczak
10-03-11, 11:16
please if you can - answer on my questions one by one - will be easy to find the best solution.
http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/1521-flag-url-incorrect.html#post7535

norku
10-03-11, 13:09
I made the changes HERE (http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/1513-cms-root-forum-forum.html#post7479) because I wanted a more consistent structure without having to move the vb suite to the root. It works nicely but with vbet there are clearly problems if a forum has my configuration.


With vbet enabled I am currently seeing the following problems:

1. Foreign characters are not recognised when I perform a search on the forum (the /de/ version of the forum). Try searching for Düsseldorf. No results even though I have results on the forum. Look at the way the word 'Düsseldorf' is returned on the search page. If I go to the english (default) version of the forum and perform the same search I get the correct results.

2. This is currently in the google index: http://ww w.xxxx.com/forum/f34/faehnlein-standard-bearer-insignia-wear-3514/ but look at the url when that page opens on my forum.

3. Sitemaps are not being seen by google webmaster tools. I have not made any of the changes detailed here: http://www.vbenterprisetranslator.com/forum/vbet4-integration-other-plugins/415-sitemap-generator-integration.html

4. View the english version of the forum and go to this url: http://w ww.xxxx.com/forum/f27/hj-gebietsjugendtag-düsseldorf-1933-schlageter-2060/ Page loads but with 404, url shows german character but if you right copy and paste that url you get: http://w ww.hj-research.com/forum/de/f27/hj-gebietsjugendtag-düsseldorf-1933-schlageter-2060/

5. I have set Replace Non-English Characters in URLs? to yes for now until this problem is resolved so you may need to set to 'keep non-English characters' to view the problems I have desribed above.

Looking forward to hearing from you.

kamilkurczak
10-03-11, 13:39
1, I will check it on my test forum
2. I tried this url and i can't see the issue - everything is good
3. so please integrate this sitemap using this instruction (from this url)
4. please, if you want to have seo links translated - integrate vbseo with vbet - edit two vbseo files - everything is described in readme.html file.
about option in vbseo - if you would like to translate seo links - you should set it like in readme.html because if you not set it - you will have 404 (if you integrate two vbseo files)

norku
10-03-11, 13:51
2. Yes, the url is the same but as I said at point 5 above you will need to set 'keep non-English characters in URLs' within vbseo to see what I mean. This setting is stipulated in your install instructions but does not work on my forum.

4. Those changes are already implemented. If you look you'll see that the files are on the server. The '...._old.php' files are the standard vbseo files. The vbet versions of those files are currently active.

Until the non-English character problem is solved I'm not going to mess around with the sitemap unless you can tell me that the current problem (google can't see my sitemaps) is because I haven't yet applied the changes here (http://www.vbenterprisetranslator.com/forum/vbet4-integration-other-plugins/415-sitemap-generator-integration.html)? If yes then I'll change that file but I need to know exactly why the sitemaps are not being seen by google before I do anything because I don't want to give google a load of incorrect URLs.

kamilkurczak
10-03-11, 14:32
ok I see when translation of url is enabled - you have 404.
according to the readme.html instruction you should have - Keep Non-English Characters in URLs. If not work - please disable it. I will chek it for you but I need access to vbseocp.

2. about sitemp. Maybe this is not detected by google because I made for you .htaccess in /forum folder. We can simply test it. Just disable vBET and delete .htaccess from /forum. comment vbet rules in main .htaccess and restore old vbseo files. After that (when vBET is completly disabled) check this sitemap and we will knot that vBET provide this issue or not.

3. This evening I will check for you configuration and integration with vBSEO
:)

norku
10-03-11, 14:44
Thanks. I have disabled 'keep non-English characters in URLs' for now and will carry out the steps you mentioned for the sitemap. I'll let you know how it went.

Looking forward to hearing from you later.

norku
10-03-11, 14:57
Update: after disabling Vbet in accordance with your post above Google now sees my sitemaps.

kamilkurczak
10-03-11, 16:25
ok, so now I know why we can't use .htaccess in /forum folder :)

another test. just enable vBET again, add this htaccess in main folder (replace with the old one (NOT IN /FORUM FOLDER)):

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /


#RewriteCond %{HTTP_HOST} !^www\.hj-research\.com
RewriteCond %{HTTP_HOST} !(^www\.hj-research\.com$|^cdn\.hj-research\.com$)
RewriteRule (.*) http://www.hj-research.com/$1 [R=301,L]

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/forum/$1 [L,R=301]

RewriteRule ^forum/((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

#vbet translator rules start

RewriteRule ^forum/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/$ forum/vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^forum/?(af|sq|ar|hy|az|eu|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|ka|de|el|ht|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|ur|vi|cy|yi)/(.*)?$ forum/vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^forum/((archive/)?(.*.php(/.*)?))$ forum/vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbenterprisetranslator_seo.php [L,QSA]

#vbet translator rules end


RewriteCond %{REQUEST_URI} !(media/|admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^forum/((archive/)?(.*\.php(/.*)?))$ forum/vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(media|admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ forum/vbseo.php [L,QSA]

## Expires
<ifModule mod_expires.c>
ExpiresActive On
ExpiresDefault "access plus 1 seconds"
ExpiresByType text/html "access plus 1 seconds"
ExpiresByType image/gif "access plus 3456000 seconds"
ExpiresByType image/jpeg "access plus 3456000 seconds"
ExpiresByType image/png "access plus 3456000 seconds"
ExpiresByType text/css "access plus 3456000 seconds"
ExpiresByType text/javascript "access plus 3456000 seconds"
ExpiresByType application/javascript "access plus 3456000 seconds"
ExpiresByType application/x-javascript "access plus 3456000 seconds"
</ifModule>

## Compression
<ifmodule mod_headers.c>
<ifmodule mod_deflate.c>
AddOutputFilterByType DEFLATE text/html text/css text/xml application/x-javascript
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4\.0[678] no-gzip
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
</ifmodule>
</ifmodule>

#Remove index.php from hj-research.com/index.php
#rewrite engine on
RewriteCond %{THE_REQUEST} index\.php
RewriteCond %{QUERY_STRING} ^$
RewriteRule ^index\.php$ / [L,R=301]

as you know with this htaccess vbet is working only on forum pages.
test it. and check that google can see your sitemap

thanks

norku
10-03-11, 16:39
Thanks. I'll try that now.

norku
10-03-11, 17:14
Tested. Only the main forum page translates (as you said it would) but the sitemap is accepted by google. The sitemap wasn't however any bigger than normal and didn't contain any foreign language urls.

The foreign language urls are still not correct on my forum and continue to produce 404 pages despite my vbseo settings and files being the same as described in your setup procedure. They look fine but when you click on them they 404.

I accept that you guys can't cater for all vbulletin configurations and that my forum presents a non-standard installation of vb so I'm going to have to leave vbet disabled for now.

I hope that it will be possible at some point to get vbet working on my forum but at the moment I wouldn't be happy with a partial translation of my forum and non-working links.

Thanks for the time you've put into this though. It was much appreciated.

kamilkurczak
10-03-11, 18:16
ok, now I know more. so we can use only htaccess in main folder, not in /folder.

Please give me some time to find a solution. I must think about it and try some configuration.
Also please give me a password to vbseocp because I will be able to check vbseo configuration to eliminate 404 error :)

Thank:) I will solve it for you

norku
10-03-11, 18:18
PM is on the way :)

kamilkurczak
11-03-11, 10:57
I would like to summarize all changes.

1. integrate with google search engine - there was a encoding issue when page was translated. how to fix?

-go to admincp->style & templates->navbar template
-in this template find:

<input type="hidden" name="ie" value="ISO-8859-2"/>
- and replace with:

<input type="hidden" name="ie"<vb:if condition="$_REQUEST['language']"> value="UTF-8"<vb:else />value="ISO-8859-2"</vb:if>/>

2. issue with german letters in url on not translated page -> we should define character replacement in vbseo general options.

EXAMPLE:

'ü' => 'ue'
'ä' => 'ae'
'ö' => 'oe'
'ß' => 'ss'

3. about translation of main page - still working.

norku
11-03-11, 11:50
There is a problem with the characters. If the user sets the forum language to German in his profile and makes a post containing Ä ä Ö ö Ü ü ß the translation works when viewed in English. However, if he wants to edit his post he sees html numbers instead of letters.

In vbseo cp ****> 'Define your Custom Character Replacements' I currently have the following entered so that my indexed URLs still work:

'ü' => 'ue'
'ä' => 'ae'
'ö' => 'oe'
'ß' => 'ss'

However, what I really need to do is to enter

'(html number)' => 'ä' so that the edit problem is fixed. However, this will have an impact on my indexed URLs. Or am I missing something here?

I can only use one language at the moment because I have no Custom Character Replacements defined for the other (50!) languages.

Is there a way to get this working?

kamilkurczak
11-03-11, 12:01
You do not need to declare characters replacement in all languages - only for letters for language before installation of vBET (German).
Now all letters for other languages are good :)
If not - please give me an example (url)

secondly: acsii numbers in post edition -> please give me url to example.
which encoding your forum use? UTF-8?

norku
11-03-11, 12:18
Hi,

My character set: ISO-8859-1

I've sent a PM to you containing a link to a post showing the problem.

kamilkurczak
11-03-11, 12:35
you are right. This is a encoding bug. I can reproduce it on my test forum.
This is created only when somebody make post from translated page.
(remember - if you would like to post in French - you should have in your usercp French language set.

I tried to fix this bug from Yesterday - in generally on not utf forum vBulletin have a problem with encoding characters with ASCII code under 256.
I made a new thread in bug section on vBulletin forum and I will try to find a solution of this bug.

In generally if you made post in french (and have in usercp french language) from normal (not translated page) everything will be ok. This only happens when you try to post from translated page.

norku
11-03-11, 12:41
Ah, okay. Yes, I copied a section from the French Wiki and pasted it.

However, when I selected my forum language as German, and then posted in German, the characters still show as html numbers when I edit that post or click on the arrow in the translated post....?

kamilkurczak
11-03-11, 12:51
yes you are right. look to my two posts - the fisrt one is made from not translated page (english) - no problem when you would like edit it.

the second one is made from translated (polish) page and here is a problem - letters with ascii code under 256 - wrong encoding - I reported this bug to vBulletin and I will try to fix it to.

kamilkurczak
11-03-11, 13:17
I am working on it with vBulletin team:
Forum ASCII characters issue (http://www.vbulletin.com/forum/showthread.php/368237-ASCII-characters-issue)

Now we have a weekend. if it is ok for you can we start this topic after weekend?

During the weekend I will work with vBulletin team.

norku
11-03-11, 13:26
Yes, of course :) But I can leave Vbet active on my forum?

kamilkurczak
11-03-11, 13:28
yes, you can leave it active. As you know post in english are translated good:)
I noticed on my test forum that on UTF-8 forum this issue not exist.

Please check in your database how messages are kept (you can paste here an example of russian message)

kamilkurczak
11-03-11, 13:51
I have a good information.

I found a conflict with vBSEO global_complete hook
If you disable this global_complete hook - post translated good but no SEO links. I need to solve this conflict but after weekend :)
Can you check it?

norku
11-03-11, 14:03
How do I check it? :)

kamilkurczak
11-03-11, 14:06
admincp->plugins & product -> Plugin Manager -> global_complete hook of vBSEO -> disable.

But as I wrote -> no seo links if you disable it. I need to check vBSEO code and integrate it.

See you after weekend :)

norku
11-03-11, 14:16
Okay thanks. Have a good weekend! :)

kamilkurczak
14-03-11, 09:27
url, encoding and search integration and issue solved

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations made by vB Enterprise Translator 4.9.99