PDA

View Full Version : vBulletin 4.1.2 + vBSEO 3.5.1 PL1 + Sitemap v3.0 - not running Sitemap.



Vetall
02-03-11, 18:17
Тестирую работоспособность.
1. Установил vBulletin 4.1.2
2. Установил согласно инструкции vBSEO 3.5.1 PL1
3. Установил согласно инструкции vbseo_sitemap-3-0_gold
4. Установил согласно инструкции vBET423
5. Выполнил изменения vBSEOсогласно инструкции - vBSEO (http://www.vbenterprisetranslator.com/forum/ru/vbet4-integration-other-plugins/414-vbseo-integration.html)
6. Выполнил изменения vbseo_sitemapсогласно инструкции - The Sitemap Generator (от vBSEO) (http://www.vbenterprisetranslator.com/forum/ru/vbet4-integration-other-plugins/415-sitemap-generator-integration.html)
7. внес изменения в .htaccess

RewriteEngine On
Options +FollowSymLinks

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]
RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]
запускаю выполнить Run Generatorипроцесс зависает на:

[SECTION START] showthread [2,915.6Kb mem used] [24,065s (+21,706s)]
... and all. - Tell me please, what is wrong?

kamilkurczak
04-03-11, 11:31
Everything looks good.

ok I will test this integration instructions for this vBSEO sitemap generator edition.
Alse - please give me an url to this sitemap edition.
Thanks

Vetall
04-03-11, 12:35
posted a link to bseo_sitemap-3-0_gold personal message.

Vetall
04-03-11, 12:49
may not work over here is the change in vbseo_sitemap_functions.php



vbseo_log_entry("[showthread] forum_id: $forumid, thread_id: $threadrow[threadid], total posts: $totalposts, pages: $totalpages, views: $threadrow[views] $prior");

for($p=1; $p<=$totalpages; $p++)
{
//additional code
$alanguages = array ('af','sq','ar','be','bg','ca','zh-CN','hr','cs','da','nl','en','pl','et','tl','fi','fr','gl','de','el','iw','hi','hu','is','id','ga','it','ja','ko','lv','lt','mk','ms','mt','no','fa','pt','ro','sr','sk','sl','es','sw','sv','zh-TW','th','tr','uk','vi','cy','yi');
if(!$archived) {
$strlenhost = strlen($vbseo_vars['bburl']."/");
$currentthreadurl = vbseo_url_thread($threadrow, $p, $archived);
$currentthreadurl_before = substr($currentthreadurl,0,$strlenhost);
$currentthreadurl_after = "/".substr($currentthreadurl,$strlenhost);
$lastpost =& $threadrow['lastpost'];
$vbseo_stat['t'] += sizeof($alanguages);
foreach($alanguages as $language) {
vbseo_add_url($currentthreadurl_before.$language.$currentthreadurl_after, $prior, $lastpost, $freq);
}
}
//end additional code
$vbseo_stat[$archived?'at':'t'] += vbseo_add_2urls(

kamilkurczak
04-03-11, 13:33
Thanks, I will check it and prepare a solution for you

kamilkurczak
07-03-11, 11:44
Please send to me by PM your admincp and FTP details and I will fix it.

Vetall
10-03-11, 08:04
Please send to me by PM your admincp and FTP details and I will fix it.
- Send a private message.

kamilkurczak
10-03-11, 09:05
Thanks, I will check it for you

kamilkurczak
11-03-11, 10:35
hello,

I checked it for you.

1. firstly.
In you file (vbseo_sitemap_functions.php) you have:

vbseo_log_entry("[showthread] forum_id: $forumid, thread_id: $threadrow[threadid], total posts: $totalposts, pages: $totalpages, views: $threadrow[views] $prior");

for($p=1; $p<=$totalpages; $p++)
{
//additional code
$alanguages = array ('af','sq','ar','be','bg','ca','zh-CN','hr','cs','da','nl','en','pl','et','tl','fi','fr','gl','de','el','iw','hi','hu','is','id','ga','it','ja','ko','lv','lt','mk','ms','mt','no','fa','pt','ro','sr','sk','sl','es','sw','sv','zh-TW','th','tr','uk','vi','cy','yi');
if(!$archived) {
$strlenhost = strlen($vbseo_vars['bburl']."/");
$currentthreadurl = vbseo_url_thread($threadrow, $p, $archived);
$currentthreadurl_before = substr($currentthreadurl,0,$strlenhost);
$currentthreadurl_after = "/".substr($currentthreadurl,$strlenhost);
$lastpost =& $threadrow['lastpost'];
$vbseo_stat['t'] += sizeof($alanguages);
foreach($alanguages as $language) {
vbseo_add_url($currentthreadurl_before.$language.$currentthreadurl_after, $prior, $lastpost, $freq);
}
}
//end additional code

try to make:

vbseo_log_entry("[showthread] forum_id: $forumid, thread_id: $threadrow[threadid], total posts: $totalposts, pages: $totalpages, views: $threadrow[views] $prior");


//additional code
$alanguages = array ('af','sq','ar','be','bg','ca','zh-CN','hr','cs','da','nl','en','pl','et','tl','fi','fr','gl','de','el','iw','hi','hu','is','id','ga','it','ja','ko','lv','lt','mk','ms','mt','no','fa','pt','ro','sr','sk','sl','es','sw','sv','zh-TW','th','tr','uk','vi','cy','yi');
if(!$archived) {
$strlenhost = strlen($vbseo_vars['bburl']."/");
$currentthreadurl = vbseo_url_thread($threadrow, $p, $archived);
$currentthreadurl_before = substr($currentthreadurl,0,$strlenhost);
$currentthreadurl_after = "/".substr($currentthreadurl,$strlenhost);
$lastpost =& $threadrow['lastpost'];
$vbseo_stat['t'] += sizeof($alanguages);
foreach($alanguages as $language) {
vbseo_add_url($currentthreadurl_before.$language.$currentthreadurl_after, $prior, $lastpost, $freq);
}
}
//end additional code

for($p=1; $p<=$totalpages; $p++)
{

2. if still not good - please delete ALL vBET code from this file (REPLACE WITH ORIGINAL ONE) and try to run sitemap - if works - there is a vBET integration issue, if still not works - maybe installation of this sitemap is not good. Please try

Vetall
11-03-11, 11:33
Thanks for the tips!

- I got:
paragraph 1 - did not help
paragraph 2 - also didn&apos;t help...

if the setting vBSEO Sitemap:
The sitemap generator is fully compatible with the vBSEO search engine optimization plugin. - Yes
- then Sitemap - is not generated.
The sitemap generator is fully compatible with the vBSEO search engine optimization plugin. - No
- then Sitemap - generates but without translation.

- what version of vBSEO Sitemap and - tested work?

Thank you!

kamilkurczak
11-03-11, 11:54
so now integrate sitemap files - make changes like in my previous post

Vetall
11-03-11, 12:14
When I ran the change:


vbseo_log_entry("[showthread] forum_id: $forumid, thread_id: $threadrow[threadid], total posts: $totalposts, pages: $totalpages, views: $threadrow[views] $prior");


//additional code
$alanguages = array ('af','sq','ar','be','bg','ca','zh-CN','hr','cs','da','nl','en','pl','et','tl','fi','fr','gl','de','el','iw','hi','hu','is','id','ga','it','ja','ko','lv','lt','mk','ms','mt','no','fa','pt','ro','sr','sk','sl','es','sw','sv','zh-TW','th','tr','uk','vi','cy','yi');
if(!$archived) {
$strlenhost = strlen($vbseo_vars['bburl']."/");
$currentthreadurl = vbseo_url_thread($threadrow, $p, $archived);
$currentthreadurl_before = substr($currentthreadurl,0,$strlenhost);
$currentthreadurl_after = "/".substr($currentthreadurl,$strlenhost);
$lastpost =& $threadrow['lastpost'];
$vbseo_stat['t'] += sizeof($alanguages);
foreach($alanguages as $language) {
vbseo_add_url($currentthreadurl_before.$language.$currentthreadurl_after, $prior, $lastpost, $freq);
}
}
//end additional code

for($p=1; $p<=$totalpages; $p++)
{

и включил настройку
The sitemap generator is fully compatible with the vBSEO search engine optimization plugin.

- Sitemap generation time does not pass:

[homepage] [2,972.6Kb mem used] [0s (+0s)]
[SECTION START] forumdisplay [2,977.0Kb mem used] [0s (+0s)]
[forumdisplay] forum_id: 3, total threads: 0, pages: 1 [2,980.6Kb mem used] [0s (+0s)]
[forumdisplay] forum_id: 2, total threads: 4, pages: 1 [3,989.1Kb mem used] [0s (+0s)]
[SECTION START] showthread [3,990.6Kb mem used] [0s (+0s)]


when
The sitemap generator is fully compatible with the vBSEO search engine optimization plugin. - выключена
- тогда генерация Sitemapвыполняется, НО ссылки в sitemap_forum_1.xml.gz генерируются вот такие:


/hu/showthread.php?t=3&page=2
/is/showthread.php?t=3&page=2
/id/showthread.php?t=3&page=2


although in a forum -

/main-forum/2-acura-integra-1997-repairs-maintenance-operation-vehicle.html
/de/main-forum/2-acura-integra-1997-reparaturen-wartung-betrieb-des-fahrzeugs.html
/uk/main-forum/2-acura-integra-1997-ремонт-обслуговування-експлуатація-транспортного-засобу.html

kamilkurczak
11-03-11, 12:40
/hu/showthread.php?t=3&page=2
/is/showthread.php?t=3&page=2
/id/showthread.php?t=3&page=2

this is good because you don't use vBSEO on your forum

Vetall
11-03-11, 12:57
/hu/showthread.php?t=3&page=2
/is/showthread.php?t=3&page=2
/id/showthread.php?t=3&page=2

this is good because you don't use vBSEO on your forum
kamilkurczak, I want to use vBSEO+Sitemap, but on the test version automan.org.ua mine is not working ... :(

- tell me what version of vBSEO and what version of Sitemap work together?

kamilkurczak
11-03-11, 13:19
I can't see in your htaccess vBSEO rules. Also you don't have vBSEO installed and on your forum you don't have SEO links.

Vetall
11-03-11, 13:27
Maybe you do not see it ...

I can't see in your htaccess vBSEO rules.

RewriteEngine On
Options +FollowSymLinks



# Redirect to WWW
#RewriteCond %{HTTP_HOST} ^automan.org.ua [NC]
#RewriteRule ^(.*)$ http://www.automan.org.ua/$1 [L,R=301]
# End Redirect to WWW

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]


RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]

Also you don't have vBSEO installed and on your forum you don't have SEO links.
Acura Integra 1997 - user guide, instruction on repair of the vehicle. (http://www.automan.org.ua/main-forum/1-acura-integra-1997-user-guide-instruction-repair-vehicle.html)



-

kamilkurczak
11-03-11, 15:37
You wrote that when you have a ORIGINAL sitemap file (WITHOUT INTEGRATION WITH vBET) this sitemap still not work.
Please disable vBET and try to generate sitemap.
If still not working - there is a sitemap problem.
If will be work - bad Integration with vBET - I will check it. So please test it.

Vetall
12-03-11, 07:46
I spent testing.
Sitemap Generator 3.0 - ORIGINAL (without integration vBET).
+
vBSEO 3.6.0 RC 1 - the ORIGINAL (without integration vBET).
= WORKING.

further, at the integration vBET instructions Integration with other mods:
- completed, paragraphs 1-3
SEO links translation integration
- changes to the functions_vbseo_createurl.php

Find:
$bloginfo['seotitle'] = vbseo_filter_replace_text($bloginfo['title']);
REPLACE it with this code:
$bloginfo['seotitle'] = vbet_vbseo_filter_replace_text($bloginfo['title']);

= vBSEO+Sitemap Generator Sitemap is generated.

- do next:

Find:
$vbseo_gcache_thread['seotitle'] = vbseo_filter_replace_text ($ttl);
REPLACE it with this code:
$vbseo_gcache_thread['seotitle'] = vbet_vbseo_filter_replace_text ($ttl);

= vBSEO+Sitemap Generator Sitemap is generated.

- cancel this change functions_vbseo_createurl.php and do the following instructions:


Find:
$replace['%category_title%'] = vbseo_filter_text($c_ttl);
REPLACE it with this code:
$replace['%category_title%'] = vbet_vbseo_filter_text($c_ttl);

= vBSEO+Sitemap Generator Sitemap is generated.

- next:


Find:
$replace['%section_title%'] = vbseo_filter_text($c_ttl);
REPLACE it with this code:
$replace['%section_title%'] = vbet_vbseo_filter_text($c_ttl);

= vBSEO+Sitemap Generator Sitemap is generated.

- cancel this change functions_vbseo_createurl.php and do the following instructions:


Find:
$replace['%entry_title%'] = vbseo_filter_text($c_ttl);
REPLACE it with this code:
$replace['%entry_title%'] = vbet_vbseo_createCmsArticleLink($c_id, $c_ttl);

= vBSEO+Sitemap Generator Sitemap is generated.

also made all the changes in functions_vbseo_url.php and vbseo_sitemap_functions.php according to the instructions.

The result is that does NOT WORK integration vBET + vBSEO+Sitemap Generator when performing these changes file functions_vbseo_createurl.php



Find:
$vbseo_gcache_thread['seotitle'] = vbseo_filter_replace_text ($ttl);
REPLACE it with this code:
$vbseo_gcache_thread['seotitle'] = vbet_vbseo_filter_replace_text ($ttl);

and


Find:
$replace['%section_title%'] = vbseo_filter_text($c_ttl);
REPLACE it with this code:
$replace['%section_title%'] = vbet_vbseo_filter_text($c_ttl);

kamilkurczak
12-03-11, 13:32
ok I will test it. Maybe there is a wrong integration with vBSEO.

Vetall
21-03-11, 14:27
possible to solve my problem of integration?

kamilkurczak
15-04-11, 19:10
can you confirm that you still need our help in this integration?

Vetall
16-04-11, 05:34
can you confirm that you still need our help in this integration?
Yes! integration problem is not solved.

vBET
02-06-11, 21:47
Hi. I just found that your thread ends with request for future support. I do not know was it solved by PM or not (Kamil was responsible for case and he has vacation right now).

That is why I'm asking do you still need support here? Does issue still exist? If yes please have me short description about actual state of issue and I will support you.

Vetall
03-06-11, 06:18
Привет!
Проблема вот в чем:
1. - интеграцию vBET, vBSEO и vBSEO_Sitemapя выполнил по инструкции.
2. - в настройках vBSEO_Sitemap - vBSEO Installed? - установил "Yes".
3. - когда запускаю "Run Generatror" - процесс создания SitemapНЕ заканчивается, последнее сообщение:


[SECTION START] showthread [9,002.5Kb mem used] [0s (+0s)]

и файлы Sitemapне создаются... : (

...

когда в настройках vBSEO_Sitemap - vBSEO Installed? - установил "No" - файлы Sitemapсоздаются и имеют ссылки вида:

http://autorepman.com/en/showthread.php?t=770

- But should be something like this:


http://autorepman.com/en/hyundai/770-of-repair-and-maintenance-of-the-car-hyundai-tucson-kia-sportage-2-2003-a.html



... need your help in solving this problem.

vBET
03-06-11, 22:06
I see this thread is long already, so to avoid another epic discussion please just send me access details to your Admin CP and FTP - I will check does integration steps was made appropriately and what is the reason of issue.

Vetall
06-06-11, 07:23
Access data in the admincp and FTP send private messages ..

vBET
06-06-11, 17:19
I was just there, run sitemap generator and everything works fine. Do you have it integrated now? I do not see any issue at this moment. Please describe exactly how to reproduce it. Please set everything as it should be to be able to see the issue.

Vetall
06-06-11, 17:30
In the settings of the Search Engine XML Sitemap, vBSEO-vBSEO Installed? -" No "-generator works.-If Search Engine XML Sitemap, vBSEO-vBSEO Installed? -" Yes "-generator does not work ... ... try it now to start to generate Sitemap files.

vBET
06-06-11, 17:57
Going there now.

vBET
06-06-11, 18:21
OK I see it. It breaks exactly at this line:

$currentthreadurl = vbseo_url_thread($threadrow, 1, $archived);

Most probably integration of vBSEO with vBET is not done appropriately. I will check it now.

vBET
06-06-11, 18:28
We have some issue with your license and cannot continue to support you until it is solved. Please see details in PM.

Vetall
06-06-11, 19:11
answered a personal message.

vBET
07-06-11, 10:14
Solved. It is working now on your forum. I added one line of code - importing our file. I do not know why only for your forum it wasn't visible - most probably some differences in .htaccess file, because the file I imported is already imported by our SEO file mapped in .htaccess. Anyway I will add this one line of code to normal integration procedure, to avoid future issues.

The line should be added at top of vBET integration code:

require_once(DIR. '/includes/vbenterprisetranslator_functions_vbseo.php');
You have it already included on your server. Enjoy vBET! :)

Vetall
07-06-11, 10:48
I declare! Was fixed, Sitemap is generated as needed. Thank you very much for your support!

vBET
08-06-11, 07:23
Glad to hear :) Enjoy vBET!

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations made by vBET 4.9.99