PDA

View Full Version : Solved not able to change language in forum and thread



Schmike
29-01-11, 09:27
when i change the language from my default language to another lanugage in a forum or a thread, the page is not translated.

the url is not right:

forum:
/forums/forumdisplay.php?29-Welcome-to-PredatoryFishKeepers.com&language=de

thread:
/forums/showthread.php?2806-Hello-I-enjoy-a-variety-of-fish&language=hi

kamilkurczak
31-01-11, 09:05
which version of vBET do you use? please paste here your forum url and I will check it.
Thanks.

Schmike
31-01-11, 16:24
it's the version for vBulletin 4.

url is here:
http://www.predatoryfishkeepers.com/testvb/forums/

kamilkurczak
01-02-11, 11:01
hello,

I was on your site and I notice that only on not translated page you have this links with:
& inside.
When you use for example this url:

http://www.predatoryfishkeepers.com/testvb/forums/showthread.php?2868-For-all-tough-dr%C3%B8ftelser-about&language=da
you have a good links. You can test it.

So, please if you use some mods. Disable all mods one by one and try to notice the good links (without & inside).

Schmike
01-02-11, 12:49
thats what i notice too. but there was no other mods installed when i tested. only recently i enabled the facebook feature in vBulletin.

kamilkurczak
01-02-11, 13:10
hmm thanks for confirmation. I will try to find a solution for you.. Thanks for your patience.

Schmike
01-02-11, 14:05
welcome.

it only happen when i change from my default language which is English. i believe it is just a missing url encoding since "&" is basically "&". not sure whats the term for it in php.

kamilkurczak
02-02-11, 09:07
hello,
I can't reproduce it on my test forum so please send to me (by PM) your FTP and admincp details and I will fix it on your server.
Thanks.

Schmike
02-02-11, 11:00
which are the files that you need? eventually i will have to do it on my live forum. maybe you can tell me which file and line to change instead?

kamilkurczak
02-02-11, 11:20
I don't know where the issue is now. I need make a logs and check it. Will be better If I will make it myself (faster).

I asked you about conflict in your previost post - you said that no conflict, so I need to check it on you server.

Schmike
02-02-11, 11:25
information sent.

kamilkurczak
02-02-11, 11:53
Thanks. I will start working on your server.

kamilkurczak
02-02-11, 12:05
also you can try to use a SEO links (without vBSEO).
just go to admincp->vBET->main and set option:
Translation links type to Create URL's according to SEO link consensus (i.e. '/en/address')

after that you should add to you .htaccess file in forums folder this rules:

#RULES for SEO translation links without any SEO engine (on raw vBulletin links)
#If you are using vB 'Mod Rewrite Friendly URLs' then put those rules JUST BEFORE vB rules
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|sq|ca|et|tl|gl|hi|id|lv|lt|mt|sl|uk|vi|cy|yi)/archive/index.php/(.*)?$ archive/index.php?/$2&language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ index.php?language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ $2?language=$1 [QSA]

kamilkurczak
02-02-11, 13:05
Hello,

Please try it now - should works now. Can you confirm it?
Secondly - this issue can be specific only for this test forum. On main forum this should works perfect.

Schmike
04-02-11, 04:43
looks fine now.

thanks.

will move it to my live forum soon.

tried using the SEO but i got a 404 error:
Not Found

The requested URL /testvb/forums/pt/forum.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Schmike
04-02-11, 05:19
just setup in my live forum, also having the same problem. what was changed to fix it in my test forum?

i've disabled it in my live forum.

Youngster
04-02-11, 08:06
i will passed it to kamil , when kamil will be we will think about it
Thanks

kamilkurczak
04-02-11, 08:31
Hello,

Please send to me by PM your admincp details - I will enable this vBET only for me and I will fix it for you.

kamilkurczak
04-02-11, 11:49
so, If you want to edit it manualy, you must:

1. open and make a copy of this file:
forum root/inlcudes/vbenterprisetranslator_functions_url.php

2. in this file find:

$amp = (THIS_SCRIPT == 'external' || THIS_SCRIPT != 'blog_external') ? '&' : '&';
3. and REPLACE with:

$amp = (THIS_SCRIPT == 'external' || THIS_SCRIPT != 'blog_external') ? '&' : '&';
4. save file
5. test it

But this is not real solution. This eliminate some functions on your site. This issue is specific on your forum (I can't reproduce it on my test forum), so I only can solve it on your server (I need admincp details too).
If you want, you can use this solution - it works, but I would like to check another solution on your server.

Please confirm it.

Thanks.

Schmike
05-02-11, 02:34
that works for my live forum now.

if you want to test out any other resolution, please do it on the test site. thanks.

kamilkurczak
07-02-11, 10:19
Yes, I would like to check it.
Thanks for confirmation :)

Schmike
12-02-11, 10:11
how is the test coming along? are you done with it?

Youngster
12-02-11, 19:10
Kamil is offline for the weekend , he will be on monday so wait or pass it to me :)

kamilkurczak
21-02-11, 08:13
yes, it is done now:) thanks

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations supported by vBET 4.9.2