PDA

View Full Version : Solved Warning: require_once vbenterprisetranslator_cachecleaner.php



StarBuG
02-12-10, 16:38
Warning: require_once(/usr/path/admincp/vbenterprisetranslator_cachecleaner.php) [function.require-once]: failed to open stream: No such file or directory in /usr/path/CORRECT ADMIN CP FOLDER/misc.php(2067) : eval()'d code on line 9

Fatal error: require_once() [function.require]: Failed opening required '/usr/path/admincp/vbenterprisetranslator_cachecleaner.php' (include_path='.:/usr/local/lib/php/') in /usr/path/CORRECT ADMIN CP FOLDER/misc.php(2067) : eval()'d code on line 9

Hi

This error occurs when I click the cache cleaner.
This most likely happens because somewhere you did not take
changed admincp folder name from config.php into account

Just a hint ;)

mateuszr
11-12-10, 10:01
There's a section in config.php called 'PATH TO ADMIN & MODERATOR CONTROL PANELS' and here are options:

$config['Misc']['admincpdir'] = 'admincp';
$config['Misc']['modcpdir'] = 'modcp';
Modifications of these should help, but we'll investigate it precisely, if there's anything else, what might cause the error described above.

mateuszr
13-12-10, 11:37
Can you confirm, that the error still occurs?

chick
31-12-10, 15:22
Sorry for the late reply**********.. YES of course I did that or I could not enter my admin panel.

Could it be that my index.php is redirected (vbseo) to bfdiscussion (not renamed just redirected)

Now what?

I put a desktop shortcut to this thread so I don't forget to see your reply.

kamilkurczak
10-01-11, 13:38
hmm, I am still try to reproduce it. can you describe this what I should do and what I should change?

kamilkurczak
20-01-11, 09:07
hello,
I have a solution for you.

1. go to admincp->Plugins & Products->Manage Products->
2. in vBET product find admin_maintenance plugin
3. in this plugin find:

require_once(DIR. '/admincp/vbenterprisetranslator_cachecleaner.php');
4. and REPLACE with:

require_once(DIR. '/'.$vbulletin->config['Misc']['admincpdir'].'/vbenterprisetranslator_cachecleaner.php');
5. save plugin
6. test it.

Solved, will be included in the next relase.
Thanks for this info :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations delivered by vBET 4.9.2