PDA

View Full Version : Solved After registration no automatic translation



Gordon78
26-11-10, 17:03
Hi there,

I installed vBET on vB 4.0.8 and have a small problem:
when a new user registers, he will get shown the language (with all flags) that he has to choose in the register form.

After confirming the registration mail his language is saved in his profile, but the there is no automatic translation to his language. He has to press manually the right flag to get the translation.

How can I solve this problem?

Thanks

Gordon78
27-11-10, 15:20
2. Problem: written articles in cms (home button, vB4) will not be translated in any language.

Gordon78
27-11-10, 21:39
3. Problem:
In the internet link should "nontranslate" rules be inactive, because the links will not work:

Here is an exaple of my Mail to a customer:


Dear User,

thanks for your post.
Regarding to your question: you will find all relevant information of our research in the actual Compendium (http://blablabla.com/shop/index.php?main=products&cat=SW).
It contains a large FAQ of almost all possible questions (with tons of pics and videos) and will help you here detailed - and at the lowest time and money cost for all participants.

Gordon78
27-11-10, 21:48
Just one thing: it would be useful to allow in the posts "english", because this is the global language and if some communication problems are seen, it would help if the user who posts already can post in english.

Gordon78
27-11-10, 21:58
4. Problem:
if the post is sent over quick reply, all characters are shown correct.

BUT if user posts his reply through "Go advanced" button (WYSISWG editor), then characters are shown wrong:

example:

danke für den Hinweis....

ü is german "Ü"

Gordon78
02-12-10, 21:12
push - can you please answer my questions. thanks

kamilkurczak
03-12-10, 11:28
4. Problem:
if the post is sent over quick reply, all characters are shown correct.

BUT if user posts his reply through "Go advanced" button (WYSISWG editor), then characters are shown wrong:

example:


ü is german "Ü"

Yes, this is a vBET bug. We are working about this. Today I will try to give you a solution.

kamilkurczak
03-12-10, 12:15
ok I have a quick solution for the issue from my previous post.
PLEASE USE IT IF YOU USE A UTF-8 FORUM

1.make a copy and edit file:

forum root/includes/vbenterprisetranslator_functions_utils.php
2. in this file find:

$string = preg_replace('/([\300-\337])([\200-\277])/e',
3. and replace with:

$string = preg_replace('/([\304-\337])([\200-\277])/e',
4. save a file
5. test it.

It was tested on our test forum on utf-8 engine (message was made by opera and IE) and it works now.

kamilkurczak
07-12-10, 09:34
no answer - solved. if not please write here and I will open this thread again.

Gordon78
08-12-10, 22:26
no answer - solved. if not please write here and I will open this thread again.

Hi there,
please give me some time, I have at the moment no possibility to test it.
Did you checked the other problems (1.-4.)?

Thanks!

mateuszr
09-12-10, 08:57
1 -> there's an existing solution here (http://www.vbenterprisetranslator.com/forum/troubleshooting/1255-user-cp-option-profile-doesnt-update-lang-settings.html)

2 -> please check http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post1546

3 -> one more time look in our FAQ section - here's a part of it:

notranslate BB code is to keep text not translated. If you want some text i post to be not translated, just simple out it inside of notranslate BBCode. It can be useful in case of some terms, or citation of some poems etc.

For example this text will never be translated. You can check it by clicking some translation flag - you will see this part will stay in original

Gordon78
15-12-10, 22:28
Thanks for your help.
Point 1,3,4 and 5 are solved now.

Problem No. 2: FAQ (http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post1546) did not worked for me.

I suppose I did unterstand something wrong.
a) I did edit my .htaccess: htdocs/forums/.htaccess

b) and placed the code to it:
# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/forums/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

# vBET
# RULES for SEO translation links with vBSEO (have to be included before all rules to vbseo.php)
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/gallery/(.*)?$ /gallery/$2?language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ index.php?language=$1&vbet_outside=true [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ $2?language=$1&vbet_outside=true [L,QSA]



RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]
# vBET End

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)

RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]


All other infos in the FAQ are not needed(?) to be done, because vBulleting cms is inside the directory /htdocs/forums.

c) It does not work: my user profile has a german setting. When I publish in the CMS a new article on german - and after this change my user profile settings to english (or simply press the english flag), the new article stays in german.

Thanks for your reply!

mateuszr
16-12-10, 08:39
In these to lines:

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/$2 [L,QSA]

Add your forum path at the end - instead of / should be /forums/ (if /forums is your forum path). So it should look like:

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forums/ [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forums/$2 [L,QSA]

Gordon78
16-12-10, 18:18
Done,

but without success:

(user profile settings: german) and posting in german:

Neuer Artikel jetzt auf deutsch: sollte jetzt automatisch übersetzt werden.

a)
(user profile settings: german) After posting it is shown as:

Neuer Artikel jetzt in english: sollte jetzt à ¼ bersetzt Automatisch Werden.

b)
And when I change the user profile settings to english, then I get shown:

Neuer Artikel jetzt auf deutsch: sollte jetzt automatisch übersetzt werden.

1. Problems with signs: a) + b) - Ü gets to à ¼
2. German posts will be again translated to german for german users (and then they are wrong): a)
3. English speaking users get untranslated text in german to read: b)

Thanks!

kamilkurczak
16-12-10, 22:16
about .htaccess.
If you want to have a outside forum page translated you must create a new htaccess file outside forums/ folder. (or edit if this file exist)
and put to this file (rules to translation page outside forum directory):

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ index.php?language=$1&vbet_outside=true [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ $2?language=$1&vbet_outside=true [L,QSA]

RewriteCond %{QUERY_STRING} !vbet_outside=true
RewriteRule ^(.*)$ $1?vbet_outside=true [L,QSA]

and you should make the next htaccess file to translate your forum.
the second htaccess file should be in forum root folder (in forum/.
and if you use vBSEO your file should look like:

# Comment the following line (add '#' at the beginning)
# to disable mod_rewrite functions.
# Please note: you still need to disable the hack in
# the vBSEO control panel to stop url rewrites.
RewriteEngine On

# Some servers require the Rewritebase directive to be
# enabled (remove '#' at the beginning to activate)
# Please note: when enabled, you must include the path
# to your root vB folder (i.e. RewriteBase /forums/)
#RewriteBase /

#RewriteCond %{HTTP_HOST} !^www\.yourdomain\.com
#RewriteRule (.*) http://www.yourdomain.com/forums/$1 [L,R=301]

RewriteRule ^((urllist|sitemap_).*.(xml|txt)(.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]

# vBET
#RULES for SEO translation links with vBSEO (have to be included before all rules to vbseo.php)
#RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forums/ [L,QSA]
#RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ vbenterprisetranslator_seo.php?vbet_lang=$1&redirected=/forums/$2 [L,QSA]

#RewriteCond %{REQUEST_URI} !(admincp/|modcp/|vbseo_sitemap/|cron)
#RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbenterprisetranslator_seo.php [L,QSA]

#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_FILENAME} !^(admincp|modcp|clientscript|cpstyles|images)/
#RewriteRule $ vbenterprisetranslator_seo.php [L,QSA]

RewriteCond %{REQUEST_URI} !(admincp/|modcp/|cron|vbseo_sitemap)

RewriteRule ^((archive/)?(.*.php(/.*)?))$ vbseo.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !/(admincp|modcp|clientscript|cpstyles|images)/
RewriteRule ^(.+)$ vbseo.php [L,QSA]

2. what about your letters - as I see you use not utf-8 forum. we are still working on this solution (becouse solution from my previous post is only for utf-8 forums)

3. about language support. go to admincp->vBET->google and set Google Language Detection to Always trust user.
(please read description of this option) after that set in usercp you user language to german.
go to forum, make a new thread in german or make a new article in german -> you should see your text in english when you are on english translation or in german when you are on german translation.

Gordon78
20-12-10, 21:52
Thanks kamilkurczak, I made all changes and hope it will work fine.

Regarding to last open problem (point no. 2):
Can I avoid the problems through changing of collate (ci_swedish ?) to UTF-8?
I had no option at the installation of the forums to choose UTF-8, and I am not sure why vB4 did take automatically swedish.

If yes, how can I change it?
(Forum is at the moment still in testing mode, untill all problems are solved).

Thanks!

mateuszr
21-12-10, 14:09
You can't simply convert your forum to UTF-8 because it can do a mess in your database (different character encoding).
There's a solution on vbulletin forum (https://www.vbulletin.org/forum/showthread.php?t=216863). Just follow these steps to make your forum UTiFied ;)

NOTICE that in step 18 of the above description, you have to write UTF-8 in lowercase (utf-8).
See -> do-not-upload|readme.html. There're some steps required for UTF-8 forums.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
vBET 4.9.2 brings automatic translations