PDA

View Full Version : Already done vBET during registration in vB4 uses Tables



StarBuG
08-11-10, 21:03
Hi

In the registration form on vBulletin 4.x series vBET uses tables for the language options to chose from.

vB4 is table free and besides the bug that one language option is positioned at the left site where only setting names should be it should not use tables.

I can't find the template or code part where "vbet_language_options" is defined so that I can change it myself.

Please provide a fix that does not use tables on vB4

Thank you very much

StarBuG

vBET
09-11-10, 12:32
Hi

Actually generation of default language options for registration form is hardcoded in /includes/vbenterprisetranslator_functions_hooks.php in funcition vbet_register_form_complete.

Using appropriate HTML structures is not a bug. It is also not a trouble since everything is working fine. So I move this to feature requests section.

Please note that it is best thing to use right tool for right job. We present language options in columns and for this tables are right tool. There is absolutely nothing wrong in it, it is fine.

Also it is not true that vBulletin 4.x is free of tables - it uses it a lot. Just please go to your Admin CP and in templates look for <table...

At this moment this change request is rejected as change which gives additional value. If you have specific suggestions how you would like to have it we can consider it again. Still please keep in mind that appropriate usage of HTML structures is not a bug :)

StarBuG
09-11-10, 13:45
99% of all styling in the user frontend is not using tables.
In the registration form only the vBET part is using tables.
vBulletins registration options are all displayed via CSS.

Besides that, it is still a bug that one language option is displayed on the left
where only the title of the setting should be.

If you don't consider removing the use of tables at least fix the display issue of
one language beeing displayed on the left side below the setting name.

See here for a demo of the problem: Bei Patientenfragen.net - wir haben die Antworten registrieren (http://www.patientenfragen.net/register.php)


Thank you

StarBuG

vBET
09-11-10, 18:03
Please note that it is displayed like this in purpose. Most of users use all 52 languages and want to display it in 4 columns, so we display it in whole available space to make it fit there.

Anyway - we will check how it will look when it will be placed only in 2nd column (like other options and descriptions) and at least we will provide you hints how to change it :)

StarBuG
09-11-10, 18:29
Thank you.

Looking forward to the fix.

I am a perfectionist when it comes to my forums and something small like this bothers me a lot :p

kamilkurczak
10-11-10, 14:04
Hello starBug,

I have a hint for you. You should put our table into <div class="rightcol"></div>

What you should do?
1. make a copy of this file: forum root/includes/vbenterprisetranslator_functions_hooks.php

2. Find in this file

function vbet_register_form_complete(&$customfields_profile, &$show) {
3. in this function find:

$vbet_language_options = '<table class="multifield group" cellpadding="4" cellspacing="1" border="0"><tr>';
and replace with:

$vbet_language_options = '<div class="rightcol"><table class="multifield group" style="width: 100%" cellpadding="4" cellspacing="1" border="0"><tr>';

4. in this function find:

$vbet_language_options .= '</tr></table>';
and replace with

$vbet_language_options .= '</tr></table></div>';

EDITED
looks good now so will be included in the next relase

Thanks

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations made by vBET 4.9.99