View Full Version : Solved Guest cache not working and when moderating have white pages.

02-11-10, 09:46
At this stage after re-installing VBET and configuring it exactly the same way I had it before, guest cache is not working and when my moderators are moving posts they are getting white pages. Please help.

02-11-10, 11:02
Hello Taurus,
Here you have a your thread with Guest cache issue. Please read it.
(about double GZIP).

about the second one. I will try to reproduce it on my test forum.

02-11-10, 11:51
As I remember you fixed it with your host provider, but after update your Apache you can have a mod_deflate enabled again. So if it is edable -> you have a double gdziped. Please contact your host provider and disable this module.

Here you have a full instruction how to check it (from your previous thread - written by MichaƂ)

When you disable vBulleitn GZIP by AdminCP option GZIP HTML Output then your output is still zipped. You can see it here:
GZip Test (http://nontroppo.org/tools/gziptest/?url=http%3A%2F%2Fcreativx.net%2Fforums%2Fgeneral-discussion%2F68-freebies.html&uas=&onlyheaders=on)
NOTE: it is clearly described in vBulletin option:

If you are already using mod_gzip or mod_deflate on your server, do not enable this option.
So at this moment it seems that you have one of those on, because output is zipped anyway. And this is most probably the cause of issues with vBET guest cache - it is double zipped so browsers get crazy with it.

02-11-10, 11:56
I have now disabled gzip in my ACP, but still get these errors:

Warning: filemtime() [function.filemtime]: stat failed for [path]/vbet_guestcache/en/_forums_dnp_news_php_content_3_id_8978.html in [path]/includes/vbenterprisetranslator_functions_guestcache.php on line 53

Warning: Cannot modify header information - headers already sent by (output started at [path]/includes/class_core.php:4598) in [path]/dnp_news.php on line 320

Warning: filemtime() [function.filemtime]: stat failed for [path]/vbet_guestcache/en/_forums_forumdisplay_php_f_8278.html in [path]/includes/vbenterprisetranslator_functions_guestcache.php on line 53

02-11-10, 12:18
This bug is solved on our forum. Try it:

1.Just edit file (please make a copy of this file): includes/vbenterprisetranslator_functions_guestcache.php
2find line::

if ((time() - filemtime($vbet_readGuestCacheFileName) <= $timeAllowed) && !vbet_verify_ip_ban()) {
change it to:

@$fileTime = filemtime($vbet_readGuestCacheFileName);
if ((time() - $fileTime <= $timeAllowed) && !vbet_verify_ip_ban()) {

02-11-10, 13:25
Awesome Kamil. That seemed to have done it. Works great now. Thank you very much!!

I will ask my Moderators to also check now whether the other issue with them moving posts and getting white pages are still present.

02-11-10, 13:34
I'm not sure that this is related to Guest Cache - if your moderators are moving threads then they are not guests... Please first check does it still happens when guest cache is disabled. If yes we will know to check something else. As I see it now it is most probably not guest cache issue - moderators are not guests, so guest cache do not work for them...

Kamil please verify with Taurus does Guest cache is working at all. Also does issue happens when Guest cache is disabled. Check can you reproduce it on our test forum.
Taurus - can you see in server logs any error messages? I expect that some file is not included by mistake. If yes in server logs you will have communicates about unknown function - this will allow us to solve the issue very fast.

02-11-10, 13:38
Sorry, I did not mean to say it had something to do with guest cache. I merely mentioned the 2 issues together as to not open a separate thread.

The first issue regarding guest cache is now solved. The other one was happening while guest cache was disabled, so I am also not sure whether solving the guest cache would solve that. But I will tell them to try now anyways. I will report back about that.

02-11-10, 13:42
OK so - my mistake. I took it as one issue. Please keep one thread per one issue. It will allow us to handle it appropriately. My mistake - sorry for you and Kamil.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations delivered by vBET 4.9.99