PDA

View Full Version : Solved When I clean the cache I get some errors



dgparent
26-10-10, 19:33
at the top of the page in Vbulletin


Warning: Illegal offset type in isset or empty in [path]/includes/vbenterprisetranslator_functions_lang.php on line 107

Warning: Illegal offset type in [path]/includes/vbenterprisetranslator_functions_lang.php on line 109

Warning: Illegal offset type in [path]/includes/vbenterprisetranslator_functions_lang.php on line 114

moman
27-10-10, 02:22
Did you clear the cache using the admin panel script? This warning is thrown when an array key is not set.

kamilkurczak
27-10-10, 14:37
Hello,
I checked it and this warning is from this function:
vbet_useCache
Normally we pass to this function only one elenent - for example 'pl'
but after cache cleaning - this is an array, but Array can't be a key to the table.
Now We are working on solution for you.

kamilkurczak
27-10-10, 16:17
Hello,
As i wrote in previous post - We know where is the issue but we should make a correction in few places in file.
We will make this corections but it will be included in the next relase.

I have a solution for you to only hide this "warnings", so:
1. edit the forum root/includes/vbenterprisetranslator_functions_lang.php file
2. find and comment:

define('VBET_USE_CACHE_FOR_ACTUAL', vbet_useCache($_REQUEST['language']));
3. paste after that:

define('VBET_USE_CACHE_FOR_ACTUAL', @vbet_useCache($_REQUEST['language']));
4. save file

Remember - this is not a solution - only you can hide this warnings now.

please after that check your site (translations, links etc.) and confirm here.
I will move this thread in to the Bug reporting area.
Confirmed and will be fixed in the next relase.

kamilkurczak
28-10-10, 09:37
Done. I edited two vBET files.it Will be includet in the next relase.
:)

scottct1
12-12-10, 10:30
While it hides the warnings it does not fix the issue as the cache is not cleared.

mateuszr
13-12-10, 09:58
Remember - this is not a solution - you can hide these warnings now
These warnings are shown, because your server settings are set to display them.
We've got a prepared solution for this issue, but it will be applied in the next release.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations supported by vB Enterprise Translator 4.9.2