PDA

View Full Version : Solved vBET doesn't work when PHP is run as an apache module



moman
26-10-10, 01:26
See this thread: http://www.vbenterprisetranslator.com/forum/troubleshooting/944-upgraded-php-5-2-14-some-languages-broken.html

The issue is still there.

I would very much like to switch back to running php as an apache module, so that I can take advantage of APC to lower server loads. However, doing so following my upgrade to PHP 5.2.14 as mentioned in the thread above breaks vBET for non-cached translations. Pages are simply blank, with no error messages or warnings, for any translations that are NOT already in the cache.

When I switch to running PHP as a CGI application, everything works fine. Can you take another look and see if you can't shed any light on this? Any ideas as to what could be going on?

moman
26-10-10, 01:31
Wow- talk about luck!

I resolved the issue by disabling the "Delay between translations" setting.

Do you have any idea why this WOULD work on PHP 5.0.77 as an apache module, but not on PHP 5.2.14? What functions does this feature use?

kamilkurczak
26-10-10, 07:29
hello,
I will ask about that MichaƂ and write here

kamilkurczak
27-10-10, 11:33
This feature use this function:
time_nanosleep() but I checked it and this is supported on PHP 5 version.
This is unavailable only for Windows versions below 5.3.

You have a good version of PHP but probably you have an issue in your version of PHP.
Here you have a full list of functions on your version:PHP Extensions List :: List all loaded extensions (http://www.satya-weblog.com/tools/php-extensions-list.php?expand=*)
You can find there a time_nanosleep().

We can make a test with this feature.
1. edit your php file:

forum root/includes/vbenterprisetranslator_functions.php
2. find and comment:

if ($subTranslated && $vbulletin->options['vbenterprisetranslator_google_delay']) {
3.paste after this line (after comment)

if ($subTranslated && $vbulletin->options['vbenterprisetranslator_google_delay'] && function_exists('time_nanosleep')) {
4. go to your admincp and enable this option.
If it will be work - you have a problem with your PHP version (some issues - because function time_nanosleep doesnt exist).

moman
27-10-10, 15:27
I made a test file, and function_exists('time_nanosleep') is false. I'm not sure why that would be the case.

I'm on a unix server - any ideas? Thanks for the reply!

kamilkurczak
27-10-10, 16:07
is false but should be true because in php 5 this function exsist:
PHP: time_nanosleep - Manual (http://php.net/manual/en/function.time-nanosleep.php)
In previous post I pasted a url to the site with all functions from your PHP relase.

so you have an issue in your PHP version.

What you should do?
-reinstall PHP or install another version
-write about that to the PHP support

This is not a vBET issue so I will mark this thread solved.

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations made by vBET 4.9.2