PDA

View Full Version : Solved link in navbar



marengo
11-10-10, 21:53
Hi

I have a custom vb skin installed with a custom navbar template and I want to include "Translations" menu item with a dropdown manually. (take a look at the top: you see User CP,FAQ,Community,Calendar,New Posts etc)
But I cannot find a code for this. Google Chrome developer tool display me :


<a id="vbettranslations" href="$show[nojs_link]#vbettranslations" accesskey="5" style="cursor: pointer; "><img class="vbet-flag vbet-en" width="16" height="11" src="images/vbet/flags/clear.gif" alt="English" border="0" title="English">Translations <img src="images/002/misc/menu_open.gif" border="0" title="" alt=""></a>
<img class="vbet-flag vbet-en" width="16" height="11" src="images/vbet/flags/clear.gif" alt="English" border="0" title="English">
"Translations"<img src="images/002/misc/menu_open.gif" border="0" title="" alt=""></a><script type="text/javascript"> vbmenu_register("vbettranslations"); </script>


I'm not sure that it's correct. I tried VB Search Templates but without success.



Could you please help me.

Thanks

Simon Lloyd
12-10-10, 11:43
You don't need the code, simply put this $vbenterprisetranslatorflagsdropdown wherever you want the dropdown to appear :)

marengo
13-10-10, 08:11
Thanks. But all links in my navbar have a custom css class

I.e.
<a id="vbettranslations" class="customclass" href="$show[nojs_link]#vbettranslations" accesskey="5" style="cursor: pointer; ">

what file should I edit?

Thanks again

kamilkurczak
13-10-10, 09:44
Hello,
As Simon said. Go to admincp->vBET->Flags->Translations dropdown menu position, read a description, set option to custom and paste only $vbenterprisetranslatorflagsdropdown to the navbar template
(only $vbenterprisetranslatorflagsdropdown, without any code more)
Just try it, if not working - try another position.

kamilkurczak
13-10-10, 11:38
I would like to know how it looks on your forum (this navbar)
Can you paste a url to your site here?

marengo
13-10-10, 19:44
Hi

thanks for the help. Well, it does work great. :)
I cannot give you a link cause this is a private forums, but here is a screenshot:
http://webdesignbe.com/misc/screen.jpg

I'll try to CSS this link now, I think I'm able to do it now.

Thanks again

kamilkurczak
14-10-10, 12:09
ok, solved. I will move this thread to troubleshooting

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Languages translations supported by vBET PRODUCER_PRODUCT_VERSION