PDA

View Full Version : Solved how to translate a non vb page or fix the url?



Simon Lloyd
11-10-10, 19:45
Hi i have a helpdesk outside of the forum and pages are not generated by vb can i use the translation on it or how dow we fix the url because when i access it i get this http://www.thecodecage.com/hesk/?vbet_outside=true

Regards,
Simon

kamilkurczak
12-10-10, 12:14
no, You can't translate a no vB pages.
just look here:
if you use this url: The Code Cage Helpdesk (http://www.thecodecage.com/hesk/)
you have a normal url, so you can edit this url from http://www.thecodecage.com/hesk to http://www.thecodecage.com/hesk/

If not - you can write in your .htaccess a new rule to this page

Simon Lloyd
12-10-10, 12:47
Sorry Kamil, i don't understand my url originally was http://www.thecodecage.com/hesk but since installing vBet it looks like this http://www.thecodecage.com/hesk/?vbet_outside=true how do i get it to look like the old url if vbet cannot translate it?

p.s if you don't want a link here to parse then just wrap it in noparse like this www.yoursite.com

kamilkurczak
12-10-10, 12:53
yes, but
your link now looks like: http://www.thecodecage.com/hesk (you can check it by your site source) and it will redirect to http://www.thecodecage.com/hesk/?vbet_outside=true.
Try to edit your url to this site to : http://www.thecodecage.com/hesk/

Simon Lloyd
12-10-10, 13:02
Kamil, my url was always www.thecodecage.com/hesk but vBet now appears after it why is that?, how can i fix it?, i wouldn't know how to edit it back because in my site templates its shows as www.thecodecage.com./hesk

kamilkurczak
12-10-10, 13:04
ok so please edit your .htaccess
after rule to this site add [L]

Simon Lloyd
12-10-10, 13:13
I have given you access as requested :)

Simon Lloyd
12-10-10, 13:56
Just checking google webmaster tools and i find i have thousands of site map problems and crawl errors!, can you also help with this please?

There are 700 404 errors! and thousands of redirect errors, i have downloaded the tables and you're quite welcome to look at them.

kamilkurczak
12-10-10, 14:07
ok
I have analyzed your .htaccess file and you have a good [L] options, but this redirect is from apache level (probably).

But please try it:
1. click on this link:

http://www.thecodecage.com/hesk you have a redirect to:

http://www.thecodecage.com/hesk/?vbet_outside=true
2. but if you click on this link:

http://www.thecodecage.com/hesk/ you have a good one.

so, what you should do? just edit your all urls to hesk, add "/" on the end of this link for example in the main black bar with menu on the main page and another pages.
edit from:

http://www.thecodecage.com/hesk
to:

http://www.thecodecage.com/hesk/

Simon Lloyd
12-10-10, 14:11
Ok no problem with doing that thanks :), do you want me to upload all my downloaded logs here from google webmaster central showing the hundreds of 404 and redirect errors?

kamilkurczak
12-10-10, 14:14
please make a new thread with this. can I mark this forum solved or not?

Simon Lloyd
12-10-10, 14:21
I'll do this and get back to you shortly - will start a new thread for the urls!

Simon Lloyd
12-10-10, 14:37
This can be marked solved i have added / after hesk, blog and webhosting, those urls work just fine now with no vbet=outside after them :)

kamilkurczak
12-10-10, 14:40
thanks for confirmation :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations delivered by vBET 4.9.99