PDA

View Full Version : Solved Forum notification double or triple posting?



Simon Lloyd
07-10-10, 12:11
Hi since having vBet installed when a new thread gets created a notification is sent to people set in the forum to recieve it (AdminCP>Forums & Moderators>Forum Manager>Whichever forum>Who should recieve an email on new thread) the problem is that it is now sending the notification sometimes twice, sometimes 3 times so it's getting quite annoying for the recipients.

Can you help?

Regards,
Simon.

kamilkurczak
07-10-10, 14:53
Can I test it on your forum? I will make a new test-thread to check it.

Simon Lloyd
07-10-10, 15:06
Sure, let me put your email address in the "Who gets an email" section of the forum marked "General"

I have now entered contact@vbenterprisetranslator.com as the email to send to for any post or thread entered in General Discussion forum :0

kamilkurczak
07-10-10, 15:35
I was on your site and I made a new thread and post - everything is ok.
try it:test thread (http://www.thecodecage.com/forumz/fun-forum/208004-test-thread.html#post741126)
how I can reproduce this issue? can you explain it?

Simon Lloyd
07-10-10, 16:07
I posted in that thread you were in the wrong forum :)

kamilkurczak
07-10-10, 16:16
I can't find it. Can you paste a url to this forum. here.
Thanks

Simon Lloyd
07-10-10, 16:19
Just make a new thread/topic here General Discussion (http://www.thecodecage.com/forumz/general-discussion/)

kamilkurczak
07-10-10, 16:25
ok I made a new thread and few posts without issue. If I made a one post - I have a only one message on my e-mail, so what is wrong?

Simon Lloyd
07-10-10, 16:27
i made a test message too in that forum did you get another from my thread?

BTW your post stayed written in polish?

Simon Lloyd
07-10-10, 17:10
Kamil 1 minute ago i created 2 more threads so at most you should only ahve 2 emails from two different threads marked for you. :)

kamilkurczak
07-10-10, 19:40
and I have only two e-mails. :) everything is good, I can't reproduce yours issue, so I think that everything is ok.

Simon Lloyd
07-10-10, 21:43
A user just posted and both i and my moderators got the notification twice!, this has only occurred since installing vBet.

Simon Lloyd
07-10-10, 21:45
I will add your email to our forum that gives the notification, if you post yourself vbulletin will not give you notification of your own post, i will post a message and see if you get only one email :)

Simon Lloyd
07-10-10, 21:51
Just posted and got 6 notifications....you would have too!

Simon Lloyd
07-10-10, 21:54
it might be something to do with the code tags?

kamilkurczak
07-10-10, 22:02
ok i noticed that. Can you explain how to add e-mail to forum? I will try to reproduce it on my test forum.

Simon Lloyd
07-10-10, 22:11
I did in first post http://www.vbenterprisetranslator.com/forum/5289-post1.html

kamilkurczak
07-10-10, 22:12
ok, Thanks for that. Now I will try to reproduce this issue on my test forum and fix it!
:)

Simon Lloyd
07-10-10, 22:14
Thanks, but it may be something to do with my code tags or my html button for highlighting the code.

Feel free to look through the templates/files you have access to both

Simon Lloyd
07-10-10, 22:15
Just had a new post in that forum but only one notification but they did not use tags Convert sorted and filtered worksheet to HTML (http://www.thecodecage.com/forumz/members-excel-vba-programming/208015-convert-sorted-filtered-worksheet-html.html#post741164)

Simon Lloyd
07-10-10, 22:35
It seems that its random as i have just posted 2 different posts using 2 different tags and only one notification each???

Simon Lloyd
07-10-10, 22:37
Have to go to bed now up at 5am :(

kamilkurczak
08-10-10, 11:05
I tested it on my test forum and I can't reproduce it.
Probably this is a conflict vBET with other mod.
You can simply check it. What you should do?
1. vBET must be enabled.
2. disable all mods (one by one) and try to find this issue again. If one mod is disable and you can't reproduce the issue - we have a conflict. (because when this mod is enabled - the issue exist)

Simon Lloyd
08-10-10, 11:08
My VBA tags call out to a php file for replacement of words and phrases, i can only imagine its that!

kamilkurczak
08-10-10, 11:55
Are you sure that when vBET is disabled you can't reproduce this mod?


From which mod VBA tags are?

Simon Lloyd
08-10-10, 12:43
Are you sure that when vBET is disabled you can't reproduce this mod?


From which mod VBA tags are?Very sure :), it has never happened before making the modifications for vbet in the templates and php files or installing vbet - prior to obtaining vbet everything was good.

Simon Lloyd
08-10-10, 12:44
Why don't we leave the issue open for now and i will monitor how many posts cause it and which bbcode if any has been used then report back say tuesday?

Simon Lloyd
08-10-10, 13:06
Deleting all tet messages on my forum for now :) we will resume on tuesday.

kamilkurczak
08-10-10, 13:08
ok, so I am waiting for the answer to Tuesday :)
Thanks

Simon Lloyd
12-10-10, 10:16
Hi Kamil, thanks for waiting, for the last few posts we have had (not had many) the notification has only posted out once (which you will have recieved notification of too) so go ahead and marked this solved, if we get a good few more posts and it happens again i will document them and save the list for your examination :)

kamilkurczak
12-10-10, 13:00
Thanks for your reply. solved.

Simon Lloyd
12-10-10, 23:15
Unfortunately not solved :(, just had a post right now here Send email based on date - The Code Cage Forums (http://www.thecodecage.com/forumz/members-excel-vba-programming/208038-send-email-based-date.html) sent 4 notifications

kamilkurczak
15-11-10, 10:38
hello,
Did you notice this issue again ?

moman
17-11-10, 15:38
I'm like to point out that users on my forum have also complained about getting multiple (up to 6) e-mail notifications for the same subscribed thread. This is definitely a bug somewhere- I'll take a look at what code could be causing it.

The weird thing is that it's happening more or less randomly.

kamilkurczak
17-11-10, 17:31
ok I will try to reproduce it on my test forum

mateuszr
18-11-10, 12:35
Hello :)
There's another test, you may try - just remove all recipents of your confirmations in AdminCP and leave just ONE - check, do you still randomly receive several messages and write here about it :)

mateuszr
25-11-10, 17:29
Thread temp. solved due to no answer and impossibility to reproduce now

Simon Lloyd
25-11-10, 19:13
mateuszr, it does still happen, we just live with it for now, and it is random, there's no pattern.

mateuszr
26-11-10, 08:51
and did you try that option with only one recipient ?

mateuszr
02-12-10, 11:08
we just live with it for nowit seems you want still live with it - I asked you about that last modification a long time ago and still no reply...

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations supported by vBET Translator 4.9.2beta