PDA

View Full Version : Solved Thread titles aren't translated



Simon Lloyd
06-10-10, 19:18
Hi, sorry to post again, i have just had a polish person post here problem z pewnym wykresem (http://www.thecodecage.com/forumz/members-excel-new-users/208000-problem-z-pewnym-wykresem.html#post741103) the post is translated but the post title is still in polish, could someone take a look please?

Regards,
Simon

vBET
06-10-10, 23:28
Please go to edit thread option, go to advanced and check does the title is inside of langtitle bbocde. If not - then please add it (use language parameter - just like for lang). Most probably this is it.

Such thing should not happen if vBET make opaquing the message (See vBET Google options for details). But if someone will opaque message by hand in lang bbcode, then vBET see that someone already took care about it and do not made any changes.

Please tell did it help and does the issue is solved.

Simon Lloyd
07-10-10, 06:59
I added language tags and the thread titile looks like this now
problem of a graph

EDIT: My apologies i added the tags like this now problem z pewnym wykresem and the title translated ok, how can i get this to be automatic as the tags were not present before i edited the title?

Regards,
Simon

vBET
07-10-10, 07:56
Just as I wrote - please see Google Options for vBET in Admin CP. You can choose there strategy how to automatically add language tag. We recommend to use Trust Google when trust worthy, sill it is wise to read description of all strategies and choose best one for you :) Whole description is in parameter description - so just in place where you ill configure it :)

Simon Lloyd
07-10-10, 08:12
I chose Trust User (as you recommended in the software), are you saying that the langtitle tag isn't added automatically?

vBET
07-10-10, 08:55
Trust user is best for performance because do not ask Google about opinion, what takes time (send request to Google - wait for response).

Still from user friendly side it is best to use strategy which trust Google. It is because not all users can have set their default language, or sometimes users set it, but also know forum language and write in forum language - in that case vBET will opaque in language point by user default language. So you can have post in English but marked as French, because user set it as his default language.

If you want to use option trust user - we strongly recommend to force user to set his default language. You can do it very easy - it is configurable in vBET. So vBET can redirect to user profile page if user didn't set his default language. For some users this can be not too convenient, but redirection will stop after user default language is set. You can even choose do you want redirect users only just after login, or again and again until the parameter is set (then user is no able to do anything on your forum until his default language is set).

So as you see vBET is highly configurable and prepared for different scenarios. It is your choice which strategy you want to use :)

Simon Lloyd
07-10-10, 10:11
Michal, thanks for the response, i already have the "Force user.." set and the user had set his default language to Polish on registration AND he posted in polish so i don't understand why the title should not have translated?

I don't really want to downgrade performance and wait for google as sometimes the forum waits for goole custom search to be loaded, waiting for post translation would be bad!

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translations made by vB Enterprise Translator 4.9.2