PDA

View Full Version : Solved SEO issue



Gaming Perfection
02-10-10, 18:14
Hi,

I'm having an issue with getting the correct paths for when I enable the SEO option "Create URL's according to SEO link consensus (i.e. '/en/address')". I don't have vBSEO installed and am running vB Suite, with my home page being site.com and my forum at site.com/forum.

With the "Forum directory" option left blank the following occurs;
On site.com, successful translation to site.com/lang but when trying to go to the forum it goes to site.com/lang/forum.php, which returns a 404 error.
On site.com/forum, successful translation to site.com/forum/lang but the translation is lost when returning to site.com.

With the "Forum directory" set to /forum the following occurs;
On site.com, translation tries to go to site.com/forum/lang, which returns a 404 error.
On site.com/forum, translation goes to site.com/forum/lang/forum.php, which returns a 404 error.

In the default vB settings of "Site Name / URL / Contact Details", my forum URL is set to site.com/forum and my homepage to site.com

My .htaccess file is;

##Translation Mod Stuff##

RewriteEngine On

RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/archive/index.php/(.*)?$ archive/index.php?/$2&language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ index.php?language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ $2?language=$1 [QSA]

I'm sure it's a setting I've configured wrong somewhere, but can't figure out where. Any ideas?

EDIT: Disabled SEO for now as I'm running into a few other issues with it.

vBET
02-10-10, 22:52
Checking in. Will give answer in few minutes :)

vBET
02-10-10, 23:02
OK so. Your forum uses sub directory in URL. That is why you have to made special integration steps to be able to translate pages outside the forum (any URL outside forum directory is not catch by .htaccess rules for vBET).

So first - please set everything right for SEO links in forum. For a moment please forget about other places and set it right just for forum pages. It is the base. Without forum working fine you cannot make the rest working. As I saw at this moment you have SEO disabled, so please enable it again. And set vBET rules in .htaccess file which is INSIDE of forum directory.

Next part is to integrate pages outside forum directory. Please fallow those steps: http://www.vbenterprisetranslator.com/forum/vbet4-troubleshooting/413-faq-2.html#post1546
Please note that you will NOT made any changes in already working .htacces for forum directory. Read instructions carefully - those are about .htaccess for site root directory.

If you have any issues with 1st or 2nd part - please write :)

Gaming Perfection
02-10-10, 23:15
Ah, I didn't realise I needed a .htaccess in both my home directory and forum sub-directory. I've managed to get it working now, thanks for the help:).

************

For anyone else that has the same problem and stumbles across this thread...

RewriteEngine On
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ index.php?language=$1&vbet_outside=true [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ $2?language=$1&vbet_outside=true [L,QSA]



RewriteEngine On
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/archive/index.php/(.*)?$ archive/index.php?/$2&language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/$ index.php?language=$1 [L,QSA]
RewriteRule ^/?(af|sq|ar|be|bg|ca|zh-CN|hr|cs|da|nl|en|et|tl|fi|fr|gl|de|el|iw|hi|hu|is|id|ga|it|ja|ko|lv|lt|mk|ms|mt|no|fa|pl|pt|ro|ru|sr|sk|sl|es|sw|sv|zh-TW|th|tr|uk|vi|cy|yi)/(.*)?$ $2?language=$1 [QSA]

vBET
02-10-10, 23:21
Glad you can enjoy vBET! :)

AfrikaansAlbanianArabicBelarusianBulgarianCatalanChineseCroatianCzechDanishDutchEnglishEstonianFilipinoFinnishFrenchGalicianGermanGreekHaitian CreoleHebrewHindiHungarianIcelandicIndonesianIrishItalianJapaneseKoreanLatvianLithuanianMacedonianMalayMalteseNorwegianPersianPolishPortugueseRomanianRussianSerbianSlovakSlovenianSpanishSwahiliSwedishTaiwaneseThaiTurkishUkrainianVietnameseWelshYiddish
Translated to other languages thanks to vBET Translator 4.9.2